Loading ...
Sorry, an error occurred while loading the content.

Re: Test result: problem rsync from slugosbe optware unstable feed AS WELL AS na

Expand Messages
  • Brian Zhou
    Sounds like this thread: http://www.mail-archive.com/rsync@lists.samba.org/msg17520.html Not sure whether we need to fix it. -Brian ... working. Saw ...
    Message 1 of 4 , Dec 31, 2006
    • 0 Attachment
      Sounds like this thread:

      http://www.mail-archive.com/rsync@.../msg17520.html

      Not sure whether we need to fix it.

      -Brian

      --- In nslu2-linux@yahoogroups.com, "CN" <t4chacko@...> wrote:
      >
      > Brian Zhao, Rod Whitby,
      >
      > I was testing the slugosbe optware unstable feed. Many pkgs are
      working. Saw
      > the following problem with rsync pkg. ipkg-opt install worked fine:
      >
      > #/opt/bin/rsync --version
      > rsync version 2.6.9 protocol version 29
      >
      > When using this rsync, there are errors of every symbolic link copy
      of the form:
      > rsync: failed to set times on "/media/sda3/bin/echo": Function not
      implemented
      > (38)
      >
      > Now, I tried the same version rsync from the unSlung feed, under
      slugos/be. It
      > does NOT show this error!
      >
      > The latest native version for slugos/be of rsync is 2.6.8.
      Interestingly, that
      > version also is showing the same error!! So something is not right
      in the normal
      > build process of the native feed, as well as in Brian's new
      slugosbe feed build.
      > Same error.
      >
      > rsync options used in the test: -a --delete -v --stats --progress
      >
      > If you need any more information please ask.
      >
      > Cordially, Chacko
      >
    • CN
      Brian, First, the premise of that thread you gave below is wrong, at least in our context. As I described in my msg below, I do not get the error msg when I
      Message 2 of 4 , Jan 1, 2007
      • 0 Attachment
        Brian,

        First, the premise of that thread you gave below is wrong, at least in our context. As I described in my msg below, I do not get the error msg when I use the rsync (same version) built for unSlung as is in SlugOS/BE. Further more,

        I am using ext3 (not ext2),
        Mine is not an external file system (just copy from one partition to another)
        I have no samba

        Note: the error is NOT specific to your cross build of optware for slugosbe. The same error is also there in the native rsync available for SlubOS/BE.

        Cordially, Chacko

        On Mon, 01 Jan 2007 05:49:27 -0000, Brian Zhou wrote:

        > Sounds like this thread:
        >
        > http://www.mail-archive.com/rsync@.../msg17520.html
        >
        > Not sure whether we need to fix it.
        >
        > -Brian
        >
        > --- In nslu2-linux@yahoogroups.com, "CN" <t4chacko@...> wrote:
        > >
        > > Brian Zhao, Rod Whitby,
        > >
        > > I was testing the slugosbe optware unstable feed. Many pkgs are
        > working. Saw
        > > the following problem with rsync pkg. ipkg-opt install worked fine:
        > >
        > > #/opt/bin/rsync --version
        > > rsync version 2.6.9 protocol version 29
        > >
        > > When using this rsync, there are errors of every symbolic link copy
        > of the form:
        > > rsync: failed to set times on "/media/sda3/bin/echo": Function not
        > implemented
        > > (38)
        > >
        > > Now, I tried the same version rsync from the unSlung feed, under
        > slugos/be. It
        > > does NOT show this error!
        > >
        > > The latest native version for slugos/be of rsync is 2.6.8.
        > Interestingly, that
        > > version also is showing the same error!! So something is not right
        > in the normal
        > > build process of the native feed, as well as in Brian's new
        > slugosbe feed build.
        > > Same error.
        > >
        > > rsync options used in the test: -a --delete -v --stats --progress
        > >
        > > If you need any more information please ask.
        > >
        > > Cordially, Chacko
        > >
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        > <*> To visit your group on the web, go to:
        > http://groups.yahoo.com/group/nslu2-linux/
        >
        > <*> Your email settings:
        > Individual Email | Traditional
        >
        > <*> To change settings online go to:
        > http://groups.yahoo.com/group/nslu2-linux/join
        > (Yahoo! ID required)
        >
        > <*> To change settings via email:
        > mailto:nslu2-linux-digest@yahoogroups.com
        > mailto:nslu2-linux-fullfeatured@yahoogroups.com
        >
        > <*> To unsubscribe from this group, send an email to:
        > nslu2-linux-unsubscribe@yahoogroups.com
        >
        > <*> Your use of Yahoo! Groups is subject to:
        > http://docs.yahoo.com/info/terms/
        >

      • Brian Zhou
        The latest optware rsync_2.6.9-2_armeb.ipk solved the problem, it is based on the last two posts in the thread I provided. The error message is superfluous and
        Message 3 of 4 , Jan 1, 2007
        • 0 Attachment
          The latest optware rsync_2.6.9-2_armeb.ipk solved the problem, it is
          based on the last two posts in the thread I provided. The error
          message is superfluous and harmless.

          Also, please don't refer the openslug package feed as native. It is
          already quite confusing, I don't want to confuse more people.

          BTW, my last name is Zhou.

          -Brian

          --- In nslu2-linux@yahoogroups.com, "CN" <t4chacko@...> wrote:
          >
          > Brian,
          >
          > First, the premise of that thread you gave below is wrong, at least
          in our
          > context. As I described in my msg below, I do not get the error msg
          when I
          > use the rsync (same version) built for unSlung as is in SlugOS/BE.
          Further
          > more,
          >
          > I am using ext3 (not ext2),
          > Mine is not an external file system (just copy from one partition
          to another)
          > I have no samba
          >
          > Note: the error is NOT specific to your cross build of optware for
          slugosbe.
          > The same error is also there in the native rsync available for
          SlubOS/BE.
          >
          > Cordially, Chacko
          >
          > On Mon, 01 Jan 2007 05:49:27 -0000, Brian Zhou wrote:
          >
          > > Sounds like this thread:
          > >
          > > http://www.mail-archive.com/rsync@.../msg17520.html
          > >
          > > Not sure whether we need to fix it.
          > >
          > > -Brian
          > >
          > > --- In nslu2-linux@yahoogroups.com, "CN" <t4chacko@> wrote:
          > > >
          > > > Brian Zhao, Rod Whitby,
          > > >
          > > > I was testing the slugosbe optware unstable feed. Many pkgs are
          > > working. Saw
          > > > the following problem with rsync pkg. ipkg-opt install worked fine:
          > > >
          > > > #/opt/bin/rsync --version
          > > > rsync version 2.6.9 protocol version 29
          > > >
          > > > When using this rsync, there are errors of every symbolic link copy
          > > of the form:
          > > > rsync: failed to set times on "/media/sda3/bin/echo": Function not
          > > implemented
          > > > (38)
          > > >
          > > > Now, I tried the same version rsync from the unSlung feed, under
          > > slugos/be. It
          > > > does NOT show this error!
          > > >
          > > > The latest native version for slugos/be of rsync is 2.6.8.
          > > Interestingly, that
          > > > version also is showing the same error!! So something is not right
          > > in the normal
          > > > build process of the native feed, as well as in Brian's new
          > > slugosbe feed build.
          > > > Same error.
          > > >
          > > > rsync options used in the test: -a --delete -v --stats --progress
          > > >
          > > > If you need any more information please ask.
          > > >
          > > > Cordially, Chacko
          > > >
          > >
          > >
          > >
          > >
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          >
        • CN
          ... That is good news! Yes, the error msg was there when there was no error. But it was not quite harmless: the script using it gets an error code and so it
          Message 4 of 4 , Jan 1, 2007
          • 0 Attachment
            On Mon, 01 Jan 2007 18:48:55 -0000, Brian Zhou wrote:

            > The latest optware rsync_2.6.9-2_armeb.ipk solved the problem, it is
            > based on the last two posts in the thread I provided. The error
            > message is superfluous and harmless.

            That is good news! Yes, the error msg was there when there was no error. But
            it was not quite harmless: the script using it gets an error code and so it wont
            proceed :( Also it was spewing out large quantities of those msgs, on big disk to
            disk copies where only a brief summary of the operation was normally present at
            the end of the script.

            > Also, please don't refer the openslug package feed as native. It is
            > already quite confusing, I don't want to confuse more people.

            I thought openslug was an old name, we no longer are using to reduce confusion


            > BTW, my last name is Zhou.

            Sorry about that, thanks for pointing it out.

            Cordially, Chacko
          Your message has been successfully submitted and would be delivered to recipients shortly.