Loading ...
Sorry, an error occurred while loading the content.
 

Re: CUPS Prints via cat and lpr -o raw, but not using ipp

Expand Messages
  • d0nv
    CUPS printing using ipp is now working for me (and works great, BTW!). What made the difference is unclear... there are two possibilities based on changes that
    Message 1 of 2 , Nov 30, 2006
      CUPS printing using ipp is now working for me (and works great, BTW!).

      What made the difference is unclear... there are two possibilities
      based on changes that were made concurrently. I'm not comfortable
      trying to backtrack on them to isolate what did it, given the time
      invested to date and the fact that things are working now, but I
      thought I'd pass on the info in case it helps someone following after me.

      I was in the situation I relate below - there were no changes made
      directly to the cupsd.conf file by me. I took only the following two
      actions from there:

      1) Set up a printer class via the CUPS Admin web form, containing the
      printer "hp990c" (this was a CUPS and Windows printing interaction
      trick I'd found via Google)
      2) Used the CUPS Admin web page to select "Save debugging information
      for troubleshooting" and clicked on "Change Settings"

      To my joy, after the above my Windows boxes could now see the printer
      and ipp jobs printed! It didn't matter whether I used
      .../printers/... or .../classes/... in the URI.

      In checking to see what the cupsd.conf file now looked like (ie: what
      made all the difference), I noted the CUPS admin page appears to have
      *significantly* altered the content of the configuration file. In
      essence, it appears as if a totally different set of content showed up
      (which just happened to work)!

      I believe I've uncovered some unexpected behavior with the CUPS
      administration tool (web interface) and what seems to be "extra"
      cupsd.conf files in the default ipkg install. The cupsd.conf files in
      the directory are currently:

      # ls -l /opt/etc/cups/cupsd.*
      -rw-r----- 1 root lp 1892 Nov 29 18:54 /opt/etc/cups/cupsd.conf
      -rw-r----- 1 root lp 2763 Nov 28 01:59 /opt/etc/cups/cupsd.conf.O
      -rw-r----- 1 root root 2375 Sep 30 13:47 /opt/etc/cups/cupsd.conf.default
      -rw------- 1 root root 1777 Nov 26 00:00 /opt/etc/cups/cupsd.conf.wtf
      -rw------- 1 root root 22102 Nov 27 21:49 /opt/etc/cups/cupsd.conf_061127
      -rw------- 1 root root 21984 Nov 25 13:10 /opt/etc/cups/cupsd.conf_bkup
      -rw------- 1 root root 1891 Nov 29 18:54 /opt/etc/cups/cupsd.conf_works
      #

      Note the size of the oldest file as compared to the current version.
      The cupsd.conf_bkup is a copy of the original cupsd.conf file from the
      install. I actually ran into this "replaced file content" behavior
      previously when using the web interface to change settings (note the
      cupsd.conf.wtf file) and had backed it out by copying back an earlier
      version to continue editing with vi. Is it possible the admin web
      interface is writing a totally new cupsd.conf.default when the options
      are selected from the web page? If so, it is lucky for me - as that
      apparently works much better than the "cupsd.conf" that is originally
      inserted on install.

      Copy of the currently working cupsd.conf file content follows. Note
      that I have not performed the samba/CUPS integration, I am just using
      ipp at this point.

      # Show general information in error_log.
      LogLevel debug
      SystemGroup sys root
      # Allow remote access
      Port 631
      Listen /opt/var/run/cups/cups.sock
      # Enable printer sharing and shared printers.
      Browsing On
      BrowseOrder allow,deny
      BrowseAllow @LOCAL
      BrowseAddress @LOCAL
      DefaultAuthType Basic
      <Location />
      # Allow shared printing and remote administration...
      Order allow,deny
      Allow @LOCAL
      </Location>
      <Location /admin>
      Encryption Required
      # Allow remote administration...
      Order allow,deny
      Allow @LOCAL
      </Location>
      <Location /printers>
      AuthType None
      Order Deny,Allow
      Deny From None
      Allow From All
      </Location>
      <Location /admin/conf>
      AuthType Basic
      Require user @SYSTEM
      # Allow remote access to the configuration files...
      Order allow,deny
      Allow @LOCAL
      </Location>
      <Policy default>
      <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job
      Purge-Jobs Set-Job-Attributes Create-Job-Subscription
      Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job
      Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
      Require user @OWNER @SYSTEM
      Order deny,allow
      </Limit>
      <Limit Pause-Printer Resume-Printer Set-Printer-Attributes
      Enable-Printer Disable-Printer Pause-Printer-After-Current-Job
      Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer
      Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer
      Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer
      CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs
      CUPS-Set-Default>
      AuthType Basic
      Require user @SYSTEM
      Order deny,allow
      </Limit>
      <Limit CUPS-Authenticate-Job>
      Require user @OWNER @SYSTEM
      Order deny,allow
      </Limit>
      # Only the owner or an administrator can cancel a job...
      <Limit Cancel-Job>
      Order deny,allow
      Require user @OWNER @SYSTEM
      </Limit>
      <Limit All>
      Order deny,allow
      </Limit>
      </Policy>


      --- In nslu2-linux@yahoogroups.com, "d0nv" <nslu2-yahoo@...> wrote:
      >
      > Hi,
      >
      > Been working this for several nights... now have it to the stage that
      > my printer is seen, and can print using the subject methods. However,
      > every time I try to use the http://server_name:631/printers/hp990c
      > approach to set up to print from Windows XP, the wizard reports not
      > being able to connect to the printer.
      >
      > Interestingly enough, I was working in Knoppix earlier (to copy over
      > the files to the disk to print using the cat and lpr approaches) and
      > the printer *did show in the printer admin tool there* (but the window
      > would hang constantly if I tried to do anything with it). It was
      > reported as an ipp: printer too.
      >
      > Smells like some setting issue somewhere, but I can't find it... what
      > little hair I still have is being pulled out. I know where every
      > setting is in cupsd.conf ;-). I've read and googled and experimented
      > but no fix yet.
      >
      > If anyone would be willing to share a *working* cupsd.conf file with
      > me, I'd very much appreciate it. My latest is copied below.
      >
      > Thanks,
      > Don
      >
      > #
      > # "$Id: cupsd.conf.in 5454 2006-04-23 21:46:38Z mike $"
      > #
      > # Sample configuration file for the Common UNIX Printing System (CUPS)
      > # scheduler. See "man cupsd.conf" for a complete description of this
      > # file.
      > #
      >
      > # Log general information in error_log - change "info" to "debug" for
      > # troubleshooting...
      > LogLevel info
      >
      > # Administrator user group...
      > SystemGroup sys root
      >
      > # Only listen for connections from the local machine.
      > Listen localhost:631
      > Listen /opt/var/run/cups/cups.sock
      > # added by donv
      > Listen 192.168.15.77:631
      >
      > # Show shared printers on the local network.
      > Browsing On
      > BrowseOrder allow,deny
      > # BrowseAllow @LOCAL
      > BrowseAllow All
      >
      > # Default authentication type, when authentication is required...
      > DefaultAuthType Basic
      >
      > # Restrict access to the server...
      > <Location />
      > Order allow,deny
      > Allow localhost
      > # added by donv
      > Allow From 192.168.15.*
      > </Location>
      >
      > # Restrict access to the admin pages...
      > <Location /admin>
      > Encryption Required
      > Order allow,deny
      > Allow localhost
      > # added by donv
      > Allow From 192.168.15.*
      > </Location>
      >
      > # added by donv
      > # This was missing in the default file...
      > <Location /printers>
      > AuthType None
      > Order Deny,Allow
      > Deny From None
      > Allow From All
      > # try this later... Allow From 192.168.15.*
      > </Location>
      >
      > # Restrict access to configuration files...
      > <Location /admin/conf>
      > AuthType Basic
      > Require user @SYSTEM
      > Order allow,deny
      > Allow localhost
      > # added by donv
      > Allow From 192.168.15.*
      > </Location>
      >
      > # Set the default printer/job policies...
      > <Policy default>
      > # Job-related operations must be done by the owner or an
      adminstrator...
      > <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job
      > Purge-Jobs Set-Job-Attributes Create-Job-Subscription
      > Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job
      > Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
      > Require user @OWNER @SYSTEM
      > Order deny,allow
      > </Limit>
      >
      > # All administration operations require an adminstrator to
      > authenticate...
      > <Limit Pause-Printer Resume-Printer Set-Printer-Attributes
      > Enable-Printer Disable-Printer Pause-Printer-After-Current-Job
      > Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer
      > Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer
      > Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer
      > CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs
      > CUPS-Set-Default>
      > AuthType Basic
      > Require user @SYSTEM
      > Order deny,allow
      > </Limit>
      >
      > # Only the owner or an administrator can cancel or authenticate a
      job...
      > <Limit Cancel-Job CUPS-Authenticate-Job>
      > Require user @OWNER @SYSTEM
      > Order deny,allow
      > </Limit>
      >
      > <Limit All>
      > Order deny,allow
      > </Limit>
      > </Policy>
      >
      > #
      > # End of "$Id: cupsd.conf.in 5454 2006-04-23 21:46:38Z mike $".
      > #
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.