Loading ...
Sorry, an error occurred while loading the content.
 

IPKG stopped working?

Expand Messages
  • dvbellamy
    I m running uNSLUng 5.5 on my Slug, which I use solely to run Ron Pedde s mt-daapd music server. It has run perfectly for several months now, but I have just
    Message 1 of 8 , Nov 28, 2006
      I'm running uNSLUng 5.5 on my Slug, which I use solely to run Ron
      Pedde's mt-daapd music server.

      It has run perfectly for several months now, but I have just tried
      doing an "IPKG Update" and I get the following errors:

      # ipkg update
      Downloading http://ipkg.nslu2-
      linux.org/feeds/unslung/cross/Packages.gz
      wget: No such file or directory
      Downloading http://ipkg.nslu2-
      linux.org/feeds/unslung/native/Packages.gz
      wget: No such file or directory
      Downloading http://ipkg.nslu2-linux.org/feeds/unslung/oe/Packages.gz
      wget: No such file or directory
      Downloading http://ipkg.nslu2-
      linux.org/feeds/unslung/cross/Packages.gz
      wget: No such file or directory
      Downloading http://ipkg.nslu2-
      linux.org/feeds/unslung/native/Packages.gz
      wget: No such file or directory
      An error ocurred, return value: 5.
      Collected errors:
      ipkg_download: ERROR: Command failed with return value 127: `wget --
      passive-ftp
      -q -P /tmp/ipkg-oA2vpn http://ipkg.nslu2-
      linux.org/feeds/unslung/cross/Packag
      es.gz'
      ipkg_download: ERROR: Command failed with return value 127: `wget --
      passive-ftp
      -q -P /tmp/ipkg-oA2vpn http://ipkg.nslu2-
      linux.org/feeds/unslung/native/Packa
      ges.gz'
      ipkg_download: ERROR: Command failed with return value 127: `wget --
      passive-ftp
      -q -P /tmp/ipkg-oA2vpn http://ipkg.nslu2-
      linux.org/feeds/unslung/oe/Packages.
      gz'
      ipkg_download: ERROR: Command failed with return value 127: `wget --
      passive-ftp
      -q -P /tmp/ipkg-oA2vpn http://ipkg.nslu2-
      linux.org/feeds/unslung/cross/Packag
      es.gz'
      ipkg_download: ERROR: Command failed with return value 127: `wget --
      passive-ftp
      -q -P /tmp/ipkg-oA2vpn http://ipkg.nslu2-
      linux.org/feeds/unslung/native/Packa
      ges.gz'
      #

      IPKG Install <whatever> gives similar results. I can successfully
      ping any website I choose, so internet access is not the issue.

      One thing I thought suspicious was the "wget: No such file or
      directory" errors above. That is the same as the errors I get when
      trying to run Nano to edit text files. Nano has never worked, but
      IPKG has never shown any problems.

      To the best of my knowledge, I haven't changed anything.
      Please be kind - I'm a bit of a novice at this.
      Thanks in advance for any insight.
      Dave
    • Robert Hammond
      In message , dvbellamy writes ... Strange here because some months ago I had a similar problem
      Message 2 of 8 , Nov 28, 2006
        In message <eki3d9+njmj@...>, dvbellamy
        <dave.bellamy1@...> writes
        >I'm running uNSLUng 5.5 on my Slug, which I use solely to run Ron
        >Pedde's mt-daapd music server.
        >
        >It has run perfectly for several months now, but I have just tried
        >doing an "IPKG Update" and I get the following errors:
        >
        <Snip>

        Strange here because some months ago I had a similar problem when using
        the ipkg web front end.

        At that time I checked my machine for the wget program file using the
        command

        find / -name 'wget'

        I think for the file command to work you may need to have the find
        optware package loaded. So you may have to go searching manually for
        wget, look in /bin first followed by /opt/bin.

        I found the working copy in /opt/bin. So obviously there was some sort
        of path problem with my setup, perhaps introduced by a miss configured
        optware package.

        If you type - set - it should display your PATH setting. The folder
        where wget resides needs to be in one of the path folders to work
        correctly.

        With my setup I decided to I created a sim link to the wget program in
        the folder /bin, this folder should always be in your path.

        Suggest that you also check where your wget program is located as part
        of your investigation.

        If you need to create a sim link in /bin then :-

        Log in as root
        ln -s /opt/bin/wget /bin/wget
        chmod 0777 /bin/wget

        --
        Robert Hammond
        PGP:0x154144DA
      • Adam Baker
        ... The version of wget in /opt/bin isn t the one that ipkg expects to be using. There should be a symbolic link /usr/bin/wget to ../../bin/slingbox. slingbox
        Message 3 of 8 , Nov 29, 2006
          Robert Hammond <rob.hammond@...> writes:


          > I think for the file command to work you may need to have the find
          > optware package loaded. So you may have to go searching manually for
          > wget, look in /bin first followed by /opt/bin.
          > I found the working copy in /opt/bin. So obviously there was some sort
          > of path problem with my setup, perhaps introduced by a miss configured
          > optware package.
          > If you type - set - it should display your PATH setting. The folder
          > where wget resides needs to be in one of the path folders to work
          > correctly.
          > With my setup I decided to I created a sim link to the wget program in
          > the folder /bin, this folder should always be in your path.
          > Suggest that you also check where your wget program is located as part
          > of your investigation.


          The version of wget in /opt/bin isn't the one that ipkg expects to be using.
          There should be a symbolic link /usr/bin/wget to ../../bin/slingbox. slingbox is
          actually a version of busybox optimised to provide the features that are missing
          from the stock linksys busybox that are required for unslung. The version of
          wget in /opt/bin (if it exists) is a package which could get uninstalled.
        • Robert Hammond
          In message , Adam Baker writes ... Many thank for this, I have now created this sym link and
          Message 4 of 8 , Nov 29, 2006
            In message <loom.20061129T221634-242@...>, Adam Baker
            <slug@...> writes
            >Robert Hammond <rob.hammond@...> writes:
            >
            >
            >> I think for the file command to work you may need to have the find
            >> optware package loaded. So you may have to go searching manually for
            >> wget, look in /bin first followed by /opt/bin.
            >> I found the working copy in /opt/bin. So obviously there was some sort
            >> of path problem with my setup, perhaps introduced by a miss configured
            >> optware package.
            >> If you type - set - it should display your PATH setting. The folder
            >> where wget resides needs to be in one of the path folders to work
            >> correctly.
            >> With my setup I decided to I created a sim link to the wget program in
            >> the folder /bin, this folder should always be in your path.
            >> Suggest that you also check where your wget program is located as part
            >> of your investigation.
            >
            >
            >The version of wget in /opt/bin isn't the one that ipkg expects to be using.
            >There should be a symbolic link /usr/bin/wget to ../../bin/slingbox.
            >slingbox is
            >actually a version of busybox optimised to provide the features that
            >are missing
            >from the stock linksys busybox that are required for unslung. The version of
            >wget in /opt/bin (if it exists) is a package which could get uninstalled.
            >
            Many thank for this, I have now created this sym link and deleted my
            old link.

            But unfortunately this now generates an error when running the command
            ipkg update.
            So there must be a little more too this. Have pasted a shortened
            version of the error log below.

            Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/Packages.gz
            -passive-ftp: applet not found
            ipkg_download: ERROR: Command failed with return value 1: `wget
            --passive-ftp -q -P /tmp/ipkg-0NiLoC http://xxxxx

            --
            Robert Hammond
            PGP:0x154144DA
          • CN
            Please see my yesterday s msg in another thread here with subject: SlugOS/BE ipkg install of apache fails After my SlugOS/BE install, without any of the fixup
            Message 5 of 8 , Nov 29, 2006
              Please see my yesterday's msg in another thread here with subject:
              SlugOS/BE ipkg install of apache fails

              After my SlugOS/BE install, without any of the fixup you did, I was getting this error one pkg. I have not seen this on installing any of the other pkgs I tried. I think you just happened to have 2 problems (possibly unrelated) , and you have corrected one of them :)

              Cordially, Chacko

              On Wed, 29 Nov 2006 21:57:56 +0000, Robert Hammond wrote:

              > In message <loom.20061129T221634-242@...>, Adam Baker
              > <slug@...> writes
              > >Robert Hammond <rob.hammond@...> writes:
              > >
              > >
              > >> I think for the file command to work you may need to have the find
              > >> optware package loaded. So you may have to go searching manually for
              > >> wget, look in /bin first followed by /opt/bin.
              > >> I found the working copy in /opt/bin. So obviously there was some sort
              > >> of path problem with my setup, perhaps introduced by a miss configured
              > >> optware package.
              > >> If you type - set - it should display your PATH setting. The folder
              > >> where wget resides needs to be in one of the path folders to work
              > >> correctly.
              > >> With my setup I decided to I created a sim link to the wget program in
              > >> the folder /bin, this folder should always be in your path.
              > >> Suggest that you also check where your wget program is located as part
              > >> of your investigation.
              > >
              > >
              > >The version of wget in /opt/bin isn't the one that ipkg expects to be using.
              > >There should be a symbolic link /usr/bin/wget to ../../bin/slingbox.
              > >slingbox is
              > >actually a version of busybox optimised to provide the features that
              > >are missing
              > >from the stock linksys busybox that are required for unslung. The version of
              > >wget in /opt/bin (if it exists) is a package which could get uninstalled.
              > >
              > Many thank for this, I have now created this sym link and deleted my
              > old link.
              >
              > But unfortunately this now generates an error when running the command
              > ipkg update.
              > So there must be a little more too this. Have pasted a shortened
              > version of the error log below.
              >
              > Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/Packages.gz
              > -passive-ftp: applet not found
              > ipkg_download: ERROR: Command failed with return value 1: `wget
              > --passive-ftp -q -P /tmp/ipkg-0NiLoC http://xxxxx
              >
              > --
              > Robert Hammond
              > PGP:0x154144DA
              >
              >
              >
              > Yahoo! Groups Links
              >
              > <*> To visit your group on the web, go to:
              > http://groups.yahoo.com/group/nslu2-linux/
              >
              > <*> Your email settings:
              > Individual Email | Traditional
              >
              > <*> To change settings online go to:
              > http://groups.yahoo.com/group/nslu2-linux/join
              > (Yahoo! ID required)
              >
              > <*> To change settings via email:
              > mailto:nslu2-linux-digest@yahoogroups.com
              > mailto:nslu2-linux-fullfeatured@yahoogroups.com
              >
              > <*> To unsubscribe from this group, send an email to:
              > nslu2-linux-unsubscribe@yahoogroups.com
              >
              > <*> Your use of Yahoo! Groups is subject to:
              > http://docs.yahoo.com/info/terms/
              >

            • Robert Hammond
              In message , Robert Hammond writes ... I think that I now know what is happening here. Firstly
              Message 6 of 8 , Nov 29, 2006
                In message <6Ek9TcDkJgbFFwQV@...>, Robert Hammond
                <rob.hammond@...> writes
                >In message <loom.20061129T221634-242@...>, Adam Baker
                ><slug@...> writes
                >>Robert Hammond <rob.hammond@...> writes:
                >>
                >>
                >>> I think for the file command to work you may need to have the find
                >>> optware package loaded. So you may have to go searching manually for
                >>> wget, look in /bin first followed by /opt/bin.
                >>> I found the working copy in /opt/bin. So obviously there was some sort
                >>> of path problem with my setup, perhaps introduced by a miss configured
                >>> optware package.
                >>> If you type - set - it should display your PATH setting. The folder
                >>> where wget resides needs to be in one of the path folders to work
                >>> correctly.
                >>> With my setup I decided to I created a sim link to the wget program in
                >>> the folder /bin, this folder should always be in your path.
                >>> Suggest that you also check where your wget program is located as part
                >>> of your investigation.
                >>
                >>
                >>The version of wget in /opt/bin isn't the one that ipkg expects to be using.
                >>There should be a symbolic link /usr/bin/wget to ../../bin/slingbox.
                >>slingbox is
                >>actually a version of busybox optimised to provide the features that
                >>are missing
                >>from the stock linksys busybox that are required for unslung. The version of
                >>wget in /opt/bin (if it exists) is a package which could get uninstalled.
                >>
                >Many thank for this, I have now created this sym link and deleted my
                >old link.
                >
                >But unfortunately this now generates an error when running the command
                >ipkg update.
                >So there must be a little more too this. Have pasted a shortened
                >version of the error log below.
                >
                >Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/Packages.gz
                >-passive-ftp: applet not found
                >ipkg_download: ERROR: Command failed with return value 1: `wget
                >--passive-ftp -q -P /tmp/ipkg-0NiLoC http://xxxxx
                >
                I think that I now know what is happening here. Firstly slingbox does
                not include the wget command so the sym link above will not work. The
                default wget program gets copied over from flash ram to /usr/bin/wget
                during unslinging.

                It looks as if when you install the optware package 'wget', it deletes
                the older version located in /usr/bin/ so the optware wget installer is
                at fault here.

                This fault is probably common to other optware packages such as 'cpio'
                and 'find' plus some others that install updated versions of standard
                /usr/bin/programs and perhaps /bin/programs.

                A better fix would be for the installers of these packages to :-
                Firstly create a backup of the /opt/bin/ program.
                Then create a sym link in /opt/bin/ to the new version.

                This could then be undone when using the ipkg remove command.

                Some cunning scripting may be needed here so that an update would
                recognise if a previous sym link had been created and not mess up.

                To correct my set up I am going to create a new sym link in /usr/bin to
                the optware version of wget.
                --
                Robert Hammond
                PGP:0x154144DA
              • dvbellamy
                Thanks to everybody for the replies. Sorry I took so long to reply, but I got an email saying this post had not been received, or words to that effect, so I
                Message 7 of 8 , Nov 30, 2006
                  Thanks to everybody for the replies.

                  Sorry I took so long to reply, but I got an email saying this post had
                  not been received, or words to that effect, so I didn't bother
                  checking.

                  Anyway, Robert Hammond's first reply has done the trick. Specifically
                  the:
                  ln -s /opt/bin/wget /bin/wget
                  chmod 0777 /bin/wget

                  ... bit. It's all up and running again now. I can't imagine why it
                  stopped. I don't fiddle with the thing becasue I don't know enough
                  about it.
                  Oh well, cheers Robert.
                • Adam Baker
                  ... The slingbox in Unslung 6.8 definitely does include wget $ /bin/slingbox --help BusyBox v1.00 (2005.12.27-01:15+0000) multi-call binary Usage: busybox
                  Message 8 of 8 , Dec 1, 2006
                    Robert Hammond <rob.hammond@...> writes:


                    > I think that I now know what is happening here. Firstly slingbox does
                    > not include the wget command so the sym link above will not work. The
                    > default wget program gets copied over from flash ram to /usr/bin/wget
                    > during unslinging.

                    The slingbox in Unslung 6.8 definitely does include wget

                    $ /bin/slingbox --help
                    BusyBox v1.00 (2005.12.27-01:15+0000) multi-call binary

                    Usage: busybox [function] [arguments]...
                    or: [function] [arguments]...

                    ...

                    Currently defined functions:
                    ..., unzip,
                    wget, zcat

                    I haven't got an unslug 5.5 box here to check what that did.


                    > It looks as if when you install the optware package 'wget', it deletes
                    > the older version located in /usr/bin/ so the optware wget installer is
                    > at fault here.

                    The wget optware package doesn't include a postinst script so can't be deleting
                    files

                    > This fault is probably common to other optware packages such as 'cpio'
                    > and 'find' plus some others that install updated versions of standard
                    > /usr/bin/programs and perhaps /bin/programs.

                    The standard optware behaviour in all of these cases is to put the new program
                    in /opt/bin and require the user to include /opt/bin ahead of /bin and /usr/bin
                    in their path.

                    It is possible to run optware on a target where /bin and /usr/bin are both on a
                    read only file system (and I've got a box here where I do) so assuming you can
                    create links there isn't a great idea.

                    > To correct my set up I am going to create a new sym link in /usr/bin to
                    > the optware version of wget.
                  Your message has been successfully submitted and would be delivered to recipients shortly.