Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Use ISO-8859-1 instead of CP437/850

Expand Messages
  • Bernhard Walle
    Hello, ... I think you must tweak the Samba configuration. ext2/ext3 doesn t honor any charset setting in filenames, it just writes the bytes you give them.
    Message 1 of 5 , Nov 2, 2006
    • 0 Attachment
      Hello,

      * Mike (mwester) <mwester@...> [2006-11-02 04:58]:
      > Somebody correct me if I'm wrong on this, but I think that ISO-8859-1 is
      > what is used for the native ext-3 formatted drives on the NSLU2. It has
      > language settings on the Admin web gui pages, but AFAIK, those settings are
      > only used when it mounts FAT and NTFS volumes.

      I think you must tweak the Samba configuration. ext2/ext3 doesn't
      honor any charset setting in filenames, it just writes the bytes you
      give them. Samba is translating this for Windows.

      Bernhard
      --
      Unser Zeitalter ist stolz auf Maschinen die denken und mi├čtrauisch gegen
      Menschen, die es versuchen.
      -- (unbekannt)
    • Ted Killmeyer
      What about if you are looking at the files directly from say, a cshell or bash shell prompt? or even through KDE? Ted (haveing a heck of a time getting cyrilic
      Message 2 of 5 , Nov 2, 2006
      • 0 Attachment
        What about if you are looking at the files directly from say, a cshell or bash
        shell prompt? or even through KDE?

        Ted
        (haveing a heck of a time getting cyrilic charaters to display properly)

        ------ Original Message ------
        Received: Thu, 02 Nov 2006 01:53:48 AM MST
        From: Bernhard Walle <Bernhard.Walle@...>
        To: nslu2-linux@yahoogroups.com
        Subject: Re: [nslu2-linux] Use ISO-8859-1 instead of CP437/850

        > Hello,
        >
        > * Mike (mwester) <mwester@...> [2006-11-02 04:58]:
        > > Somebody correct me if I'm wrong on this, but I think that ISO-8859-1 is
        > > what is used for the native ext-3 formatted drives on the NSLU2. It has
        > > language settings on the Admin web gui pages, but AFAIK, those settings
        are
        > > only used when it mounts FAT and NTFS volumes.
        >
        > I think you must tweak the Samba configuration. ext2/ext3 doesn't
        > honor any charset setting in filenames, it just writes the bytes you
        > give them. Samba is translating this for Windows.
        >
        > Bernhard
        > --
        > Unser Zeitalter ist stolz auf Maschinen die denken und mi├čtrauisch gegen
        > Menschen, die es versuchen.
        > -- (unbekannt)
        >

        > ---------------------------------------------
        > Attachment: application/pgp-signature
        > MIME Type: application/pgp-signature
        > ---------------------------------------------
      Your message has been successfully submitted and would be delivered to recipients shortly.