Loading ...
Sorry, an error occurred while loading the content.

Use ISO-8859-1 instead of CP437/850

Expand Messages
  • Stefan Carslöv
    Is there a way to use ISO-8859-1 instead of CP437 in the slug? It got the Unslung firmware v6.8 beta.
    Message 1 of 5 , Nov 1, 2006
    • 0 Attachment
      Is there a way to use ISO-8859-1 instead of CP437 in the slug? It got
      the Unslung firmware v6.8 beta.
    • Mike (mwester)
      Somebody correct me if I m wrong on this, but I think that ISO-8859-1 is what is used for the native ext-3 formatted drives on the NSLU2. It has language
      Message 2 of 5 , Nov 1, 2006
      • 0 Attachment
        Somebody correct me if I'm wrong on this, but I think that ISO-8859-1 is
        what is used for the native ext-3 formatted drives on the NSLU2. It has
        language settings on the Admin web gui pages, but AFAIK, those settings are
        only used when it mounts FAT and NTFS volumes.
        Mike (mwester)

        ----- Original Message -----
        From: "Stefan Carslöv" <fraterodur@...>
        To: <nslu2-linux@yahoogroups.com>
        Sent: Wednesday, November 01, 2006 3:45 PM
        Subject: [nslu2-linux] Use ISO-8859-1 instead of CP437/850


        > Is there a way to use ISO-8859-1 instead of CP437 in the slug? It got
        > the Unslung firmware v6.8 beta.
      • Stefan Carslöv
        OK. My problem is this: My Unslunged (6.8 beta) NSLU2 is used for Samba against a WinXP computer and a Xbox. I ve installed the CP850 kernel module, and I ve
        Message 3 of 5 , Nov 1, 2006
        • 0 Attachment
          OK. My problem is this:
          My Unslunged (6.8 beta) NSLU2 is used for Samba against a WinXP
          computer and a Xbox. I've installed the CP850 kernel module, and I've
          also installed proftpd on it.

          When I create dirs or files on it from the XP computer, the xbox and
          the computer shows the swedish special characters (åäö) correct, but
          not from an ftp client. If I create the same dirs from the ftp client,
          it shows them correctly, but not the XP or the Xbox.

          If i connect through SSH to the with Putty, and tell PuTTY to
          translate the chars to CP850, then it also shows the dirs and files
          created from the computer correct, but the once created from a ftp
          client only displays correctly if I tell PuTTY to translate to ISO-8850-1.

          The smb.conf has the entries:
          unix charset = CP850
          dos charset = CP850

          Which is what I changed it to in the Web admin interface.

          Anyone who has a solution to my problem?

          Kind regards,
          Stefan


          --- In nslu2-linux@yahoogroups.com, "Mike \(mwester\)" <mwester@...>
          wrote:
          >
          > Somebody correct me if I'm wrong on this, but I think that ISO-8859-1 is
          > what is used for the native ext-3 formatted drives on the NSLU2. It has
          > language settings on the Admin web gui pages, but AFAIK, those
          settings are
          > only used when it mounts FAT and NTFS volumes.
          > Mike (mwester)
          >
          > ----- Original Message -----
          > From: "Stefan Carslöv" <fraterodur@...>
          > To: <nslu2-linux@yahoogroups.com>
          > Sent: Wednesday, November 01, 2006 3:45 PM
          > Subject: [nslu2-linux] Use ISO-8859-1 instead of CP437/850
          >
          >
          > > Is there a way to use ISO-8859-1 instead of CP437 in the slug? It got
          > > the Unslung firmware v6.8 beta.
          >
        • Bernhard Walle
          Hello, ... I think you must tweak the Samba configuration. ext2/ext3 doesn t honor any charset setting in filenames, it just writes the bytes you give them.
          Message 4 of 5 , Nov 2, 2006
          • 0 Attachment
            Hello,

            * Mike (mwester) <mwester@...> [2006-11-02 04:58]:
            > Somebody correct me if I'm wrong on this, but I think that ISO-8859-1 is
            > what is used for the native ext-3 formatted drives on the NSLU2. It has
            > language settings on the Admin web gui pages, but AFAIK, those settings are
            > only used when it mounts FAT and NTFS volumes.

            I think you must tweak the Samba configuration. ext2/ext3 doesn't
            honor any charset setting in filenames, it just writes the bytes you
            give them. Samba is translating this for Windows.

            Bernhard
            --
            Unser Zeitalter ist stolz auf Maschinen die denken und mißtrauisch gegen
            Menschen, die es versuchen.
            -- (unbekannt)
          • Ted Killmeyer
            What about if you are looking at the files directly from say, a cshell or bash shell prompt? or even through KDE? Ted (haveing a heck of a time getting cyrilic
            Message 5 of 5 , Nov 2, 2006
            • 0 Attachment
              What about if you are looking at the files directly from say, a cshell or bash
              shell prompt? or even through KDE?

              Ted
              (haveing a heck of a time getting cyrilic charaters to display properly)

              ------ Original Message ------
              Received: Thu, 02 Nov 2006 01:53:48 AM MST
              From: Bernhard Walle <Bernhard.Walle@...>
              To: nslu2-linux@yahoogroups.com
              Subject: Re: [nslu2-linux] Use ISO-8859-1 instead of CP437/850

              > Hello,
              >
              > * Mike (mwester) <mwester@...> [2006-11-02 04:58]:
              > > Somebody correct me if I'm wrong on this, but I think that ISO-8859-1 is
              > > what is used for the native ext-3 formatted drives on the NSLU2. It has
              > > language settings on the Admin web gui pages, but AFAIK, those settings
              are
              > > only used when it mounts FAT and NTFS volumes.
              >
              > I think you must tweak the Samba configuration. ext2/ext3 doesn't
              > honor any charset setting in filenames, it just writes the bytes you
              > give them. Samba is translating this for Windows.
              >
              > Bernhard
              > --
              > Unser Zeitalter ist stolz auf Maschinen die denken und mißtrauisch gegen
              > Menschen, die es versuchen.
              > -- (unbekannt)
              >

              > ---------------------------------------------
              > Attachment: application/pgp-signature
              > MIME Type: application/pgp-signature
              > ---------------------------------------------
            Your message has been successfully submitted and would be delivered to recipients shortly.