Loading ...
Sorry, an error occurred while loading the content.

Q: hang after exec 0x01d00000

Expand Messages
  • nww
    Hi, I am about to test my newly built openslug image. I followed the instructions in http://www.nslu2-linux.org/wiki/HowTo/TestAnImageInRamUsingRedBoot.
    Message 1 of 4 , Oct 1, 2006
    • 0 Attachment
      Hi,

      I am about to test my newly built openslug image. I followed the
      instructions in
      http://www.nslu2-linux.org/wiki/HowTo/TestAnImageInRamUsingRedBoot.
      However, it hang when I performed the last step. Does anyone know why?
      Below are the steps I did.


      == Executing boot script in 1.260 seconds - enter ^C to abort
      Telnet escape character is '~'.
      Trying 192.168.0.1...
      Connected to 192.168.0.1.
      Escape character is '~'.
      RedBoot> ip_address -l 192.168.0.1 -h 192.168.0.2
      IP: 192.168.0.1/255.255.255.0, Gateway: 192.168.0.1
      Default server: 192.168.0.2, DNS server IP: 0.0.0.0
      RedBoot> load -r -v -b 0x01000000 -m http /ramdisk.gz

      /------------------------------------------------------------------------
      Raw file loaded 0x01000000-0x0101fff3, assumed entry at 0x01000000
      RedBoot> cksum

      -------------------------------------------------------------------------------
      Raw file loaded 0x01d00000-0x01df24f7, assumed entry at
      0x01d00000--------------------------------------------------------------------------------------------
      RedBoot>
      cksum------------------------------------------------------------------------------------------------------------------------------------------------
      Computing cksum for area
      0x01d00000-0x01df24f8----------------------------------------------------------------------------------------------------------------
      POSIX cksum = 1864616807 992504 (0x6f23cb67 0x000f24f8)
      RedBoot> exec 0x01d00000
    • nww
      ... /------------------------------------------------------------------------ ...
      Message 2 of 4 , Oct 1, 2006
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, "nww" <csnww97@...> wrote:
        >
        > Hi,
        >
        > I am about to test my newly built openslug image. I followed the
        > instructions in
        > http://www.nslu2-linux.org/wiki/HowTo/TestAnImageInRamUsingRedBoot.
        > However, it hang when I performed the last step. Does anyone know why?
        > Below are the steps I did.
        >
        >
        > == Executing boot script in 1.260 seconds - enter ^C to abort
        > Telnet escape character is '~'.
        > Trying 192.168.0.1...
        > Connected to 192.168.0.1.
        > Escape character is '~'.
        > RedBoot> ip_address -l 192.168.0.1 -h 192.168.0.2
        > IP: 192.168.0.1/255.255.255.0, Gateway: 192.168.0.1
        > Default server: 192.168.0.2, DNS server IP: 0.0.0.0
        > RedBoot> load -r -v -b 0x01000000 -m http /ramdisk.gz
        >
        >
        /------------------------------------------------------------------------
        > Raw file loaded 0x01000000-0x0101fff3, assumed entry at 0x01000000
        > RedBoot> cksum
        >
        >
        > RedBoot> load -r -v -b 0x01d00000 -m http /vmlinuz
        -------------------------------------------------------------------------------
        > Raw file loaded 0x01d00000-0x01df24f7, assumed entry at
        >
        0x01d00000--------------------------------------------------------------------------------------------
        > RedBoot>
        >
        cksum------------------------------------------------------------------------------------------------------------------------------------------------
        > Computing cksum for area
        >
        0x01d00000-0x01df24f8----------------------------------------------------------------------------------------------------------------
        > POSIX cksum = 1864616807 992504 (0x6f23cb67 0x000f24f8)
        > RedBoot> exec 0x01d00000
        >
      • nww
        I am using Fedora4 to built the openslug image. i.e. make openslug-image ... /------------------------------------------------------------------------ ...
        Message 3 of 4 , Oct 1, 2006
        • 0 Attachment
          I am using Fedora4 to built the openslug image.

          i.e. make openslug-image

          --- In nslu2-linux@yahoogroups.com, "nww" <csnww97@...> wrote:
          >
          > Hi,
          >
          > I am about to test my newly built openslug image. I followed the
          > instructions in
          > http://www.nslu2-linux.org/wiki/HowTo/TestAnImageInRamUsingRedBoot.
          > However, it hang when I performed the last step. Does anyone know why?
          > Below are the steps I did.
          >
          >
          > == Executing boot script in 1.260 seconds - enter ^C to abort
          > Telnet escape character is '~'.
          > Trying 192.168.0.1...
          > Connected to 192.168.0.1.
          > Escape character is '~'.
          > RedBoot> ip_address -l 192.168.0.1 -h 192.168.0.2
          > IP: 192.168.0.1/255.255.255.0, Gateway: 192.168.0.1
          > Default server: 192.168.0.2, DNS server IP: 0.0.0.0
          > RedBoot> load -r -v -b 0x01000000 -m http /ramdisk.gz
          >
          >
          /------------------------------------------------------------------------
          > Raw file loaded 0x01000000-0x0101fff3, assumed entry at 0x01000000
          > RedBoot> cksum
          >
          >
          -------------------------------------------------------------------------------
          > Raw file loaded 0x01d00000-0x01df24f7, assumed entry at
          >
          0x01d00000--------------------------------------------------------------------------------------------
          > RedBoot>
          >
          cksum------------------------------------------------------------------------------------------------------------------------------------------------
          > Computing cksum for area
          >
          0x01d00000-0x01df24f8----------------------------------------------------------------------------------------------------------------
          > POSIX cksum = 1864616807 992504 (0x6f23cb67 0x000f24f8)
          > RedBoot> exec 0x01d00000
          >
        • Rod Whitby
          Could be any number of things - if you are testing newly built images then you really should have a serial port attached and be talking to redboot via the
          Message 4 of 4 , Oct 1, 2006
          • 0 Attachment
            Could be any number of things - if you are testing newly built images then you really should have a serial port attached and be talking to redboot via the serial port.
            Note that to load an image into ram via redboot, the FIS directory in the last block of flash must match the image you are trying to load. For example, if you took a stock slug (which has no FIS directory) and tried to load an openslug image into RAM on it (instead of flashing it with the image), then you would be missing the FIS directory and the kernel would not be able to find the jffs2 partition.
            I am continually amazed at the number of people who are adding memory to their slugs as if it's an easy polished user-accessible procedure, and don't have a serial port, and aren't experienced in compiling new kernels and images and tesing them ...
            -- Rod

            -----Original Message-----
            From: "nww" <csnww97@...>
            Date: Monday, Oct 2, 2006 3:48 am
            Subject: [nslu2-linux] Q: hang after exec 0x01d00000

            Hi,

            I am about to test my newly built openslug image. I followed the
            instructions in
            http://www.nslu2-linux.org/wiki/HowTo/TestAnImageInRamUsingRedBoot.
            However, it hang when I performed the last step. Does anyone know why?
            Below are the steps I did.

            == Executing boot script in 1.260 seconds - enter ^C to abort
            Telnet escape character is '~'.
            Trying 192.168.0.1...
            Connected to 192.168.0.1.
            Escape character is '~'.
            RedBoot> ip_address -l 192.168.0.1 -h 192.168.0.2
            IP: 192.168.0.1/255.255.255.0, Gateway: 192.168.0.1
            Default server: 192.168.0.2, DNS server IP: 0.0.0.0
            RedBoot> load -r -v -b 0x01000000 -m http /ramdisk.gz

            /----------------------------------------------------------
            Raw file loaded 0x01000000-0x0101fff3, assumed entry at 0x01000000
            RedBoot> cksum

            ----------------------------------------------------------
            Raw file loaded 0x01d00000-0x01df24f7, assumed entry at
            0x01d00000----------------------------------------------------------
            RedBoot>
            cksum----------------------------------------------------------
            Computing cksum for area
            0x01d00000-0x01df24f8----------------------------------------------------------
            POSIX cksum = 1864616807 992504 (0x6f23cb67 0x000f24f8)
            RedBoot> exec 0x01d00000
          Your message has been successfully submitted and would be delivered to recipients shortly.