Loading ...
Sorry, an error occurred while loading the content.

DebianSlug / Bootstrap - can't install openssh?

Expand Messages
  • Rob Lockhart
    Hello, I am trying again to start from scratch from these instructions: http://www.nslu2-linux.org/wiki/DebianSlug/Bootstrap (I actually am using a slightly
    Message 1 of 4 , Aug 4, 2006
    • 0 Attachment
      Hello,

      I am trying again to start from scratch from these instructions:
      http://www.nslu2-linux.org/wiki/DebianSlug/Bootstrap

      (I actually am using a slightly modified version since I have a "/"
      and "/share" on sda1, sda3 and "/bak" and "/sharebak" on sdb1, sdb3,
      respectively).

      Everything working fine so far, per that page, until I try this:

      "apt-get install openssh-server"

      I get this error message:

      Setting up openssh-server (4.3p2-3) ...
      useradd: invalid numeric argument 'nogroup'
      adduser: `/usr/sbin/useradd -d /var/run/sshd -g nogroup -s
      /usr/sbin/nologin -u 100 sshd' returned error code 3. Exiting.
      dpkg: error processing openssh-server (--configure):
      subprocess post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of ssh:
      ssh depends on openssh-server; however:
      Package openssh-server is not configured yet.
      dpkg: error processing ssh (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      openssh-server
      ssh
      E: Sub-process /usr/bin/dpkg returned an error code (1)

      Note that I have confirmed that in the /etc/groups file has the
      required groupname:

      nogroup:x:65534:

      I even tried grpconv (as per making shadow groups as well) and it does
      create the gshadow file, containing "nogroup":

      root@brokenslug:/etc# cat /etc/gshadow | grep nogroup
      nogroup:*::

      root@brokenslug:/etc# cat /etc/passwd | grep nobody
      nobody:x:65534:65534:nobody:/nonexistent:/bin/sh

      root@brokenslug:/etc# cat /etc/shadow | grep nobody
      nobody:*:13364:0:99999:7:::

      Unless there is something wrong with the preceeding directions, I
      don't know why it wouldn't work, unless there's something wrong with
      the installer or adduser is not acceping non-numeric group names.

      At the very least, seems it's time to update the Wiki! :-)

      Any clues?

      Regards,
      -Rob

      P.S. some places in the Wiki, it specifies to "edit", but that leaves
      it open to interpretation if that means "add", "replace" or if add,
      which order. Specifically:

      "edit /etc/apt/sources.list to point to deb ..."
    • Rob Lockhart
      ... What a pain, but I think I figured out what the problem was. I ran aptitude and deleted openssh-server. Then I did a search of adduser and found a perl
      Message 2 of 4 , Aug 5, 2006
      • 0 Attachment
        On 8/4/06, Rob Lockhart <rlockhar@...> wrote:
        > Hello,
        >
        > I am trying again to start from scratch from these instructions:
        > http://www.nslu2-linux.org/wiki/DebianSlug/Bootstrap
        >
        > Everything working fine so far, per that page, until I try this:
        >
        > "apt-get install openssh-server"
        >
        > I get this error message:
        >
        > Setting up openssh-server (4.3p2-3) ...
        > useradd: invalid numeric argument 'nogroup'
        > adduser: `/usr/sbin/useradd -d /var/run/sshd -g nogroup -s
        > /usr/sbin/nologin -u 100 sshd' returned error code 3. Exiting.
        > dpkg: error processing openssh-server (--configure):
        > subprocess post-installation script returned error exit status 1
        > dpkg: dependency problems prevent configuration of ssh:
        > ssh depends on openssh-server; however:
        > Package openssh-server is not configured yet.
        > dpkg: error processing ssh (--configure):
        > dependency problems - leaving unconfigured
        > Errors were encountered while processing:
        > openssh-server
        > ssh
        > E: Sub-process /usr/bin/dpkg returned an error code (1)

        What a pain, but I think I figured out what the problem was. I ran
        aptitude and deleted openssh-server. Then I did a search of "adduser"
        and found a perl program to do this (perhaps allowing the non-numeric
        fields for "adduser" / useradd) called "adduser-ng". After installing
        that, then re-installing openssh-server, it seems that the
        installation was a success. No errors, and aptitude didn't show any
        problems with the install. Perhaps the dependency list of the
        openssh-server (for at least the arm) needs to be updated by someone
        in the Debian development team?

        Then, after rebooting, indeed ssh was installed and running, as I was
        able to ssh into the DebSlug.

        I'll be sure to update the instructions in the Wiki, after I do a
        clean install just to validate my additions fixed it.
      • emm_is
        ... according to http://article.gmane.org/gmane.linux.debian.devel.bugs.general/122969/match=381394 there was a regression in passwd 4.0.18-1 which has now be
        Message 3 of 4 , Aug 6, 2006
        • 0 Attachment
          > > Everything working fine so far, per that page, until I try this:
          > >
          > > "apt-get install openssh-server"
          > >
          > > I get this error message:

          > > useradd: invalid numeric argument 'nogroup'
          > > adduser: `/usr/sbin/useradd -d /var/run/sshd -g nogroup -s
          > > /usr/sbin/nologin -u 100 sshd' returned error code 3. Exiting.


          according to
          http://article.gmane.org/gmane.linux.debian.devel.bugs.general/122969/match=381394
          there was a regression in passwd 4.0.18-1 which has now be updated to
          4.0.18.1-1 and now seems to work fine.
        • Rob Lockhart
          ... Yes, I had problems with that too, until I installed the adduser-ng module. Then I could install openssh-server. Before then, I got the same message. In
          Message 4 of 4 , Aug 6, 2006
          • 0 Attachment
            On 8/6/06, emm_is <emm_is@...> wrote:
            >
            >
            > Everything working fine so far, per that page, until I try this:
            >
            > "apt-get install openssh-server"
            >
            > I get this error message:
            >
            > useradd: invalid numeric argument 'nogroup'
            > adduser: `/usr/sbin/useradd -d /var/run/sshd -g nogroup -s
            > /usr/sbin/nologin -u 100 sshd' returned error code 3. Exiting.
            >
            >
            > according to
            > http://article.gmane.org/gmane.linux.debian.devel.bugs.general/122969/match=381394
            > there was a regression in passwd 4.0.18-1 which has now be updated to
            > 4.0.18.1-1 and now seems to work fine.
            >

            Yes, I had problems with that too, until I installed the adduser-ng
            module. Then I could install openssh-server. Before then, I got the
            same message. In fact, you probably missed my post about this just
            Friday.

            It was only when I ran "aptitude" that I was able to see the entire
            reason for the failure, and an alternative for adduser (which worked).

            Now that my DebianSlug is up again (I switched to newer Seagate HDs),
            I doubt I'll be able to reinstall, except to perhaps a portable USB
            drive just as a test. Unless something was changed in regards to the
            passwd program as you said, maybe it was just a coincidence that it
            now works?

            Regards,
            -Rob
          Your message has been successfully submitted and would be delivered to recipients shortly.