Loading ...
Sorry, an error occurred while loading the content.

Warning: ixp400_eth ethernet driver not found, not included on image

Expand Messages
  • rounin_urashima
    Hi, ... apt-get install nslu2-utils Reading package lists... Done Building dependency tree... Done The following extra packages will be installed: devio The
    Message 1 of 1 , Jun 1, 2006
    • 0 Attachment
      Hi,
      I did the following:
      --------------------------------------------------------
      apt-get install nslu2-utils

      Reading package lists... Done
      Building dependency tree... Done
      The following extra packages will be installed:
      devio
      The following NEW packages will be installed:
      devio nslu2-utils
      0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
      Need to get 28.7kB of archives.
      After unpacking 250kB of additional disk space will be used.
      Do you want to continue [Y/n]? Y
      Get:1 http://ftp.uk.debian.org etch/main devio 1.2-1 [16.7kB]
      Get:2 http://ftp.uk.debian.org etch/main nslu2-utils 0.10+r58-2
      [12.0kB]
      Fetched 28.7kB in 1s (16.0kB/s)
      Selecting previously deselected package devio.
      (Reading database ... 20324 files and directories currently
      installed.)
      Unpacking devio (from .../archives/devio_1.2-1_arm.deb) ...
      Selecting previously deselected package nslu2-utils.
      Unpacking nslu2-utils (from .../nslu2-utils_0.10+r58-2_arm.deb) ...
      Setting up devio (1.2-1) ...
      Setting up nslu2-utils (0.10+r58-2) ...
      Warning: ixp400_eth ethernet driver not found, not included on image
      Error: This system has the ixp400_eth module loaded;
      not creating initramfs image that does not contain the module.

      To force creation of an image without the module, set
      NSLU2_IXP400_REQUIRED=false in /etc/mkinitramfs/initramfs.conf

      dpkg: error processing nslu2-utils (--configure):
      subprocess post-installation script returned error exit status 1
      Errors were encountered while processing:
      nslu2-utils
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      --------------------------------------------------------
      I took a look at this to get it working:

      http://www.linuxquestions.org/questions/showthread.php?t=431862

      ---------------------------------------------------------
      install package yaird and then do the following:

      rm /boot/initrd.img-2.6.15-1-686(you should give yours here)


      yaird -v-o /boot/initrd.img-2.6.15-1-686 2.6-15-1-686

      then boot with your new kernel

      replace -1-686 with yours
      ---------------------------------------------------------

      ls -alrt /boot
      total 9532
      21 root root 4096 Jan 1 1970 ..
      1 root root 22 Jan 1 1970 vmlinuz -> vmlinuz-2.6.15-1-nslu2
      1 root root 25 Jan 1 1970 initrd.img -> initrd.img-2.6.15-1-
      nslu2
      1 root root 2976309 Jan 1 1970 initrd.img-2.6.15-1-nslu2_orig
      1 root root 2976309 Jan 1 1970 initrd.img-2.6.15-1-nslu2
      1 root root 34802 Mar 6 12:52 config-2.6.15-1-nslu2
      1 root root 1017964 Mar 7 17:47 vmlinuz-2.6.15-1-nslu2
      1 root root 531893 Mar 7 17:50 System.map-2.6.15-1-nslu2
      1 root root 1064960 Jun 1 23:23 initrd.img-2.6.15-1-nslu2_old
      1 root root 1117376 Jun 1 23:29 initrd.img-2.6.15-1-nslu2_new
      2 root root 4096 Jun 1 23:39 .

      --------------------------------------------------------------
      It seems the debian slug version is larger, than what yaird created.

      I managed to copy an initrd.img-2.6.15-1-nslu2 file from my other
      nslu2, will it still work and boot up properly?
      I'm scared of rebooting the machine now...
      Hope someone can help out.
      Thanks,
      ROuNIN
    Your message has been successfully submitted and would be delivered to recipients shortly.