Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Disk administration shut - "incorrect username or password" with Unslung 6.8

Expand Messages
  • Mike (mwester)
    ... Did you reboot, with no disks attached, after removing the USB stick? Whenever I have observed such a problem (the device being confused about which pages
    Message 1 of 6 , May 2, 2006
    • 0 Attachment
      > After removing the USB stick
      > I can reach the administration
      pages using user "admin" and my old
      > password (with harddisk attached) or
      "admin" with no disk attached. My
      > problem is that I cannot reach the
      "disk" page under administration!
      > Every time I try I get "Incorrect
      user name or password.".
      Did you reboot, with no disks attached, after removing the USB stick?  Whenever I have observed such a problem (the device being confused about which pages have what password) it is usually because a device containing a passwd file was removed from the NSLU2 while it was running.
       
      Mike (mwester)
    • blennhed
      ... stick? Whenever I have observed such a problem (the device being confused about which pages have what password) it is usually because a device containing
      Message 2 of 6 , May 2, 2006
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, "Mike \(mwester\)" <mwester@...>
        wrote:
        >
        > > After removing the USB stick
        > > I can reach the administration pages using user "admin" and my old
        > > password (with harddisk attached) or "admin" with no disk attached. My
        > > problem is that I cannot reach the "disk" page under administration!
        > > Every time I try I get "Incorrect user name or password.".
        >
        > Did you reboot, with no disks attached, after removing the USB
        stick? Whenever I have observed such a problem (the device being
        confused about which pages have what password) it is usually because a
        device containing a passwd file was removed from the NSLU2 while it
        was running.
        >
        > Mike (mwester)
        >
        Regarding your previous answer: ok, so reverting is possible but a
        little more complex. No problem. Thank you for your reply!

        Regarding password issue - I did reboot as you described. And yes, I
        agree: the problem is most likely a misconfiguration between "admin"
        passwords in internal flash memory and on the external USB harddisk.

        However, I did complete the process of unslinging to the USB harddisk
        (now configured as disk2). It worked like a charm when I gave up
        using the USB stick. The interesting part is that now that I am
        unslung ("have unslung"?) I still have the same password problem! I
        can do absolutely everything with my NSLU2 that unslung 6.8 offers,
        including a successful installation of OpenSSH, but I cannot reach the
        "disk" section of "administration" in the web admin pages!!!
        I have tried accessing administration pages with user admin and
        password "admin", "uNSLUng" and <former password> without success.
        The other administration pages always work, disk pages never.

        Suggestions?

        And once again, thank you for your help!
        Best regards
        /Björn
      • Mike (mwester)
        Try clearing your browser cache. There is no per-page .htaccess file or mechanism, so there is no way that the slug itself could have different authentication
        Message 3 of 6 , May 2, 2006
        • 0 Attachment
          Try clearing your browser cache.  There is no per-page .htaccess file or mechanism, so there is no way that the slug itself could have different authentication for the "disks" page versus the other pages in the "Management" directory.
          Mike (mwester)
          ----- Original Message -----
          From: blennhed
          Sent: Tuesday, May 02, 2006 1:16 PM
          Subject: [nslu2-linux] Re: Disk administration shut - "incorrect username or password" with Unslung 6.8

          --- In nslu2-linux@yahoogroups.com, "Mike \(mwester\)" <mwester@...>
          wrote:
          >
          > > After removing the USB stick
          > > I can reach the administration pages using user "admin" and my old
          > > password (with harddisk attached) or "admin" with no disk attached. My
          > > problem is that I cannot reach the "disk" page under administration!
          > > Every time I try I get "Incorrect user name or password.".
          >
          > Did you reboot, with no disks attached, after removing the USB
          stick?  Whenever I have observed such a problem (the device being
          confused about which pages have what password) it is usually because a
          device containing a passwd file was removed from the NSLU2 while it
          was running.
          >
          > Mike (mwester)
          >
          Regarding your previous answer: ok, so reverting is possible but a
          little more complex. No problem. Thank you for your reply!

          Regarding password issue - I did reboot as you described. And yes, I
          agree: the problem is most likely a misconfiguration between "admin"
          passwords in internal flash memory and on the external USB harddisk.

          However, I did complete the process of unslinging to the USB harddisk
          (now configured as disk2).  It worked like a charm when I gave up
          using the USB stick.  The interesting part is that now that I am
          unslung ("have unslung"?) I still have the same password problem!  I
          can do absolutely everything with my NSLU2 that unslung 6.8 offers,
          including a successful installation of OpenSSH, but I cannot reach the
          "disk" section of "administration" in the web admin pages!!!
          I have tried accessing administration pages with user admin and
          password "admin", "uNSLUng" and <former password> without success.
          The other administration pages always work, disk pages never.

          Suggestions?

          And once again, thank you for your help!
          Best regards
          /Björn
        • blennhed
          ... file or mechanism, so there is no way that the slug itself could have different authentication for the disks page versus the other pages in the
          Message 4 of 6 , May 3, 2006
          • 0 Attachment
            --- In nslu2-linux@yahoogroups.com, "Mike \(mwester\)" <mwester@...>
            wrote:
            >
            > Try clearing your browser cache. There is no per-page .htaccess
            file or mechanism, so there is no way that the slug itself could have
            different authentication for the "disks" page versus the other pages
            in the "Management" directory.
            > Mike (mwester)

            Aha - that's it! Logging in from another computer works, so it should
            work if I clear the cache on yesterday's computer too!!

            Thank you ever so much!
            /Björn
          Your message has been successfully submitted and would be delivered to recipients shortly.