Loading ...
Sorry, an error occurred while loading the content.
 

unslung 6.8 asterisk issue

Expand Messages
  • global_dev
    I performed a quick test (installed asterisk to debian box) to update a previous thread.... I have 2 asterisk boxes working 1) vanilla asterisk on debian-based
    Message 1 of 2 , May 1 6:16 AM
      I performed a quick test (installed asterisk to debian box) to update
      a previous thread....

      I have 2 asterisk boxes working

      1) vanilla asterisk on debian-based distro (1.2.7.1) not debslug -
      regular box
      2) unslung asterisk (1.2.5)

      same config exactly, not nat issues whatsoever.

      the debian-based works great with the sample config for the unslung
      version. no stutter/jitter whatever

      the unslung version asterisk seems to work fine no stutter on the lan
      however calling in gives a stuttering (perhaps jittery) call...

      upload is >348kbps
      download >3000kbps

      when the atas direct to a vOSP (no asterisk involved) seems to work
      fine (no jitter)

      calling from pstn to VOSP via asterisk only (e.g, voicemail) has
      this bad jitter as well (no ata involved). hearing teh comedian
      messgae system and teh resultant leaving a message on the slug is
      stuttered.

      calling my cell providers vm from the unslung asterisk, I left a non-
      stuttered message but the vm system sounded stuttered to me.

      I have added only the following to the slug

      1- to unslung i have added updated busybox, openssh, bash and nano
      2- to asterisk I have added privacy manager app

      perhaps the memory free is an issue?

      i had "top" working in 5.5 (i thought via busybox), but in 6.8, it
      didn't install.. so i can't see the apps running and the memory
      commits.

      under 5.5, asterisk had about 4 or 5 entries in top. why should there
      be some many processes (with no channels going)

      any thoughts?
    • CORNELIU DOBAN
      You experience this problem only on unslung 6.8? It worked fine on unslung 5.5? I m using 5.5 from an USB flash stick (no swap active) and have no problems
      Message 2 of 2 , May 1 10:49 AM
        You experience this problem only on unslung 6.8?
        It worked fine on unslung 5.5?

        I'm using 5.5 from an USB flash stick (no swap active) and have no problems with asterisk (uptime > 60 days).
        I have 2 ATA. A Sipura SPA-3000 that works perfect and a Grandstream HT286 on which I have a little bit of jitter.

        Check the voicemail config that it records the messages in only one format.
        I'm recording only in wav47 because any windows box can play them when received in e-mail attacments.

        Memory could be an issue if you are running other apps in the same time (like a ssh session maybe). Use the command free to display the memory status.
        Try vmstat -S several time during a call to see if there is swaping happening (I'm not sure what it will display, I looked only in the man pages of the command)

        global_dev <global_dev@...> wrote:
        I performed a quick test (installed asterisk to debian box) to update
        a previous thread....

        I have 2 asterisk boxes working

        1) vanilla asterisk on debian-based distro (1.2.7.1) not debslug -
        regular box
        2) unslung asterisk (1.2.5)

        same config exactly, not nat issues whatsoever.

        the debian-based works great with the sample config for the unslung
        version. no stutter/jitter whatever

        the unslung version asterisk seems to work fine no stutter on the lan
        however calling in gives a stuttering (perhaps jittery) call...

        upload is >348kbps
        download >3000kbps

        when the atas direct to a vOSP (no asterisk involved) seems to work
        fine (no jitter)

        calling from pstn to VOSP via asterisk only (e.g,  voicemail) has
        this bad jitter as well (no ata involved). hearing teh comedian
        messgae system and teh resultant leaving a message on the slug is
        stuttered.

        calling my cell providers vm from the unslung asterisk, I left a non-
        stuttered message but the vm system sounded stuttered to me.

        I have added only the following to the slug

        1- to unslung i have added updated busybox, openssh, bash and nano
        2- to asterisk I have added privacy manager app

        perhaps the memory free is an issue?

        i had "top" working in 5.5 (i thought via busybox), but in 6.8, it
        didn't install.. so i can't see the apps running and the memory
        commits.

        under 5.5, asterisk had about 4 or 5 entries in top. why should there
        be some many processes (with no channels going)

        any thoughts?







        Blab-away for as little as 1ยข/min. Make PC-to-Phone Calls using Yahoo! Messenger with Voice.

      Your message has been successfully submitted and would be delivered to recipients shortly.