Loading ...
Sorry, an error occurred while loading the content.

need guidance building Openslug

Expand Messages
  • h8dc
    I have successfully built Unslung Alpha and have used it on my slug for a while. I d like to try my hands on Openslug but am having trouble getting it built.
    Message 1 of 6 , Apr 1, 2006
    • 0 Attachment
      I have successfully built Unslung Alpha and have used it on my slug
      for a while. I'd like to try my hands on Openslug but am having
      trouble getting it built. In a nutshell:

      I tried "make openslug" and it failed. I forget the exact error
      message but it was complaining about the IPL_ixp400AccessLibrary*
      file I had. I got a newer one and tried the build again, several
      times, with the latest try running 'clean' (make distclean-openslug,
      make setup, make update, make openslug). I can't get past this
      point:

      NOTE: package ixp4xx-2.1-r9: task do_compile: started
      ERROR: function do_compile failed
      ERROR: see log...

      Log file said:

      /home/slugdev/slug/openslug/tmp/work/ixp4xx-csr-2.1-r9/
      ixp400_xscale_sw/lib/linuxbe/ixp400.c:1:2: #error this file
      must never be compiled

      I have NO clue how to go about this one! Anyone?!
    • Frederic Wenzel
      ... I don t know where you put the intel drivers, apparently not in the main download directory (i.e. probably something like /home/$YOU/slug/download) as
      Message 2 of 6 , Apr 1, 2006
      • 0 Attachment
        h8dc schrieb:
        > NOTE: package ixp4xx-2.1-r9: task do_compile: started
        > ERROR: function do_compile failed
        > ERROR: see log...
        >
        > Log file said:
        >
        > /home/slugdev/slug/openslug/tmp/work/ixp4xx-csr-2.1-r9/
        > ixp400_xscale_sw/lib/linuxbe/ixp400.c:1:2: #error this file
        > must never be compiled

        I don't know where you put the intel drivers, apparently not in the main
        "download" directory (i.e. probably something like
        /home/$YOU/slug/download) as the master makefile howto tells you. Right?

        Good luck

        Fred
      • Rod Whitby
        This is a known real problem which even has the development core team stumped. If anyone works out how to fix this one we will be very grateful. It must be
        Message 3 of 6 , Apr 1, 2006
        • 0 Attachment
          This is a known real problem which even has the development core team stumped. If anyone works out how to fix this one we will be very grateful. It must be environment-triggered, as it does't happen to everyone (some people can build it fine every time).

          -- Rod
          -----Original Message-----
          From: "h8dc" <h8dc@...>
          Date: Sunday, Apr 2, 2006 3:08 am
          Subject: [nslu2-linux] need guidance building Openslug

          I have successfully built Unslung Alpha and have used it on my slug
          for a while. I'd like to try my hands on Openslug but am having
          trouble getting it built. In a nutshell:



          I tried 'make openslug' and it failed. I forget the exact error
          message but it was complaining about the IPL_ixp400AccessLibrary*
          file I had. I got a newer one and tried the build again, several
          times, with the latest try running 'clean' (make distclean-openslug,
          make setup, make update, make openslug). I can't get past this
          point:



          NOTE: package ixp4xx-2.1-r9: task do_compile: started

          ERROR: function do_compile failed

          ERROR: see log...



          Log file said:



          /home/slugdev/slug/openslug/tmp/work/ixp4xx-csr-2.1-r9/

          ixp400_xscale_sw/lib/linuxbe/ixp400.c:1:2: #error this file
          must never be compiled



          I have NO clue how to go about this one! Anyone?!












          YAHOO! GROUPS LINKS
          Visit your group "nslu2-linux" on the web.
          To unsubscribe from this group, send an email to:
          nslu2-linux-unsubscribe@yahoogroups.com
          Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        • h8dc
          I m running CoLinux with Debian/Etch. Unslung seems to build fine, but not Openslug or Debianslug. Cool! A problem to solve! I ll play around with this one
          Message 4 of 6 , Apr 1, 2006
          • 0 Attachment
            I'm running CoLinux with Debian/Etch. Unslung seems to build fine,
            but not Openslug or Debianslug. Cool! A problem to solve! I'll
            play around with this one (although with my 600 Mhz build machine,
            and 6+ hour build times, it may take me a while!)! :-)

            Thanks for the info!


            --- In nslu2-linux@yahoogroups.com, "Rod Whitby" <list.nslu2-
            linux@...> wrote:
            >
            > This is a known real problem which even has the development core
            team stumped. If anyone works out how to fix this one we will be
            very grateful. It must be environment-triggered, as it does't
            happen to everyone (some people can build it fine every time).
            >
            > -- Rod
            > -----Original Message-----
            > From: "h8dc" <h8dc@...>
            > Date: Sunday, Apr 2, 2006 3:08 am
            > Subject: [nslu2-linux] need guidance building Openslug
            >
            > I have successfully built Unslung Alpha and have used it on my
            slug
            > for a while. I'd like to try my hands on Openslug but am having
            > trouble getting it built. In a nutshell:
            >
            >
            >
            > I tried 'make openslug' and it failed. I forget the exact error
            > message but it was complaining about the IPL_ixp400AccessLibrary*
            > file I had. I got a newer one and tried the build again, several
            > times, with the latest try running 'clean' (make distclean-
            openslug,
            > make setup, make update, make openslug). I can't get past this
            > point:
            >
            >
            >
            > NOTE: package ixp4xx-2.1-r9: task do_compile: started
            >
            > ERROR: function do_compile failed
            >
            > ERROR: see log...
            >
            >
            >
            > Log file said:
            >
            >
            >
            > /home/slugdev/slug/openslug/tmp/work/ixp4xx-csr-2.1-r9/
            >
            > ixp400_xscale_sw/lib/linuxbe/ixp400.c:1:2: #error this file
            > must never be compiled
            >
            >
            >
            > I have NO clue how to go about this one! Anyone?!
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
            > YAHOO! GROUPS LINKS
            > Visit your group "nslu2-linux" on the web.
            > To unsubscribe from this group, send an email to:
            > nslu2-linux-unsubscribe@yahoogroups.com
            > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            Service.
            >
          • h8dc
            Still digging for clues. Don t want to beat a dead horse, but this has me confounded. As far as it being environment-triggered, and as I am running CoLinux
            Message 5 of 6 , Apr 4, 2006
            • 0 Attachment
              Still digging for clues. Don't want to beat a dead horse, but this
              has me confounded.

              As far as it being environment-triggered, and as I am running
              CoLinux with Debian/Etch on a Windoze XP box, would a proper path
              for a solution be to try dumping CoLinux and turning my machine into
              a Linux box with Debian Sarge/Woody/whatever, or try building it on
              totally different machine (my build machine is quite old - I have
              others)?

              TIA

              --- In nslu2-linux@yahoogroups.com, "Rod Whitby" <list.nslu2-
              linux@...> wrote:
              >
              > This is a known real problem which even has the development core
              team stumped. If anyone works out how to fix this one we will be
              very grateful. It must be environment-triggered, as it does't
              happen to everyone (some people can build it fine every time).
              >
              > -- Rod
              > -----Original Message-----
              > From: "h8dc" <h8dc@...>
              > Date: Sunday, Apr 2, 2006 3:08 am
              > Subject: [nslu2-linux] need guidance building Openslug
              >
              > I have successfully built Unslung Alpha and have used it on my
              slug
              > for a while. I'd like to try my hands on Openslug but am having
              > trouble getting it built. In a nutshell:
              >
              >
              >
              > I tried 'make openslug' and it failed. I forget the exact error
              > message but it was complaining about the IPL_ixp400AccessLibrary*
              > file I had. I got a newer one and tried the build again, several
              > times, with the latest try running 'clean' (make distclean-
              openslug,
              > make setup, make update, make openslug). I can't get past this
              > point:
              >
              >
              >
              > NOTE: package ixp4xx-2.1-r9: task do_compile: started
              >
              > ERROR: function do_compile failed
              >
              > ERROR: see log...
              >
              >
              >
              > Log file said:
              >
              >
              >
              > /home/slugdev/slug/openslug/tmp/work/ixp4xx-csr-2.1-r9/
              >
              > ixp400_xscale_sw/lib/linuxbe/ixp400.c:1:2: #error this file
              > must never be compiled
              >
              >
              >
              > I have NO clue how to go about this one! Anyone?!
              >
              >
              >
              >
              >
              >
              >
              >
              >
              >
              >
              >
              > YAHOO! GROUPS LINKS
              > Visit your group "nslu2-linux" on the web.
              > To unsubscribe from this group, send an email to:
              > nslu2-linux-unsubscribe@yahoogroups.com
              > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
              Service.
              >
            • h8dc
              Can t say I resolved the problem, but I fixed it here, in that OpenSlug finally built! Under CoLinux, I originally installed Debian Etch/testing using the
              Message 6 of 6 , Apr 8, 2006
              • 0 Attachment
                Can't say I resolved the problem, but I fixed it here, in that
                OpenSlug finally built! Under CoLinux, I originally installed
                Debian Etch/testing using the image debian-testing-i386-
                netinst.iso. I couldn't get a successful OpenSlug build with that,
                but Unslung built okay. It was after I upgraded the distro,
                using "apt-get update" then "apt-get dist-upgrade", that I was
                finally able to get a successful OpenSlug build.

                Don't know if this helps anyone else, but maybe someone on the
                Development Core Team can see something in my trials and errors.
                :-)

                Now off to try building DebianSlug......


                --- In nslu2-linux@yahoogroups.com, "Rod Whitby" <list.nslu2-
                linux@...> wrote:
                >
                > This is a known real problem which even has the development core
                team stumped. If anyone works out how to fix this one we will be
                very grateful. It must be environment-triggered, as it does't
                happen to everyone (some people can build it fine every time).
                >
                > -- Rod
                > -----Original Message-----
                > From: "h8dc" <h8dc@...>
                > Date: Sunday, Apr 2, 2006 3:08 am
                > Subject: [nslu2-linux] need guidance building Openslug
                >
                > I have successfully built Unslung Alpha and have used it on my
                slug
                > for a while. I'd like to try my hands on Openslug but am having
                > trouble getting it built. In a nutshell:
                >
                > I tried 'make openslug' and it failed. I forget the exact error
                > message but it was complaining about the IPL_ixp400AccessLibrary*
                > file I had. I got a newer one and tried the build again, several
                > times, with the latest try running 'clean' (make distclean-
                openslug,
                > make setup, make update, make openslug). I can't get past this
                > point:
                >
                >
                > NOTE: package ixp4xx-2.1-r9: task do_compile: started
                >
                > ERROR: function do_compile failed
                >
                > ERROR: see log...
                >
                > Log file said:
                >
                > /home/slugdev/slug/openslug/tmp/work/ixp4xx-csr-2.1-r9/
                >
                > ixp400_xscale_sw/lib/linuxbe/ixp400.c:1:2: #error this file
                > must never be compiled
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.