Loading ...
Sorry, an error occurred while loading the content.

Problem while building openslug-packages

Expand Messages
  • Marc-AndrĂ© Funk
    Dear All, I m new to openembedded and I m currently on the way to bring up a cross-development platform on a EPIA-based gentoo system (freshly installed and
    Message 1 of 1 , Feb 28 11:17 PM
    • 0 Attachment
      Dear All,

      I'm new to openembedded and I'm currently on the way to bring up a
      cross-development platform on a EPIA-based gentoo system (freshly
      installed and hence up to date).
      I followed all instructions for using the mastermakefile on the wiki
      and was able to build unslung completely and the openslug image.

      However, building the target openslug-packages fails (see logging
      below).
      I couldn't figure out what's really going wrong. Even running bitbake
      in verbose debugging mode does not give conclusive results - it seems
      that the target slugos-native is built correctly (its last dependency
      is monotone) and I would expect that the build is then going on with
      the first package "alsa" (which is the next top level after slugos-
      native) - but then the libc6 message comes out of nowhere...
      (BTW: glibc did build without problems)

      What am I doing wrong? Any hints?

      (I could supply the debugging output if anyony is interested).

      Thanks and cheers,
      //MAF


      embedded@edip ~ $ make openslug-packages
      ( cd openslug ; make distro )
      make[1]: Entering directory `/data01/embedded/openslug'
      . conf/topdir.conf && test "`pwd`" = "$TOPDIR" || echo
      "TOPDIR='`pwd`'" > conf/topdir.conf
      . ./setup-env; exec bitbake "openslug"-packages
      NOTE: Using cache in '/data01/embedded/openslug/tmp/cache'
      NOTE: Parsing finished. 0 cached, 913 parsed, 25 skipped, 0 masked.
      NOTE: build 200602282311: started

      OE Build Configuration:
      BB_VERSION = "1.3.2.1"
      OE_REVISION = "83f19fb9d221b3326d823d0c4833b0df84cec412"
      TARGET_ARCH = "armeb"
      TARGET_OS = "linux"
      MACHINE = "nslu2"
      DISTRO = "openslug"
      TARGET_FPU = "soft"

      NOTE: package slugos-image-1.0: started
      NOTE: package slugos-image-1.0-r26: task do_fetch: started
      NOTE: package slugos-image-1.0-r26: task do_fetch: completed
      NOTE: package slugos-image-1.0-r26: task do_rootfs: started
      NOTE: package slugos-image-1.0-r26: task do_rootfs: completed
      NOTE: package slugos-image-1.0-r26: task do_build: started
      NOTE: package slugos-image-1.0-r26: task do_build: completed
      NOTE: package slugos-image-1.0: completed
      ERROR: Nothing provides runtime dependency libc6
      NOTE: no buildable providers for slugos-native
      ERROR: dependency slugos-native (for slugos-packages) not satisfied
      NOTE: no buildable providers for openslug-packages
      make[1]: *** [distro] Error 1
      make[1]: Leaving directory `/data01/embedded/openslug'
      make: *** [openslug-packages] Error 2
    Your message has been successfully submitted and would be delivered to recipients shortly.