Loading ...
Sorry, an error occurred while loading the content.
 

Modify DebianSlug Patch for DallasOneWire - Keeping up with Kernel versions

Expand Messages
  • Dave Coutts
    Hi All I have followed the instructions in the how-to below so as to allow OneWire support for the Debian slug.
    Message 1 of 1 , Feb 28, 2006
      Hi All

      I have followed the instructions in the how-to below so as to allow OneWire support for the Debian slug.

      http://www.nslu2-linux.org/wiki/DebianSlug/InstallDallasOneWire
       
      I went to make the DebianSlug image only to find that the kernel version has changed from '2.6.15.3' to '2.6.16-rc4-git9'. Hence the patch wasn't applied.

      The how-to clearly states that the kernel will change and that one need to modify the patch to take into account the new kernel version.

      Ive never patched before. Does the patch below look correct for the kernel linux-2.6.16-rc4-git7 ?
      I'm not sure if the exact date has to be specified or if the digits 730,735 / 730,737 need to be changed.
      If someone wise in the ways of linux patching could add a little more detail to the how-to, Id appreciate it.

      Thanks

      Dave

       *** linux-2.6.16-rc4-git7/arch/arm/Kconfig     2006-02-24 08:51:30.000000000 +0100
      --- linux-2.6.16-rc4-git7/arch/arm/Kconfig     2006-02-28 23:00:00.000000000 +0100
      ***************
      *** 730,735 ****
      --- 730,737 ----

        source "drivers/i2c/Kconfig"

      + source "drivers/w1/Kconfig"
      +
        source "drivers/hwmon/Kconfig"

        #source "drivers/l3/Kconfig"

    Your message has been successfully submitted and would be delivered to recipients shortly.