Loading ...
Sorry, an error occurred while loading the content.
 

[nslu2-linux] SOLVED - Problems writing to share from Linux client

Expand Messages
  • Gelan Hopkins
    It was strange, but I put these lines into my /opt/etc/samba/smb.conf file: force directory mode=777 force create mode=777 create mask=777 That seems to have
    Message 1 of 6 , Jan 30, 2006
      It was strange, but I put these lines into my /opt/etc/samba/smb.conf file:

      force directory mode=777
      force create mode=777
      create mask=777

      That seems to have cleared up the permissions problems. Strange that the
      permissions didn't have any effect on my Windows Laptop.

      Gelan Hopkins


      >From: Adam Baker <slug@...>
      >Reply-To: nslu2-linux@yahoogroups.com
      >To: nslu2-linux@yahoogroups.com
      >Subject: [nslu2-linux] Re: Problems writing to share from Linux client
      >Date: Tue, 24 Jan 2006 20:22:19 +0000 (UTC)
      >
      >
      >
      >
      >
      >Gelan Hopkins <purelithium@...> writes:
      >
      >
      >
      > >
      >
      > > Hi I've found that when I'm connecting to the samba shares from my
      >Mandriva
      >
      > > Linux client, I can only write to the NSLU2 shares as root. Do you think
      >
      > > this could be a problem with how the mount is configured on my end or on
      >the
      >
      > > NSLU2's end?
      >
      > >
      >
      >Almost certainly the Mandriva end, by default the permissions will be the
      >umask
      >
      >of the person performong the mount. You could specify the fmask and dmask
      >values
      >
      >at mount time or you could specify the user option in fstab so the user who
      >
      >wants to access the file system performs the mount or you could install
      >
      >something like LinNeighborhood which lets you browse through remote mounts
      >as a
      >
      >normal user.
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      > SPONSORED LINKS
      >
      >
      >
      >
      > Communication and networking
      >
      >
      > Wireless communication and networking
      >
      >
      > Linksys nslu2
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      > YAHOO! GROUPS LINKS
      >
      >
      >
      >
      > Visit your group "nslu2-linux" on the web.
      >
      > To unsubscribe from this group, send an email to:
      >nslu2-linux-unsubscribe@yahoogroups.com
      >
      > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.