Loading ...
Sorry, an error occurred while loading the content.
 

Re: OpenSlug and wxBase

Expand Messages
  • teosog
    ... the exact error is: make: *** [basedll_cmdline.o] Error 1 ... part (the ... errors with ... with it.
    Message 1 of 8 , Jan 2, 2006
      --- In nslu2-linux@yahoogroups.com, "thx1011" <thx1011@y...> wrote:
      >
      > Hi,
      the exact error is:
      make: *** [basedll_cmdline.o] Error 1

      > I had the same problem, and the issue was that memory was short to
      > compile. So make sure that you have swap space, at least 128MB.
      >
      > I have amule working right now on the slug with no problems at all.
      >
      > thx1011
      >
      > --- In nslu2-linux@yahoogroups.com, "teosog" <teosog@y...> wrote:
      > >
      > > the gcc autokills, i'll try later today with that versions
      > >
      > >
      > > --- In nslu2-linux@yahoogroups.com, "ramiro_barreiro69"
      > > <ramiro_barreiro69@y...> wrote:
      > > >
      > > > --- In nslu2-linux@yahoogroups.com, "teosog" <teosog@y...> wrote:
      > > > >
      > > > > Hi, i'm just trying to make aMule working on my slug.
      > > > > I got samba and ftp working on my slug, and i have some problems
      > > > > trying to install aMule.
      > > > > First of all, I'm not able to build wxBase, I'm able to finish the
      > > > > ./configure part, but i got and error while doing the make
      part (the
      > > > > make program autokills), and the same with GD.
      > > > > What am I doing wrong? Maybe it's the wxBase and GD version? Which
      > > > > versions are known to work OK on Openslug?
      > > > > Thank you and happy new year
      > > > >
      > > >
      > > > Hi,
      > > > I've tried both wxBase 2.6.1 and 2.6.2. They built with no
      errors with
      > > > gcc 3.4.4. Th gd version I built was 2.0.33.
      > > > What is the error reported by 'make'?
      > > > By the way, amule 2.1.0 has been released, I'll begin testing
      with it.
      > > >
      > >
      >
    • ramiro_barreiro69
      ... I can t guess what is happening. This is what configure says: Configured wxWidgets 2.6.2 for `armv5teb-unknown-linux-gnu Which GUI toolkit should
      Message 2 of 8 , Jan 3, 2006
        --- In nslu2-linux@yahoogroups.com, "teosog" <teosog@y...> wrote:


        > the exact error is:
        > make: *** [basedll_cmdline.o] Error 1

        I can't guess what is happening. This is what configure says:
        Configured wxWidgets 2.6.2 for `armv5teb-unknown-linux-gnu'

        Which GUI toolkit should wxWidgets use? base only
        Should wxWidgets be compiled into single library? no
        Should wxWidgets be compiled in debug mode? no
        Should wxWidgets be linked as a shared library? yes
        Should wxWidgets be compiled in Unicode mode? no
        What level of wxWidgets compatibility should be enabled?
        wxWidgets 2.2 no
        wxWidgets 2.4 yes
        Which libraries should wxWidgets use?
        jpeg none
        png none
        regex sys
        tiff none
        zlib sys
        odbc no
        expat sys
        libmspack no
        sdl no
        gnomeprint none

        Don't know if that helps
      • Robert Demski
        What about cross-compiling in OE evirnoment? I have succes with compiling on OpenSlug too but I can t create ipk package in OE on PC and on slug. Error is in
        Message 3 of 8 , Jan 3, 2006
          What about cross-compiling in OE evirnoment?
          I have succes with compiling on OpenSlug too but I can't create ipk
          package in OE on PC and on slug. Error is in configure stage (but now I
          don't remember what it was error)

          ramiro_barreiro69 napisaƂ(a):

          > --- In nslu2-linux@yahoogroups.com, "teosog" <teosog@y...> wrote:
          > >
          > > Hi, i'm just trying to make aMule working on my slug.
          > > I got samba and ftp working on my slug, and i have some problems
          > > trying to install aMule.
          > > First of all, I'm not able to build wxBase, I'm able to finish the
          > > ./configure part, but i got and error while doing the make part (the
          > > make program autokills), and the same with GD.
          > > What am I doing wrong? Maybe it's the wxBase and GD version? Which
          > > versions are known to work OK on Openslug?
          > > Thank you and happy new year
          > >
          >
          > Hi,
          > I've tried both wxBase 2.6.1 and 2.6.2. They built with no errors with
          > gcc 3.4.4. Th gd version I built was 2.0.33.
          > What is the error reported by 'make'?
          > By the way, amule 2.1.0 has been released, I'll begin testing with it.
          >
          >
          >
          >
          >
          >
          > ------------------------------------------------------------------------
          > YAHOO! GROUPS LINKS
          >
          > * Visit your group "nslu2-linux
          > <http://groups.yahoo.com/group/nslu2-linux>" on the web.
          > * To unsubscribe from this group, send an email to:
          > nslu2-linux-unsubscribe@yahoogroups.com
          > <mailto:nslu2-linux-unsubscribe@yahoogroups.com?subject=Unsubscribe>
          > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          > Service <http://docs.yahoo.com/info/terms/>.
          >
          >
          > ------------------------------------------------------------------------
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.