Loading ...
Sorry, an error occurred while loading the content.

Can't boot from disk1 after plugging in disk2

Expand Messages
  • Mani Varadarajan
    Hello, Yesterday I successfully unslung my NSLU with Unslung 5.5 after following the instructions on the Wiki. The rootfs was mounted off of disk1 and
    Message 1 of 1 , Dec 31, 2005
    View Source
    • 0 Attachment
      Hello,

      Yesterday I successfully unslung my NSLU with Unslung 5.5 after
      following the instructions on the Wiki. The rootfs was mounted
      off of disk1 and everything was working perfectly well. Today,
      I wanted to add a non-NSLU formatted disk on disk2. It is an
      ext3fs file system but it wasn't formatted using the Slug.
      The disk was recognized (I checked when telnetted in; it wasn't
      recognized in the Web interface) and I mounted it by hand.

      I then rebooted with both disks plugged in. The Slug stopped
      booting from this point onwards, as long as the unslung disk
      (disk1) is plugged in. If I unplug the disk and boot with
      no disks attached, everything is fine, disk1 is recognized post-
      bootup. I've tried unslinging disk1 again but it makes no
      difference. I can still only boot off the flash rootfs and not
      disk1. In this situation, the Slug doesn't ping, etc.

      Can anyone help me here? I've gone through the Wiki again and
      again but haven't seen anything which describes a solution to
      this problem.

      Thanks,
      Mani Varadarajan
    Your message has been successfully submitted and would be delivered to recipients shortly.