Loading ...
Sorry, an error occurred while loading the content.

Re: USB enclosre that supports APM enabled drive for spindown

Expand Messages
  • zhyla
    Ah, I think you re a little confused. The -S parameter sets a spindown timer that is unrelated to the APM setting. You want to reboot the drive and then
    Message 1 of 11 , Dec 1, 2005
    • 0 Attachment
      Ah, I think you're a little confused. The -S parameter sets a
      spindown timer that is unrelated to the APM setting. You want to
      reboot the drive and then query that timer value. If it's still set
      then put the drive in the enclosure and just let it sit for however
      long you set the timer (in the case of 120, I think 10 minutes).

      The results you got from setting the APM value sounds reasonable, it
      spins it lower to save power and heat (so your PC could turn the fans
      down a bit to save power as well). We're more interested in drive
      life though.

      BTW there is an acoustic setting in hdparm which is not guaranteed to
      be supported, you might see if it makes the drive any quieter.

      --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...> wrote:
      >
      > Zyla:
      >
      > I used "hdparm -k1 -K1 -S120 /dev/hdb" last night. "hdparm -
      > I /dev/hdb" command does show APM changed to 120. However when I
      > reboot after powershutdown , and use the feature tool, the APM valu
      > is still 127. So look like hdprm is ineffective with the new hitachi
      > 500 GB deskstar.
      >
      > I then used feature tool to set APM to 69. The drive in USB
      > enclosure does seem to spindown to a low rpm, I guess from 7200 to
      > 4200. But I cannot get it to completley stop spinning. I did some
      > more reseach with the feature tool. In the older version APM values
      > 0x01 to 0x3F used to be standby mode. The new feature tool lists
      > these values as invalid. The first valid range begins at 0x40 (64
      > and it is low rpm idle. Looks like hitachi got rid of standby mode
      > from APM.
      >
      > Althogh invalid, I will try APM 0x01, just to see if the drive will
      > comletely stop spinning and go into standbty mode. According to the
      > documentation on the hitachi website, the 500GB deskstar drive does
      > have a standby mode. I can't figure why would they remove that mode
      > from the latest feature tool.
      >
      > Anyone else has observed this with the new hitachi drives and the
      > feature tool.
      >
      > Bharat
      >
      >
      > --- In nslu2-linux@yahoogroups.com, "zhyla" <nbm_clan@y...> wrote:
      > >
      > > I feel a little hesitant to give exact instructions on this since I
      > > haven't done this with my drive yet but here is what I was
      > thinking:
      > >
      > > hdparm -S120 -K
      > >
      > > I don't think the -k option applies to -S and at any rate as the
      > > manpage states DO NOT set -k without testing first.
      > >
      > > Let me know if it works. Also maybe play with the -B option and
      > > report back on that.
      > >
      > > Zhyla
      > >
      > > --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...> wrote:
      > > >
      > > > Thanks Zhyla. I will try that again tonight. Now the hdparm
      > command
      > > > is "hdpam -B 127" or "hdparm -k1- K1 -S127"?
      > > >
      > > > Bharat
      > >
      >
    • jhaveri
      Zyla: Thanks you for clearing the difference between -S in hdparn and APM in feature tool. I checked some more and turned out that it was the - B value in
      Message 2 of 11 , Dec 1, 2005
      • 0 Attachment
        Zyla:

        Thanks you for clearing the difference between -S in hdparn and APM
        in feature tool. I checked some more and turned out that it was the -
        B value in hdparm, i.e. "hdparm -B 120 /dev/hdb" that was changing
        the APM value, not -S.

        So after I issue the command "hpram -S 120 /dev/hdb", poweroff PC,
        rebbot, and to check if the -S value is not reset, how do I check
        that? When I issue "hdparm -I /dev/hdb", the command output does not
        list S value, all it shows is the APM value. That was thr reason for
        my confusion.

        By the way, last night I took APM with the feature tool all the way
        down to 0x01 (lowest), and 0x40 (64), still not srandby. I guess I
        will have to use the hdparm with -S.

        One last question, does unslung have hdparm? I checked and it was
        only packaged for openslug. If not, am I correct that you don't
        really need hdparm in unslung. All you have to do it set it in a PC,
        and the disk itself will manage it's standby mode.

        Thanks again to be patient with this newbie.

        Bharat



        --- In nslu2-linux@yahoogroups.com, "zhyla" <nbm_clan@y...> wrote:
        >
        > Ah, I think you're a little confused. The -S parameter sets a
        > spindown timer that is unrelated to the APM setting. You want to
        > reboot the drive and then query that timer value. If it's still
        set
        > then put the drive in the enclosure and just let it sit for however
        > long you set the timer (in the case of 120, I think 10 minutes).
        >
        > The results you got from setting the APM value sounds reasonable,
        it
        > spins it lower to save power and heat (so your PC could turn the
        fans
        > down a bit to save power as well). We're more interested in drive
        > life though.
        >
        > BTW there is an acoustic setting in hdparm which is not guaranteed
        to
        > be supported, you might see if it makes the drive any quieter.
        >
        > --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...> wrote:
        > >
        > > Zyla:
        > >
        > > I used "hdparm -k1 -K1 -S120 /dev/hdb" last night. "hdparm -
        > > I /dev/hdb" command does show APM changed to 120. However when I
        > > reboot after powershutdown , and use the feature tool, the APM
        valu
        > > is still 127. So look like hdprm is ineffective with the new
        hitachi
        > > 500 GB deskstar.
        > >
        > > I then used feature tool to set APM to 69. The drive in USB
        > > enclosure does seem to spindown to a low rpm, I guess from 7200
        to
        > > 4200. But I cannot get it to completley stop spinning. I did
        some
        > > more reseach with the feature tool. In the older version APM
        values
        > > 0x01 to 0x3F used to be standby mode. The new feature tool lists
        > > these values as invalid. The first valid range begins at 0x40
        (64
        > > and it is low rpm idle. Looks like hitachi got rid of standby
        mode
        > > from APM.
        > >
        > > Althogh invalid, I will try APM 0x01, just to see if the drive
        will
        > > comletely stop spinning and go into standbty mode. According to
        the
        > > documentation on the hitachi website, the 500GB deskstar drive
        does
        > > have a standby mode. I can't figure why would they remove that
        mode
        > > from the latest feature tool.
        > >
        > > Anyone else has observed this with the new hitachi drives and
        the
        > > feature tool.
        > >
        > > Bharat
        > >
        > >
        > > --- In nslu2-linux@yahoogroups.com, "zhyla" <nbm_clan@y...>
        wrote:
        > > >
        > > > I feel a little hesitant to give exact instructions on this
        since I
        > > > haven't done this with my drive yet but here is what I was
        > > thinking:
        > > >
        > > > hdparm -S120 -K
        > > >
        > > > I don't think the -k option applies to -S and at any rate as
        the
        > > > manpage states DO NOT set -k without testing first.
        > > >
        > > > Let me know if it works. Also maybe play with the -B option
        and
        > > > report back on that.
        > > >
        > > > Zhyla
        > > >
        > > > --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...>
        wrote:
        > > > >
        > > > > Thanks Zhyla. I will try that again tonight. Now the hdparm
        > > command
        > > > > is "hdpam -B 127" or "hdparm -k1- K1 -S127"?
        > > > >
        > > > > Bharat
        > > >
        > >
        >
      • zhyla
        Bharat, if you keep this up I m going to have to get off my butt and do this to my drive :) It doesn t look like hdparm has a documented way of querying the -S
        Message 3 of 11 , Dec 2, 2005
        • 0 Attachment
          Bharat, if you keep this up I'm going to have to get off my butt and
          do this to my drive :)

          It doesn't look like hdparm has a documented way of querying the -S
          value. But what you want to do is put it back in the enclosure, power
          it up and see if after ten minutes the drive stops spinning. It
          should spin up automatically when there is disk activity and then when
          there is none it should spin back down when it is idle.

          hdparm absolutely, positively, 100% will not work on a USB drive, so
          it's pretty useless to package it for either distribution.

          Zhyla

          --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...> wrote:
          >
          > Zyla:
          >
          > Thanks you for clearing the difference between -S in hdparn and APM
          > in feature tool. I checked some more and turned out that it was the -
          > B value in hdparm, i.e. "hdparm -B 120 /dev/hdb" that was changing
          > the APM value, not -S.
          >
          > So after I issue the command "hpram -S 120 /dev/hdb", poweroff PC,
          > rebbot, and to check if the -S value is not reset, how do I check
          > that? When I issue "hdparm -I /dev/hdb", the command output does not
          > list S value, all it shows is the APM value. That was thr reason for
          > my confusion.
          >
          > By the way, last night I took APM with the feature tool all the way
          > down to 0x01 (lowest), and 0x40 (64), still not srandby. I guess I
          > will have to use the hdparm with -S.
          >
          > One last question, does unslung have hdparm? I checked and it was
          > only packaged for openslug. If not, am I correct that you don't
          > really need hdparm in unslung. All you have to do it set it in a PC,
          > and the disk itself will manage it's standby mode.
          >
          > Thanks again to be patient with this newbie.
          >
          > Bharat
          >
          >
          >
          > --- In nslu2-linux@yahoogroups.com, "zhyla" <nbm_clan@y...> wrote:
          > >
          > > Ah, I think you're a little confused. The -S parameter sets a
          > > spindown timer that is unrelated to the APM setting. You want to
          > > reboot the drive and then query that timer value. If it's still
          > set
          > > then put the drive in the enclosure and just let it sit for however
          > > long you set the timer (in the case of 120, I think 10 minutes).
          > >
          > > The results you got from setting the APM value sounds reasonable,
          > it
          > > spins it lower to save power and heat (so your PC could turn the
          > fans
          > > down a bit to save power as well). We're more interested in drive
          > > life though.
          > >
          > > BTW there is an acoustic setting in hdparm which is not guaranteed
          > to
          > > be supported, you might see if it makes the drive any quieter.
          > >
          > > --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...> wrote:
          > > >
          > > > Zyla:
          > > >
          > > > I used "hdparm -k1 -K1 -S120 /dev/hdb" last night. "hdparm -
          > > > I /dev/hdb" command does show APM changed to 120. However when I
          > > > reboot after powershutdown , and use the feature tool, the APM
          > valu
          > > > is still 127. So look like hdprm is ineffective with the new
          > hitachi
          > > > 500 GB deskstar.
          > > >
          > > > I then used feature tool to set APM to 69. The drive in USB
          > > > enclosure does seem to spindown to a low rpm, I guess from 7200
          > to
          > > > 4200. But I cannot get it to completley stop spinning. I did
          > some
          > > > more reseach with the feature tool. In the older version APM
          > values
          > > > 0x01 to 0x3F used to be standby mode. The new feature tool lists
          > > > these values as invalid. The first valid range begins at 0x40
          > (64
          > > > and it is low rpm idle. Looks like hitachi got rid of standby
          > mode
          > > > from APM.
          > > >
          > > > Althogh invalid, I will try APM 0x01, just to see if the drive
          > will
          > > > comletely stop spinning and go into standbty mode. According to
          > the
          > > > documentation on the hitachi website, the 500GB deskstar drive
          > does
          > > > have a standby mode. I can't figure why would they remove that
          > mode
          > > > from the latest feature tool.
          > > >
          > > > Anyone else has observed this with the new hitachi drives and
          > the
          > > > feature tool.
          > > >
          > > > Bharat
          > > >
          > > >
          > > > --- In nslu2-linux@yahoogroups.com, "zhyla" <nbm_clan@y...>
          > wrote:
          > > > >
          > > > > I feel a little hesitant to give exact instructions on this
          > since I
          > > > > haven't done this with my drive yet but here is what I was
          > > > thinking:
          > > > >
          > > > > hdparm -S120 -K
          > > > >
          > > > > I don't think the -k option applies to -S and at any rate as
          > the
          > > > > manpage states DO NOT set -k without testing first.
          > > > >
          > > > > Let me know if it works. Also maybe play with the -B option
          > and
          > > > > report back on that.
          > > > >
          > > > > Zhyla
          > > > >
          > > > > --- In nslu2-linux@yahoogroups.com, "jhaveri" <jhaveri@y...>
          > wrote:
          > > > > >
          > > > > > Thanks Zhyla. I will try that again tonight. Now the hdparm
          > > > command
          > > > > > is "hdpam -B 127" or "hdparm -k1- K1 -S127"?
          > > > > >
          > > > > > Bharat
          > > > >
          > > >
          > >
          >
        • jhaveri
          ... Zhyla: I did this one more time. Put the drive back in PC linux box. At bash prompt, did hdparm -K1 -S240 /dev/hdb Shur down PC. Put drive back in USB
          Message 4 of 11 , Dec 3, 2005
          • 0 Attachment
            --- In nslu2-linux@yahoogroups.com, "zhyla" <nbm_clan@y...> wrote:
            >
            > Bharat, if you keep this up I'm going to have to get off my butt and
            > do this to my drive :)
            >
            > It doesn't look like hdparm has a documented way of querying the -S
            > value. But what you want to do is put it back in the enclosure, power
            > it up and see if after ten minutes the drive stops spinning. It
            > should spin up automatically when there is disk activity and then when
            > there is none it should spin back down when it is idle.
            >
            > hdparm absolutely, positively, 100% will not work on a USB drive, so
            > it's pretty useless to package it for either distribution.
            >
            > Zhyla
            >

            Zhyla:

            I did this one more time. Put the drive back in PC linux box.

            At bash prompt, did "hdparm -K1 -S240 /dev/hdb"

            Shur down PC. Put drive back in USB enclosure.

            After some inactivity the drive goes back in low RPM idle (you can hear
            some clicks when that happens) but no complete stop. I waited the whole
            night (not quite, I did sleep). In the morning it was still spinning
            but very low rpm.

            Looks like hitachi has changed somethin in their 400GB and up drives.
            This is what I found from Silentpc review of Hitachi 400 GB review
            (http://www.silentpcreview.com/article256-page2.html)

            "The high noise and power draw meant I was looking forward to seeing
            how effective the Low RPM mode would be on this drive. So, I duly
            enabled it in the APM section of Hitachi's feature tool, and waited.
            And waited. And, no matter how long I waited, I never heard the heads
            park or the disk spin down. For whatever reason, the drive never
            entered Low RPM mode even after sitting idle for two or more hours —
            far longer than it took for the 7K250 to enter this mode.

            So finally I am giving up.

            Thanks again for all your help. You have been very kind.

            Bharat
          Your message has been successfully submitted and would be delivered to recipients shortly.