Loading ...
Sorry, an error occurred while loading the content.

25195Re: [nslu2-linux] More recent build of hplip? [1 Attachment]

Expand Messages
  • Craig Noble
    Dec 29, 2013
    Alex,

    While libusb1 is a great addition, it's not needed to build the most recent hplip.

    You can use the configure option "--enable-libusb01_build".

    Makefile attached.

    Also, did you find out who to get a key from? I have several patches for broken download links.

    Cheers,
    Craig.


    On Sunday, December 29, 2013 5:46 PM, Alex Potapenko <opotapenko@...> wrote:
     
    [Attachment(s) from Alex Potapenko included below]
    I also made another mistake: a trailing slash in the LIBUSB1_SITE variable value, leading to a double slash in the address passed on to wget and an HTTP 404 error as a result.

    That being sad, here's the fixed version


    2013/12/29 Alex Potapenko <opotapenko@...>
    Hello Paul,

    Sorry for the sane-related comments. I used libusb.mk as a basis for writing libusb1.mk, and replaced the header comments containing libusb package versions history with the usual stuff, like the one in template.mk. Took it from sane-backends.mk, since I was upgrading it to v1.0.24 a little earlier. Just forgot to replace all occurrences



    Peter,

    I've built hplip-3.13.11 and libusb-1.0.9 for cs08q1armel target. You can give them a go if you want to:


    Hope it works



    --
    Best regards,
    Alex Potapenko


  • Show all 11 messages in this topic