Loading ...
Sorry, an error occurred while loading the content.

24781updating kernel - /dev/mtdblock3 is not a block device

Expand Messages
  • e_zago
    Feb 20, 2011
      Greetings -

      My NSLU2 has been running lenny for some time; this morning I changed my sources.list to squeeze - ran apt-get-update and apt-get dist-upgrade. That went smoothly, except for the dependency-based services error, but I was able to correct that after the upgrade was done.

      However - as I noticed that no kernel upgrade was included in the upgrade. My currently installed kernel is: linux-image-2.6.26-2-ixp4xx

      However - as I noticed that the current version available from Debian is linux-image-2.6.32-5-ixp4xx - which is referred to by the meta-package linux-image-ixp4xx.

      So - I ran sudo apt-get install linux-image-ixp4xx - and the installation fails with the following error message:
      --------------Begin Copied Error Message-----------------

      eric@stowage:~$ sudo apt-get install linux-image-ixp4xx
      [sudo] password for eric:
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      linux-image-ixp4xx is already the newest version.
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      3 not fully installed or removed.
      After this operation, 0 B of additional disk space will be used.
      Do you want to continue [Y/n]? y
      Setting up linux-image-2.6.32-5-ixp4xx (2.6.32-30) ...
      Running depmod.
      Running update-initramfs.
      update-initramfs: Generating /boot/initrd.img-2.6.32-5-ixp4xx
      initrd.img(/boot/initrd.img-2.6.32-5-ixp4xx
      ) points to /boot/initrd.img-2.6.32-5-ixp4xx
      (/boot/initrd.img-2.6.32-5-ixp4xx) -- doing nothing at
      /var/lib/dpkg/info/linux-image-2.6.32-5-ixp4xx.postinst line 347.
      vmlinuz(/boot/vmlinuz-2.6.32-5-ixp4xx
      ) points to /boot/vmlinuz-2.6.32-5-ixp4xx
      (/boot/vmlinuz-2.6.32-5-ixp4xx) -- doing nothing at
      /var/lib/dpkg/info/linux-image-2.6.32-5-ixp4xx.postinst line 347.
      Running flash-kernel.
      /dev/mtdblock3 is not a block device
      User postinst hook script [flash-kernel] exited with value 1
      dpkg: error processing linux-image-2.6.32-5-ixp4xx (--configure):
      subprocess installed post-installation script returned error exit status 1
      configured to not write apport reports
      dpkg: dependency problems prevent
      configuration of linux-image-2.6-ixp4xx:
      linux-image-2.6-ixp4xx depends on linux-image-2.6.32-5-ixp4xx; however:
      Package linux-image-2.6.32-5-ixp4xx is not configured yet.
      dpkg: error processing linux-image-2.6-ixp4xx (--configure):
      dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of linux-image-ixp4xx:
      linux-image-ixp4xx depends on linux-image-2.6.32-5-ixp4xx; however:
      Package linux-image-2.6.32-5-ixp4xx is not configured yet.
      dpkg: error processing linux-image-ixp4xx (--configure):
      dependency problems - leaving unconfigured
      configured to not write apport reports
      configured to not write apport reports

      Errors were encountered while processing:
      linux-image-2.6.32-5-ixp4xx
      linux-image-2.6-ixp4xx
      linux-image-ixp4xx
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      ----------End Copied Error Output-------------
      I've searched both here and on Debian's forums - but can't find any mention of this problem. For now - the device continues to boot the 2.6.26 kernel reliably - but seems to be in a broken state since it things the updated kernel package is installed.

      Thanks in advance for any suggestions!

      -Eric
    • Show all 4 messages in this topic