Loading ...
Sorry, an error occurred while loading the content.

24480Re: [nslu2-linux] Re: Help with IceS - PERL quesion

Expand Messages
  • M.J. Johnson
    May 18, 2010
         I managed to get the binary from the "unstable" optware ipkg feed.  The new ices0 build is working perfectly with my Perl script.

         Thanks for the extended amount of support from this community, and especially from Robert and Brian.  I'm extremely grateful to have this technical problem well in hand now.

      On Tue, May 18, 2010 at 1:06 PM, Robert Hammond <robham@...> wrote:
       

      I have never seen this before but over the years I have needed to used
      the force install option with some packages, needed to overcome similar
      problems.

      I think the command line should be something like :-

      ipkg install -force-depends path/package_name_goes_here.ipk

      If you type

      ipkg --help

      will give a list of the command line options.

      In message
      <AANLkTinGgqCSsOrEQu_moi5NW3JpM1HDFk9wiMnFjsak@...>, M.J.

      Johnson <threeeyedtoad@...> writes
      > Dang it. Same result...
      >
      ># ipkg install ./ices0_0.4-2_armeb.ipk
      >Installing ices0 (0.4-2) to root...
      >Nothing to be done
      >Collected errors:
      >Multiple packages (ices0 and ices0) providing same name marked HOLD or
      >PREFER. Using latest.
      >Package ices0 md5sum mismatch. Either the ipkg or the package index are
      >corrupt. Try 'ipkg update'.
      >
      > I think the real problem here is we're getting md5sum mismatches. Any
      >insight among the community on how to avoid?
      >
      > Thanks for the help making the build, Robert!
      >
      >
      >On Sun, May 16, 2010 at 2:27 PM, Robert Hammond <robham@...> wrote:
      >
      >> Whoops
      >>
      >> I built both the old version and also the new version, but accidentally
      >> sent the old version.
      >>
      >> New version attached to this email
      >>
      >>
      >>
      >>
      >> In message <AANLkTimTnQZ_h_EEpPp1u0GmLrmya6Gbp7wL6zmVcNIJ@...>,
      >> M.J. Johnson <threeeyedtoad@...> writes
      >>
      >>> Thanks so much, Robert. I went ahead and attempted to install the ipk
      >>> you sent. Here's what I got: I wasn't entirely sure how to install a
      >>> local
      >>> ipk, so I went with the following:
      >>>
      >>> # ipkg install ./ices0_0.4-1_armeb.ipk
      >>> Installing ices0 (0.4-1) to root...
      >>> Nothing to be done
      >>> Collected errors:
      >>> Multiple packages (ices0 and ices0) providing same name marked HOLD or
      >>> PREFER. Using latest.
      >>> Package ices0 md5sum mismatch. Either the ipkg or the package index are
      >>> corrupt. Try 'ipkg update'.
      >>>
      >>> So, it looks like perhaps there is a version conflict? Not really sure.
      >>>
      >>> Again, thanks for all the assistance...
      >>>
      >>> On Wed, May 12, 2010 at 5:39 PM, Robert Hammond <robham@...>
      >>> wrote:
      >>>
      >>>
      >>>>
      >>>> I now have it built, sent by PM
      >>>>
      >>>>
      >>>> >
      >>>> >
      >>>> >I tried to build this package tonight but unfortunately Perl fails to
      >>>> >build on my build system.
      >>>> >
      >>>> >Investigating....
      >>>> >
      >>>> >In message
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>>
      >>>> >>>>>>>>>>>>>>>>>><AANLkTinL6G5YqVZaEQuhxTmdBBpAZ-3MKTsfBCMOblJh@...
      >>>> <AANLkTinL6G5YqVZaEQuhxTmdBBpAZ-3MKTsfBCMOblJh%40mail.gmail>
      >>>> .
      >>>> >com>, M.J.
      >>>> >Johnson <threeeyedtoad@... <threeeyedtoad%40gmail.com>> writes
      >>>> >> Anyone? Pretty please?
      >>>> >>
      >>>> >>On Mon, May 10, 2010 at 12:19 PM, M.J. Johnson <threeeyedtoad@
      >>>> >gmail.com>wrote:
      >>>> >>
      >>>> >>> Following up on this thread from last month, and taking the
      >>>> suggestion
      >>>> >>> Brian offered - is there anyone who has a build environment up and
      >>>> >running
      >>>> >>> that would allow them to build the ipk binary I require (of ices0)?
      >>>> If
      >>>> so,
      >>>> >>> would you care to share? The ipkg feed has not updated in the last
      >>>> two
      >>>> >>> weeks with the updated ipk I seek...
      >>>> >>>
      >>>> >>> TIA...
      >>>> >>>
      >>>> >>> On Thu, Apr 29, 2010 at 7:07 PM, Brian >>><b88zhou@...
      >>>> <b88zhou%40gmail.com>
      >>>> >
      >>>> >wrote:
      >>>> >>>
      >>>> >>>>
      >>>> >>>>
      >>>> >>>> http://trac.nslu2-linux.org/optware/changeset/11582
      >>>> >>>>
      >>>> >>>> (took a little hack in adding the perl support because of cross
      >>>> >>>> compilation)
      >>>> >>>>
      >>>> >>>> Our autobuilder is having some problem. So the ipkg won't appear in
      >>>> >the
      >>>> >>>> feeds for a few days.
      >>>> >>>>
      >>>> >>>> If you cannot wait, try setup a build environment and build the ipk
      >>>> >binary
      >>>> >>>> yourself. Or ask some one to build it for you.
      >>>> >>>>
      >>>> >>>> Regards,
      >>>> >>>>
      >>>> >>>> -Brian
      >>>> >>>>
      >>>> >>>>
      >>>> >>>> --- In nslu2-linux@yahoogroups.com >>>><nslu2-linux%
      >>>> 40yahoogroups.com><nslu2-linux%40yahoogroups.
      >>>> >com>,
      >>>> >>>> "threeeyedtoad" <threeeyedtoad@...> wrote:
      >>>> >>>> >
      >>>> >>>> > I believe I'm very, very close to solving the problem of streaming
      >>>> >music
      >>>> >>>> via icecast while using mpd as the playlist manager - with no
      >>>> >transcoding.
      >>>> >>>> >
      >>>> >>>> > My success currently seems to hinge on being able to use a PERL
      >>>> >module
      >>>> >>>> written for use with Ices0.
      >>>> >>>> >
      >>>> >>>> > I've successfully installed Ices0 (0.4-1) from the ipkg feed for
      >>>> >>>> unslung. However, when I attempt to use ices with the PERL module I
      >>>> >have, I
      >>>> >>>> receive this message:
      >>>> >>>> >
      >>>> >>>> > Initialization of playlist handler failed. [This binary has no
      >>>> support
      >>>> >>>> for embedded perl]
      >>>> >>>> > Ices Exiting...
      >>>> >>>> >
      >>>> >>>> > A quick search on this error reveals that I may be looking at a
      >>>> >>>> re-compile:
      >>>> >>>> >
      >>>> >>>> > http://icecast.imux.net/viewtopic.php?t=6799
      >>>> >>>> >
      >>>> >>>> > http://svn.xiph.org/icecast/trunk/ices0/INSTALL
      >>>> >>>> >
      >>>> >>>> > I know Ices does work on my Slug without attempting to use the
      >>>> >PERL
      >>>> >>>> module, as I've tested it with Icecast, and it works fine.
      >>>> >>>> >
      >>>> >>>> > Please, please - would it be possible for the maintainer of the
      >>>> ipkg
      >>>> >>>> feed to add in support for PERL to Ices0?
      >>>> >>>> >
      >>>> >>>> > It all feels so very, very close...
      >>>> >>>> >
      >>>> >>>>
      >>>> >>>>
      >>>> >>>>
      >>>> >>>
      >>>> >>>
      >>>>
      >>>> --
      >>>> Robert Hammond
      >>>> PGP:0x154144DA
      >>>> 592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA
      >>>>
      >>>>
      >>>>
      >> --
      >> Robert Hammond
      >> PGP:0x154144DA
      >> 592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA
      >>
      >>

      --
      Robert Hammond
      PGP:0x154144DA
      592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA

    • Show all 20 messages in this topic