Loading ...
Sorry, an error occurred while loading the content.

23590Re: jamvm (Java VM) on SlugOS ==> "ld.so does not support TLS, but program uses

Expand Messages
  • Brian Zhou
    Apr 10, 2009
      > The reason is straight-forward. JamVM 1.5.2 requires GNU Classpath 0.98, but the installed Classpath is 0.97.2. As GNU Classpath is Java, you can't check versions at configure time. Compatible versions are listed in the README, but this is less than ideal.
      >
      > I tested building Classpath 0.98 and everything worked OK. However, you will need to modify the upstream site listed in classpath.mk from http://builder.classpath.org/dist to ftp://ftp.gnu.org/gnu/classpath, as 0.98 doesn't exist on builder (ftp.gnu.org is the official download location).
      >

      Thanks Rob, I've upgraded classpath to 0.98 (requires downloading of antlr.jar at build time), and have jamvm depends on classpath (>=0.98). It will be in all feeds in an hour or so.

      Best regards,

      -Brian
    • Show all 19 messages in this topic