Loading ...
Sorry, an error occurred while loading the content.

23561RE: [nslu2-linux] jamvm (Java VM) on SlugOS ==> "ld.so does not support TLS, but program uses it"

Expand Messages
  • Jan
    Apr 8, 2009
    • 0 Attachment

      Thanks. At this point I need to ask: What is TLS? Or is my slug really asking for a bit of TLC? ;-)

       

      From: nslu2-linux@yahoogroups.com [mailto:nslu2-linux@yahoogroups.com] On Behalf Of S├ębastien Lorquet
      Sent: Wednesday, April 08, 2009 8:31 AM
      To: nslu2-linux@yahoogroups.com
      Subject: Re: [nslu2-linux] jamvm (Java VM) on SlugOS ==> "ld.so does not support TLS, but program uses it"

       

      If ld.so does not support TLS, then I suppose you need a ld.so that supports TLS :)

      An option should be to upgrade this particular spark plug from the same one of another distribution, but it sounds a bit dangerous to me.

      Sebastien

      On Wed, Apr 8, 2009 at 2:02 PM, Jan Stanger <jan.stanger@...> wrote:

      Thanks for this suggestion. But it sounds more like replacing the engine of a car if all it takes is changing the spark plugs. SlugOS 3.10 has been running without a hitch for the last 2+ years on my NSLU2, and if not being able to run Java programs on it is the only drawback, then I will probably live with it (for now). J

       

      Perhaps there is another and simpler way to fix this (hint: spark plugs)? J

       

      Thanks

      -J

       

       

      From: nslu2-linux@yahoogroups.com [mailto:nslu2-linux@yahoogroups.com] On Behalf Of S├ębastien Lorquet
      Sent: Wednesday, April 08, 2009 1:42 AM
      To: nslu2-linux@yahoogroups.com
      Subject: Re: [nslu2-linux] jamvm (Java VM) on SlugOS ==> "ld.so does not support TLS, but program uses it"

       

      The first suggestion would be to drop slugos 3.10 and use Slugos 5.3 from http://www.slug-firmware.net/ (you'll notice that SlugOS 3 is release N-2 :) )
      After this, you may find that some bugs were resolved :)

      On Wed, Apr 8, 2009 at 5:28 AM, obi_jan <nslu2-linux@...> wrote:

      Hello!

      I was following the instructions on this page here to install Java on my NSLU2 under SlugOS 3.10: http://www.dpembo.ukfsn.org/2008/08/28/java-compiler-vm-on-the-nslu2/

      However, when I call 'jamvm', this error message appears:

      root@FileServer:~# jamvm
      ld.so does not support TLS, but program uses it!

      What a shame, I really wanted to run VideoLANs VLMa web interface: http://www.videolan.org/vlma/doc/setup.html

      Any suggestions?
      -J




      ------------------------------------

      Yahoo! Groups Links

      <*> To visit your group on the web, go to:
         http://groups.yahoo.com/group/nslu2-linux/

      <*> Your email settings:
         Individual Email | Traditional

      <*> To change settings online go to:
         http://groups.yahoo.com/group/nslu2-linux/join
         (Yahoo! ID required)

      <*> To change settings via email:
         mailto:nslu2-linux-digest@yahoogroups.com
         mailto:nslu2-linux-fullfeatured@yahoogroups.com

      <*> To unsubscribe from this group, send an email to:
         nslu2-linux-unsubscribe@yahoogroups.com

      <*> Your use of Yahoo! Groups is subject to:
         http://docs.yahoo.com/info/terms/

       

       

       

    • Show all 19 messages in this topic