Loading ...
Sorry, an error occurred while loading the content.

23556slug usb controller hurt?

Expand Messages
  • S├ębastien Lorquet
    Apr 8, 2009
      Hi,

      I just left my slug up and running a few days, nothing special, just a small usb stick connected.

      This morning, I wanted to ssh into in. Impossible to connect. The first thing I try is power down, remove the usb stick, boot from flash.
      It was all ok, the slug is working.

      Then, I plug my usb stick in usb port 2 (next to ethernet socket)

      This results in immediate lockup, ssh connection is lost.
      The only thing I can do is remove the power and restart.
      The same results happens if I connect ANY usb stick in ANY port.
      I also tried to reflash with a fresh slugosbe 5.3 binary.

      I suspect the usb controller is dead or hurt. But how is it possible? heat? The slug was not moved, not shocked, not in a hot place, etc

      I hope I'll find a oops on the serial console.
      I don't have one now, i'm going to try to solder a row of pins and get a 3.3v rs232 adapter. I hope FTDI USBMODs are ok with 3.3V, this could save me a lot of worries.

      Any idea on this sudden usb death?

      Sebastien

      PS: the problem is partial, when I plug a smart card reader in port 1 (next to power) I get:
      usb 2-1: new full speed USB device using ohci_hcd and address 2
      usb 2-1: configuration #1 chosen from 1 choice

      and when I plug the same card reader in port 2 (next to ethernet) I get the slug locked.
      Argh, Sometimes the slug dies when I plug the reader in port 1 too.

    • Show all 16 messages in this topic