Loading ...
Sorry, an error occurred while loading the content.

23307Re: Using ddclient on SlugOS/BE 4.8 Beta. Is this possible?

Expand Messages
  • Brian Zhou
    Mar 5, 2009
    • 0 Attachment
      On slugos, don't add optware ipkg source to /etc/ipkg/any.conf, the two ipkg repos are not designed to be managed with the same ipkg db (package name and file path may conflict). Instead, follow http://www.nslu2-linux.org/wiki/Optware/Slugosbe

      Right now, to differentiate from optware/slugos5be, optware/slugosbe feed has been renamed to optware/slugos4be. The old optware/slugosbe name will eventually go away.

      -Brian

      --- In nslu2-linux@yahoogroups.com, "bettega_stefano" <bettega_stefano@...> wrote:
      >
      > Hi,
      > I just installed SlugOS/BE 4.8 Beta on my NSLU2, with samba and ntpclient using ipkg.
      >
      > I installed ez-ipupdate, but figured out it doesn't work for my network, as NSLU2 is connected to a router and ez-ipupdate only gets my eth0 local address and not my public address (the only way to make it work is by applying a patch to ez-ipupdate).
      >
      > So I decided to use ddclient, but ddclient did not appear in my ipkg list. I was wondering if I could add more repositories to my ipkg configuration. I added the new source "http://ipkg.nslu2-linux.org/feeds/unslung/cross/" into my ipkg configuration directory, did an ipkg update and then ddclient appeared in my ipkg list. I did an ipkg install ddclient, and it worked: ddclient was installed into /opt/sbin, and also perl was downloaded...
      >
      > ... but it doesn't work. I configured ddclient in /opt/etc/ddclient.conf, but when i start ddclient from command line, there are some error in compiling perl script. Am I doing the right thing? In fact any SlugOS/BE package ends with -armv5teb, while unslung packages ends with -armeb. Are those architectures compatible? Is there any other option to set up?
      >
      > Thanks
      >
    • Show all 4 messages in this topic