Loading ...
Sorry, an error occurred while loading the content.

19992Re: [nslu2-linux] Installing linux-image-2.6-ixp4xx on NSLU2

Expand Messages
  • Martin Michlmayr
    Oct 22, 2007
    • 0 Attachment
      * peterb <peterb@...> [2007-10-22 02:54]:
      > slug:~# uname -a
      > Linux slug 2.6.18-4-ixp4xx #1 Sun Apr 22 08:34:11 UTC 2007 armv5tel

      So you're (almost) running the latest kernel. There's a
      2.6.18-5-ixp4xx update but that currently won't get installed
      automatically linux-image-2.6-ixp4xx still points to 2.6.18-4-ixp4xx
      rather than 2.6.18-5-ixp4xx. (That bug is the reason the installer
      currently doesn't work.)

      You can manually install that with:

      apt-get install linux-image-2.6.18-5-ixp4xx

      > slug:~# cat /proc/mtd
      > dev: size erasesize name
      > mtd0: 00040000 00020000 "RedBoot"
      > mtd1: 00020000 00020000 "SysConf"
      > mtd2: 00020000 00020000 "Loader"

      This shows that you have the modern flash layout (Loader is where APEX
      is put).

      So just keep on using apt-get update/upgrade. I'll clarify
      http://www.cyrius.com/debian/nslu2/upgrade.html to say who this
      applies to.
      --
      Martin Michlmayr
      http://www.cyrius.com/
    • Show all 4 messages in this topic