Loading ...
Sorry, an error occurred while loading the content.

RE: [nslu2-general] Re: Telnet Problem

Expand Messages
  • Inge Bjørnvall Arnesen
    That sounds reasonable too, unless you went into the web interface first and enabled it. It will be disabled on each reboot and you have to make a diversion
    Message 1 of 9 , Mar 7, 2005
    • 0 Attachment
      That sounds reasonable too, unless you went into the web interface first and
      enabled it. It will be disabled on each reboot and you have to make a
      diversion script if you want telnet enabled. Luckily there is dropbear (ssh)
      which is much better, that you can install once you get in. Follow the
      README that came with the Unlung firmware to every detail.

      best,

      -- Inge


      ----Original Message----
      From: raylittle [mailto:ray@...]
      Sent: 7. mars 2005 10:39
      To: nslu2-general@yahoogroups.com
      Subject: [nslu2-general] Re: Telnet Problem

      > --- In nslu2-general@yahoogroups.com, "Gerald L. Clark"
      > I tried 'C:>telnet 192.168.1.77' and received the message:
      >
      > Connecting To 192.168.1.77...Could not open connection to
      > the host, on port 23: Connect failed
      >
      > Under Linux entered '$ telnet 192.168.1.77' ang got the
      > message:
      > telnet: Unable to connect to remote host: Connection
      > refused
      >
      > Ray
      > <gerald_clark@m...> wrote:
      > > raylittle wrote:
      > > >
      > > >
      > > > My NSLU2 now has firmware
      > > > V2.3R25-uNSLUng-standard-3.18-beta. I'm trying to
      > > > telnet to it (no disk attached) from a PC running
      > > > Libranet
      > > > 2.8.1 and get the result:
      > > >
      > > > $ telnet 192.168.1.77 <port #>
      > > And just what port number is that? 80?
      > > Port 80 is thttpd on the NSLU2.
      > > Telnetd runs on port 23.
      > > > Connected to 192.168.1.77.
      > > > Excape character is '^]'.
      > > > _
      > > >
      > > > I was expecting some kind of prompt but all I see is
      > > > the cursor and it seems like anything I enter causes
      > > > me to get the message:
      > > >
      > > > UNKNOWN 400 Bad Request
      > > > Server: thttpd
      > > > Content-Type: text/html
      > > > Date: ...
      > > > Last-Modified: ...
      > > > Accept-Range: bytes
      > > > Connection: close
      > > > <HTML>
      > > > ....
      > > > </HTML>
      > > >
      > > > Connection closed by foreign host.
      > > >
      > > > I also tried from WinXP with basically the same
      > > > result.
      > > >
      > > > TIA,
      > > > Ray
      > > >
      > > > P.S. I work on a Linux system but I'm not a guru.
      > > >
      >
      >
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
    • raylittle
      ... That was indeed the problem. I forgot that I had rebooted the NSLU2. I had to re-enable telnet. Unfortunately, the password uNSLUng didn t work for root.
      Message 2 of 9 , Mar 7, 2005
      • 0 Attachment
        --- In nslu2-general@yahoogroups.com, Inge Bjørnvall Arnesen
        That was indeed the problem. I forgot that I had rebooted the NSLU2.
        I had to re-enable telnet. Unfortunately, the password uNSLUng
        didn't work for root. I probably did something wrong. I'll research
        it later today.

        Thanks,
        Ray
        <i.b.arnesen@f...> wrote:
        > That sounds reasonable too, unless you went into the web interface
        first and
        > enabled it. It will be disabled on each reboot and you have to make a
        > diversion script if you want telnet enabled. Luckily there is
        dropbear (ssh)
        > which is much better, that you can install once you get in. Follow the
        > README that came with the Unlung firmware to every detail.
        >
        > best,
        >
        > -- Inge
        >
        >
        > ----Original Message----
        > From: raylittle [mailto:ray@r...]
        > Sent: 7. mars 2005 10:39
        > To: nslu2-general@yahoogroups.com
        > Subject: [nslu2-general] Re: Telnet Problem
        >
        > > --- In nslu2-general@yahoogroups.com, "Gerald L. Clark"
        > > I tried 'C:>telnet 192.168.1.77' and received the message:
        > >
        > > Connecting To 192.168.1.77...Could not open connection to
        > > the host, on port 23: Connect failed
        > >
        > > Under Linux entered '$ telnet 192.168.1.77' ang got the
        > > message:
        > > telnet: Unable to connect to remote host: Connection
        > > refused
        > >
        > > Ray
        > > <gerald_clark@m...> wrote:
        > > > raylittle wrote:
        > > > >
        > > > >
        > > > > My NSLU2 now has firmware
        > > > > V2.3R25-uNSLUng-standard-3.18-beta. I'm trying to
        > > > > telnet to it (no disk attached) from a PC running
        > > > > Libranet
        > > > > 2.8.1 and get the result:
        > > > >
        > > > > $ telnet 192.168.1.77 <port #>
        > > > And just what port number is that? 80?
        > > > Port 80 is thttpd on the NSLU2.
        > > > Telnetd runs on port 23.
        > > > > Connected to 192.168.1.77.
        > > > > Excape character is '^]'.
        > > > > _
        > > > >
        > > > > I was expecting some kind of prompt but all I see is
        > > > > the cursor and it seems like anything I enter causes
        > > > > me to get the message:
        > > > >
        > > > > UNKNOWN 400 Bad Request
        > > > > Server: thttpd
        > > > > Content-Type: text/html
        > > > > Date: ...
        > > > > Last-Modified: ...
        > > > > Accept-Range: bytes
        > > > > Connection: close
        > > > > <HTML>
        > > > > ....
        > > > > </HTML>
        > > > >
        > > > > Connection closed by foreign host.
        > > > >
        > > > > I also tried from WinXP with basically the same
        > > > > result.
        > > > >
        > > > > TIA,
        > > > > Ray
        > > > >
        > > > > P.S. I work on a Linux system but I'm not a guru.
        > > > >
        > >
        > >
        > >
        > >
        > >
        > >
        > > Yahoo! Groups Links
        > >
        > >
        > >
      • Inge Bjørnvall Arnesen
        In the readme it says to boot _without disks connected_, enable telnet and login _before_ connecting disks. Did you follow that procedure? If not, shame on
        Message 3 of 9 , Mar 7, 2005
        • 0 Attachment
          In the readme it says to boot _without disks connected_, enable telnet and
          login _before_ connecting disks. Did you follow that procedure? If not,
          shame on you. ByronT's readme rules and commands respect! It says all of
          these things in minute detail.

          best,

          -- Inge


          ----Original Message----
          From: raylittle [mailto:ray@...]
          Sent: 7. mars 2005 13:06
          To: nslu2-general@yahoogroups.com
          Subject: [nslu2-general] Re: Telnet Problem

          > --- In nslu2-general@yahoogroups.com, Inge Bjørnvall
          > Arnesen
          > That was indeed the problem. I forgot that I had
          > rebooted the NSLU2. I had to re-enable telnet.
          > Unfortunately, the password uNSLUng didn't work for root.
          > I probably did something wrong. I'll research it later
          > today.
          >
          > Thanks,
          > Ray
          > <i.b.arnesen@f...> wrote:
          > > That sounds reasonable too, unless you went into the
          > > web interface
          > first and
          > > enabled it. It will be disabled on each reboot and you
          > > have to make a diversion script if you want telnet
          > > enabled. Luckily there is
          > dropbear (ssh)
          > > which is much better, that you can install once you get
          > > in. Follow the README that came with the Unlung
          > > firmware to every detail.
          > >
          > > best,
          > >
          > > -- Inge
          > >
          > >
          > > ----Original Message----
          > > From: raylittle [mailto:ray@r...]
          > > Sent: 7. mars 2005 10:39
          > > To: nslu2-general@yahoogroups.com
          > > Subject: [nslu2-general] Re: Telnet Problem
          > >
          > > > --- In nslu2-general@yahoogroups.com, "Gerald L.
          > > > Clark"
          > > > I tried 'C:>telnet 192.168.1.77' and received the
          > > > message:
          > > >
          > > > Connecting To 192.168.1.77...Could not open
          > > > connection to the host, on port 23: Connect failed
          > > >
          > > > Under Linux entered '$ telnet 192.168.1.77' ang got
          > > > the
          > > > message:
          > > > telnet: Unable to connect to remote host: Connection
          > > > refused
          > > >
          > > > Ray
          > > > <gerald_clark@m...> wrote:
          > > > > raylittle wrote:
          > > > > >
          > > > > >
          > > > > > My NSLU2 now has firmware
          > > > > > V2.3R25-uNSLUng-standard-3.18-beta. I'm trying to
          > > > > > telnet to it (no disk attached) from a PC running
          > > > > > Libranet
          > > > > > 2.8.1 and get the result:
          > > > > >
          > > > > > $ telnet 192.168.1.77 <port #>
          > > > > And just what port number is that? 80?
          > > > > Port 80 is thttpd on the NSLU2.
          > > > > Telnetd runs on port 23.
          > > > > > Connected to 192.168.1.77.
          > > > > > Excape character is '^]'.
          > > > > > _
          > > > > >
          > > > > > I was expecting some kind of prompt but all I see
          > > > > > is the cursor and it seems like anything I enter
          > > > > > causes me to get the message:
          > > > > >
          > > > > > UNKNOWN 400 Bad Request
          > > > > > Server: thttpd
          > > > > > Content-Type: text/html
          > > > > > Date: ...
          > > > > > Last-Modified: ...
          > > > > > Accept-Range: bytes
          > > > > > Connection: close
          > > > > > <HTML>
          > > > > > ....
          > > > > > </HTML>
          > > > > >
          > > > > > Connection closed by foreign host.
          > > > > >
          > > > > > I also tried from WinXP with basically the same
          > > > > > result.
          > > > > >
          > > > > > TIA,
          > > > > > Ray
          > > > > >
          > > > > > P.S. I work on a Linux system but I'm not a guru.
          > > > > >
          > > >
          > > >
          > > >
          > > >
          > > >
          > > >
          > > > Yahoo! Groups Links
          > > >
          > > >
          > > >
          >
          >
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
        • raylittle
          ... I followed all the rules. However, it turns out I wasn t entering the telnet command correctly so I reconnected the hard disk (I do have work to do) until
          Message 4 of 9 , Mar 7, 2005
          • 0 Attachment
            --- In nslu2-general@yahoogroups.com, Inge Bjørnvall Arnesen
            I followed all the rules. However, it turns out I wasn't entering the
            telnet command correctly so I reconnected the hard disk (I do have
            work to do) until I could get more time to continue working on the setup.

            Ray
            <i.b.arnesen@f...> wrote:
            > In the readme it says to boot _without disks connected_, enable
            telnet and
            > login _before_ connecting disks. Did you follow that procedure? If not,
            > shame on you. ByronT's readme rules and commands respect! It says all of
            > these things in minute detail.
            >
            > best,
            >
            > -- Inge
            >
            >
            > ----Original Message----
            > From: raylittle [mailto:ray@r...]
            > Sent: 7. mars 2005 13:06
            > To: nslu2-general@yahoogroups.com
            > Subject: [nslu2-general] Re: Telnet Problem
            >
            > > --- In nslu2-general@yahoogroups.com, Inge Bjørnvall
            > > Arnesen
            > > That was indeed the problem. I forgot that I had
            > > rebooted the NSLU2. I had to re-enable telnet.
            > > Unfortunately, the password uNSLUng didn't work for root.
            > > I probably did something wrong. I'll research it later
            > > today.
            > >
            > > Thanks,
            > > Ray
            > > <i.b.arnesen@f...> wrote:
            > > > That sounds reasonable too, unless you went into the
            > > > web interface
            > > first and
            > > > enabled it. It will be disabled on each reboot and you
            > > > have to make a diversion script if you want telnet
            > > > enabled. Luckily there is
            > > dropbear (ssh)
            > > > which is much better, that you can install once you get
            > > > in. Follow the README that came with the Unlung
            > > > firmware to every detail.
            > > >
            > > > best,
            > > >
            > > > -- Inge
            > > >
            > > >
            > > > ----Original Message----
            > > > From: raylittle [mailto:ray@r...]
            > > > Sent: 7. mars 2005 10:39
            > > > To: nslu2-general@yahoogroups.com
            > > > Subject: [nslu2-general] Re: Telnet Problem
            > > >
            > > > > --- In nslu2-general@yahoogroups.com, "Gerald L.
            > > > > Clark"
            > > > > I tried 'C:>telnet 192.168.1.77' and received the
            > > > > message:
            > > > >
            > > > > Connecting To 192.168.1.77...Could not open
            > > > > connection to the host, on port 23: Connect failed
            > > > >
            > > > > Under Linux entered '$ telnet 192.168.1.77' ang got
            > > > > the
            > > > > message:
            > > > > telnet: Unable to connect to remote host: Connection
            > > > > refused
            > > > >
            > > > > Ray
            > > > > <gerald_clark@m...> wrote:
            > > > > > raylittle wrote:
            > > > > > >
            > > > > > >
            > > > > > > My NSLU2 now has firmware
            > > > > > > V2.3R25-uNSLUng-standard-3.18-beta. I'm trying to
            > > > > > > telnet to it (no disk attached) from a PC running
            > > > > > > Libranet
            > > > > > > 2.8.1 and get the result:
            > > > > > >
            > > > > > > $ telnet 192.168.1.77 <port #>
            > > > > > And just what port number is that? 80?
            > > > > > Port 80 is thttpd on the NSLU2.
            > > > > > Telnetd runs on port 23.
            > > > > > > Connected to 192.168.1.77.
            > > > > > > Excape character is '^]'.
            > > > > > > _
            > > > > > >
            > > > > > > I was expecting some kind of prompt but all I see
            > > > > > > is the cursor and it seems like anything I enter
            > > > > > > causes me to get the message:
            > > > > > >
            > > > > > > UNKNOWN 400 Bad Request
            > > > > > > Server: thttpd
            > > > > > > Content-Type: text/html
            > > > > > > Date: ...
            > > > > > > Last-Modified: ...
            > > > > > > Accept-Range: bytes
            > > > > > > Connection: close
            > > > > > > <HTML>
            > > > > > > ....
            > > > > > > </HTML>
            > > > > > >
            > > > > > > Connection closed by foreign host.
            > > > > > >
            > > > > > > I also tried from WinXP with basically the same
            > > > > > > result.
            > > > > > >
            > > > > > > TIA,
            > > > > > > Ray
            > > > > > >
            > > > > > > P.S. I work on a Linux system but I'm not a guru.
            > > > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > > Yahoo! Groups Links
            > > > >
            > > > >
            > > > >
            > >
            > >
            > >
            > >
            > >
            > >
            > > Yahoo! Groups Links
            > >
            > >
            > >
          • arjanvankesteren
            ... telnet and ... not, ... all of ... I too am having the same problem. Followed the readme exactly, all went well. But I did all this a few days ago and had
            Message 5 of 9 , Mar 11, 2005
            • 0 Attachment
              --- In nslu2-general@yahoogroups.com, Inge Bjørnvall Arnesen
              <i.b.arnesen@f...> wrote:
              > In the readme it says to boot _without disks connected_, enable
              telnet and
              > login _before_ connecting disks. Did you follow that procedure? If
              not,
              > shame on you. ByronT's readme rules and commands respect! It says
              all of
              > these things in minute detail.
              >
              > best,
              >
              > -- Inge

              I too am having the same problem. Followed the readme exactly, all
              went well. But I did all this a few days ago and had to connect the
              disks to be able to work (docs & mail all -and only- on the networked
              drive). Now that I've got the time to actually start using the
              potential of this thing I can't get into it any more. I'm not that
              used to Linux but every option given assumes you can Telnet into the
              box, right? Meaning diversion scripts, changing pw from commandline
              etc.
              Is there ANY way to be able to get into the box again, or do I need to
              flash another firmware first and then re-flash w/ unslung (will this
              even work)? And then change the root pw before anthing else following
              the howto? And this is me just being curious: if I do change the root
              pw before attaching the drives, won't the pw be overwritten when I do
              connect them?
            Your message has been successfully submitted and would be delivered to recipients shortly.