Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Ampache + amarok running on unslung - is it possible?

Expand Messages
  • Anthony Takata
    Hmm. Well if the requirement for mysql5 is just for names sake, you can certainly try it with mysql 4, which is in the repo. If the app is smart enough, which
    Message 1 of 4 , Apr 17, 2013
    • 0 Attachment
      Hmm. Well if the requirement for mysql5 is just for names sake, you can
      certainly try it with mysql 4, which is in the repo. If the app is smart
      enough, which version of mysql you have shouldn't really matter.
      On Apr 17, 2013 11:16 AM, "Joao" <j-mir@...> wrote:

      > **
      >
      >
      > Hello everyone!
      >
      > I got Ampache v.3.5.4 (a �rich�, i.e., *heavy* MPD web client) running on
      > my
      > unslung 6.10 slug and connected to a pair of Hi-Fi speakers through a cheap
      > Media-C usb soundcard (kinda slow but it works!).
      >
      > I wonder if it's possible to install on top of it the media player Amarok?
      > The
      > newest 2.7 release uses mysql5 (not included yet on ipkg's repo), but
      > maybe an
      > older version (just like Ampache) that uses mysql (and not mysql5) will do
      > the job?
      >
      > Any hint or feedback about similar successful (or unsuccessful) attempts
      > would
      > be very much appreciated...
      > Salut!
      > J. Miranda
      >
      >
      >


      [Non-text portions of this message have been removed]
    • Joao
      Hi, Anthony Takata! Thanks for your feedback! In fact, mysql version that works with Ampache 3.4.5 on the unslung slug is actually version 4 (more prec.:
      Message 2 of 4 , Apr 18, 2013
      • 0 Attachment
        Hi, Anthony Takata! Thanks for your feedback!

        In fact, mysql version that works with Ampache 3.4.5 on the unslung slug is actually version 4 (more prec.: v.4.1.22-3); it is incompatible with mysql5, which is a different software (ipkg will warn you about that at install if it detects that you have already one of them installed )...

        Have you ever tried to install/run Amarok on the slug? If yes, could you share that how-to) Also, which webclient for use with mpd would you recommend?

        Cheers
        João


        --- In nslu2-general@yahoogroups.com, Anthony Takata <htwiz2002@...> wrote:
        >
        > Hmm. Well if the requirement for mysql5 is just for names sake, you can
        > certainly try it with mysql 4, which is in the repo. If the app is smart
        > enough, which version of mysql you have shouldn't really matter.
        > On Apr 17, 2013 11:16 AM, "Joao" <j-mir@...> wrote:
        >
        > > **
        > >
        > >
        > > Hello everyone!
        > >
        > > I got Ampache v.3.5.4 (a «rich», i.e., *heavy* MPD web client) running on
        > > my
        > > unslung 6.10 slug and connected to a pair of Hi-Fi speakers through a cheap
        > > Media-C usb soundcard (kinda slow but it works!).
        > >
        > > I wonder if it's possible to install on top of it the media player Amarok?
        > > The
        > > newest 2.7 release uses mysql5 (not included yet on ipkg's repo), but
        > > maybe an
        > > older version (just like Ampache) that uses mysql (and not mysql5) will do
        > > the job?
        > >
        > > Any hint or feedback about similar successful (or unsuccessful) attempts
        > > would
        > > be very much appreciated...
        > > Salut!
        > > J. Miranda
        > >
        > >
        > >
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Anthony Takata
        According to my information found using Google, Amarok seems to be a GUI application. Unfortunately, the slug is usually not able to handle GUI applications
        Message 3 of 4 , Apr 18, 2013
        • 0 Attachment
          According to my information found using Google, Amarok seems to be a GUI
          application. Unfortunately, the slug is usually not able to handle GUI
          applications much more complex than a text editor or terminal. If you would
          be using the slug as just a database slave, that might work with a little
          configuring, but I personally have not delved into that subject.

          I actually have also similarly not heard of mpd either, I'm assuming you're
          talking about Music Player Daemon. For a client, this would mean I have no
          opinion, as I don't have it in any case. ;)

          If memory serves, getting MySQL5 to work correctly requires a lot of
          finesse, as many of the binaries seg-fault when trying to run them, so
          configuration basically takes place off of the slug and you move the files
          back for running. Last time I tried migrating over though I lost most of my
          databases to corruption so if you already have MySQL4 I would highly
          recommend backing things up before trying!



          On Thu, Apr 18, 2013 at 12:51 PM, Joao <j-mir@...> wrote:

          > **
          >
          >
          >
          >
          > Hi, Anthony Takata! Thanks for your feedback!
          >
          > In fact, mysql version that works with Ampache 3.4.5 on the unslung slug
          > is actually version 4 (more prec.: v.4.1.22-3); it is incompatible with
          > mysql5, which is a different software (ipkg will warn you about that at
          > install if it detects that you have already one of them installed )...
          >
          > Have you ever tried to install/run Amarok on the slug? If yes, could you
          > share that how-to) Also, which webclient for use with mpd would you
          > recommend?
          >
          > Cheers
          > Jo�o
          >
          >
          > --- In nslu2-general@yahoogroups.com, Anthony Takata <htwiz2002@...>
          > wrote:
          > >
          > > Hmm. Well if the requirement for mysql5 is just for names sake, you can
          > > certainly try it with mysql 4, which is in the repo. If the app is smart
          > > enough, which version of mysql you have shouldn't really matter.
          > > On Apr 17, 2013 11:16 AM, "Joao" <j-mir@...> wrote:
          > >
          > > > **
          >
          > > >
          > > >
          > > > Hello everyone!
          > > >
          > > > I got Ampache v.3.5.4 (a �rich�, i.e., *heavy* MPD web client) running
          > on
          > > > my
          > > > unslung 6.10 slug and connected to a pair of Hi-Fi speakers through a
          > cheap
          > > > Media-C usb soundcard (kinda slow but it works!).
          > > >
          > > > I wonder if it's possible to install on top of it the media player
          > Amarok?
          > > > The
          > > > newest 2.7 release uses mysql5 (not included yet on ipkg's repo), but
          > > > maybe an
          > > > older version (just like Ampache) that uses mysql (and not mysql5)
          > will do
          > > > the job?
          > > >
          > > > Any hint or feedback about similar successful (or unsuccessful)
          > attempts
          > > > would
          > > > be very much appreciated...
          > > > Salut!
          > > > J. Miranda
          > > >
          > > >
          > > >
          > >
          > >
          > > [Non-text portions of this message have been removed]
          > >
          >
          >
          >


          [Non-text portions of this message have been removed]
        Your message has been successfully submitted and would be delivered to recipients shortly.