Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] problem with openslug + nslu2

Expand Messages
  • Eric CS
    df command gives me this response Filesystem 1K-blocks Used Available Use% Mounted on /dev/root 6400 5468 932 85%
    Message 1 of 9 , Feb 22, 2013
    • 0 Attachment
      df command gives me this response

      Filesystem 1K-blocks Used Available Use% Mounted on
      /dev/root 6400 5468 932 85% /initrd
      /dev/sda1 384578164 251608 364791116 0% /
      /dev/sda1 384578164 251608 364791116 0% /dev/.static/dev
      udev 2048 36 2012 2% /dev
      tmpfs 15120 0 15120 0% /var/volatile
      tmpfs 15120 0 15120 0% /dev/shm

      I'm using an external hard drive 400 gb not think it's due to lack of space
      .. perhaps the downloads directory hosts "ipkg" not correct? I've also tried
      reinstalling "ipkg" but without success, when I try to use "ipkg" or "ipkg-
      opt" the NSLU2 reboots itself.

      2013/2/23 Anthony Takata <htwiz2002@...>

      > **
      >
      >
      > IIRC = If I Remember Correctly.
      > Make sure you have sufficient space on the disks (use the df command)
      > You can always try reinstalling ipkg, that won't harm anything.
      >
      >
      > On Fri, Feb 22, 2013 at 11:54 AM, Eric CS erics324@...> wrote:
      >
      > > **
      > >
      > >
      > > thanks for the reply.
      > > Yes I installed the firmware is Big endian think.
      > > In fact the first time I try to "opkg update" works fine but then "opkg
      > > upgrade" the system hangs and reboots. I also managed to install ipkg
      > with
      > > "setup-optware.sh" installs fine but when I do "ipkg update" the system
      > > also
      > > hangs and reboots too.
      > > What is IIRC? how I can fix the kernel panic?
      > >
      > > 2013/2/22 Anthony Takata htwiz2002@...>
      > >
      > > > **
      >
      > >
      > > >
      > > >
      > > > Do you get any data back before it restarts? If it's causing a kernel
      > > panic
      > > > that might be the cause.
      > > > I'm not familiar with openslug, but iirc you might need to make sure
      > > > whether the programs you install are big-endian or little-endian (I
      > think
      > > > the nslu2 is big endian by default?)
      > > >
      > > > On Fri, Feb 22, 2013 at 8:16 AM, Eric CS erics324@...> wrote:
      > > >
      > > > > **
      > >
      > > >
      > > > >
      > > > >
      > > > > Hi all, I have a question about slugosBE 5.3 Beta and NSLU2. I
      > > installed
      > > > > the
      > > > > firmware with upslug2 successfully. I configured the network with
      > > "turnup
      > > > > init" then I installed the system to my external hard drive 400 gb
      > > with "
      > > > > turnup disk-i / dev/sda1" then I created a swapfile file. Everything
      > > fine
      > > > > until I try to use opkg or ipkg, when I use the command "opkg update"
      > > > and "
      > > > > ipkg update" NSLU2 automatically restarts.
      > > > > I searched a lot on google but can not find solution. Someone could
      > > give
      > > > > me a
      > > > > solution to solve this? thanks
      > > > >
      > > > > [Non-text portions of this message have been removed]
      > > > >
      > > > >
      > > > >
      > > >
      > > > [Non-text portions of this message have been removed]
      > > >
      > > >
      > > >
      > >
      > > [Non-text portions of this message have been removed]
      > >
      > >
      > >
      >
      > [Non-text portions of this message have been removed]
      >
      >
      >


      [Non-text portions of this message have been removed]
    • Ovidiu Sas
      Try to re-unsling the hard drive and start fresh. I have openslug installed on a NSLU a while ago and it is working fine. Regards, Ovidiu Sas
      Message 2 of 9 , Feb 22, 2013
      • 0 Attachment
        Try to re-unsling the hard drive and start fresh.
        I have openslug installed on a NSLU a while ago and it is working fine.

        Regards,
        Ovidiu Sas

        On Fri, Feb 22, 2013 at 6:59 PM, Eric CS <erics324@...> wrote:
        >
        >
        >
        > df command gives me this response
        >
        > Filesystem 1K-blocks Used Available Use% Mounted on
        > /dev/root 6400 5468 932 85% /initrd
        > /dev/sda1 384578164 251608 364791116 0% /
        > /dev/sda1 384578164 251608 364791116 0% /dev/.static/dev
        > udev 2048 36 2012 2% /dev
        > tmpfs 15120 0 15120 0% /var/volatile
        > tmpfs 15120 0 15120 0% /dev/shm
        >
        > I'm using an external hard drive 400 gb not think it's due to lack of space
        > .. perhaps the downloads directory hosts "ipkg" not correct? I've also tried
        > reinstalling "ipkg" but without success, when I try to use "ipkg" or "ipkg-
        > opt" the NSLU2 reboots itself.
        >
        > 2013/2/23 Anthony Takata htwiz2002@...>
        >
        > > **
        >
        >
        > >
        > >
        > > IIRC = If I Remember Correctly.
        > > Make sure you have sufficient space on the disks (use the df command)
        > > You can always try reinstalling ipkg, that won't harm anything.
        > >
        > >
        > > On Fri, Feb 22, 2013 at 11:54 AM, Eric CS erics324@...> wrote:
        > >
        > > > **
        > > >
        > > >
        > > > thanks for the reply.
        > > > Yes I installed the firmware is Big endian think.
        > > > In fact the first time I try to "opkg update" works fine but then "opkg
        > > > upgrade" the system hangs and reboots. I also managed to install ipkg
        > > with
        > > > "setup-optware.sh" installs fine but when I do "ipkg update" the system
        > > > also
        > > > hangs and reboots too.
        > > > What is IIRC? how I can fix the kernel panic?
        > > >
        > > > 2013/2/22 Anthony Takata htwiz2002@...>
        > > >
        > > > > **
        > >
        > > >
        > > > >
        > > > >
        > > > > Do you get any data back before it restarts? If it's causing a kernel
        > > > panic
        > > > > that might be the cause.
        > > > > I'm not familiar with openslug, but iirc you might need to make sure
        > > > > whether the programs you install are big-endian or little-endian (I
        > > think
        > > > > the nslu2 is big endian by default?)
        > > > >
        > > > > On Fri, Feb 22, 2013 at 8:16 AM, Eric CS erics324@...> wrote:
        > > > >
        > > > > > **
        > > >
        > > > >
        > > > > >
        > > > > >
        > > > > > Hi all, I have a question about slugosBE 5.3 Beta and NSLU2. I
        > > > installed
        > > > > > the
        > > > > > firmware with upslug2 successfully. I configured the network with
        > > > "turnup
        > > > > > init" then I installed the system to my external hard drive 400 gb
        > > > with "
        > > > > > turnup disk-i / dev/sda1" then I created a swapfile file. Everything
        > > > fine
        > > > > > until I try to use opkg or ipkg, when I use the command "opkg update"
        > > > > and "
        > > > > > ipkg update" NSLU2 automatically restarts.
        > > > > > I searched a lot on google but can not find solution. Someone could
        > > > give
        > > > > > me a
        > > > > > solution to solve this? thanks
      • Eric CS
        I reinstalled the firmware and reunsling hard disk several times with the same result. 2013/2/23 Ovidiu Sas ... [Non-text portions of
        Message 3 of 9 , Feb 23, 2013
        • 0 Attachment
          I reinstalled the firmware and reunsling hard disk several times with the
          same result.


          2013/2/23 Ovidiu Sas <osas@...>

          > **
          >
          >
          > Try to re-unsling the hard drive and start fresh.
          > I have openslug installed on a NSLU a while ago and it is working fine.
          >
          > Regards,
          > Ovidiu Sas
          >
          >
          > On Fri, Feb 22, 2013 at 6:59 PM, Eric CS erics324@...> wrote:
          > >
          > >
          > >
          > > df command gives me this response
          > >
          > > Filesystem 1K-blocks Used Available Use% Mounted on
          > > /dev/root 6400 5468 932 85% /initrd
          > > /dev/sda1 384578164 251608 364791116 0% /
          > > /dev/sda1 384578164 251608 364791116 0% /dev/.static/dev
          > > udev 2048 36 2012 2% /dev
          > > tmpfs 15120 0 15120 0% /var/volatile
          > > tmpfs 15120 0 15120 0% /dev/shm
          > >
          > > I'm using an external hard drive 400 gb not think it's due to lack of
          > space
          > > .. perhaps the downloads directory hosts "ipkg" not correct? I've also
          > tried
          > > reinstalling "ipkg" but without success, when I try to use "ipkg" or
          > "ipkg-
          > > opt" the NSLU2 reboots itself.
          > >
          > > 2013/2/23 Anthony Takata htwiz2002@...>
          > >
          > > > **
          >
          > >
          > >
          > > >
          > > >
          > > > IIRC = If I Remember Correctly.
          > > > Make sure you have sufficient space on the disks (use the df command)
          > > > You can always try reinstalling ipkg, that won't harm anything.
          > > >
          > > >
          > > > On Fri, Feb 22, 2013 at 11:54 AM, Eric CS erics324@...> wrote:
          > > >
          > > > > **
          > > > >
          > > > >
          > > > > thanks for the reply.
          > > > > Yes I installed the firmware is Big endian think.
          > > > > In fact the first time I try to "opkg update" works fine but then
          > "opkg
          > > > > upgrade" the system hangs and reboots. I also managed to install ipkg
          > > > with
          > > > > "setup-optware.sh" installs fine but when I do "ipkg update" the
          > system
          > > > > also
          > > > > hangs and reboots too.
          > > > > What is IIRC? how I can fix the kernel panic?
          > > > >
          > > > > 2013/2/22 Anthony Takata htwiz2002@...>
          > > > >
          > > > > > **
          > > >
          > > > >
          > > > > >
          > > > > >
          > > > > > Do you get any data back before it restarts? If it's causing a
          > kernel
          > > > > panic
          > > > > > that might be the cause.
          > > > > > I'm not familiar with openslug, but iirc you might need to make
          > sure
          > > > > > whether the programs you install are big-endian or little-endian (I
          > > > think
          > > > > > the nslu2 is big endian by default?)
          > > > > >
          > > > > > On Fri, Feb 22, 2013 at 8:16 AM, Eric CS erics324@...>
          > wrote:
          > > > > >
          > > > > > > **
          > > > >
          > > > > >
          > > > > > >
          > > > > > >
          > > > > > > Hi all, I have a question about slugosBE 5.3 Beta and NSLU2. I
          > > > > installed
          > > > > > > the
          > > > > > > firmware with upslug2 successfully. I configured the network with
          > > > > "turnup
          > > > > > > init" then I installed the system to my external hard drive 400
          > gb
          > > > > with "
          > > > > > > turnup disk-i / dev/sda1" then I created a swapfile file.
          > Everything
          > > > > fine
          > > > > > > until I try to use opkg or ipkg, when I use the command "opkg
          > update"
          > > > > > and "
          > > > > > > ipkg update" NSLU2 automatically restarts.
          > > > > > > I searched a lot on google but can not find solution. Someone
          > could
          > > > > give
          > > > > > > me a
          > > > > > > solution to solve this? thanks
          >
          >
          >


          [Non-text portions of this message have been removed]
        • Eric CS
          I can do ipkg update succesfully the first time I reflashed openslug, but then ipkg upgrade or ipkg install x fails. maybe it s because I made the
          Message 4 of 9 , Feb 23, 2013
          • 0 Attachment
            I can do "ipkg update" succesfully the first time I reflashed openslug, but
            then "ipkg upgrade" or "ipkg install x" fails.
            maybe it's because I made the modification in resistance R83?


            2013/2/23 Eric CS <erics324@...>

            > I reinstalled the firmware and reunsling hard disk several times with the
            > same result.
            >
            >
            > 2013/2/23 Ovidiu Sas <osas@...>
            >
            >> **
            >>
            >>
            >> Try to re-unsling the hard drive and start fresh.
            >> I have openslug installed on a NSLU a while ago and it is working fine.
            >>
            >> Regards,
            >> Ovidiu Sas
            >>
            >>
            >> On Fri, Feb 22, 2013 at 6:59 PM, Eric CS erics324@...> wrote:
            >> >
            >> >
            >> >
            >> > df command gives me this response
            >> >
            >> > Filesystem 1K-blocks Used Available Use% Mounted on
            >> > /dev/root 6400 5468 932 85% /initrd
            >> > /dev/sda1 384578164 251608 364791116 0% /
            >> > /dev/sda1 384578164 251608 364791116 0% /dev/.static/dev
            >> > udev 2048 36 2012 2% /dev
            >> > tmpfs 15120 0 15120 0% /var/volatile
            >> > tmpfs 15120 0 15120 0% /dev/shm
            >> >
            >> > I'm using an external hard drive 400 gb not think it's due to lack of
            >> space
            >> > .. perhaps the downloads directory hosts "ipkg" not correct? I've also
            >> tried
            >> > reinstalling "ipkg" but without success, when I try to use "ipkg" or
            >> "ipkg-
            >> > opt" the NSLU2 reboots itself.
            >> >
            >> > 2013/2/23 Anthony Takata htwiz2002@...>
            >> >
            >> > > **
            >>
            >> >
            >> >
            >> > >
            >> > >
            >> > > IIRC = If I Remember Correctly.
            >> > > Make sure you have sufficient space on the disks (use the df command)
            >> > > You can always try reinstalling ipkg, that won't harm anything.
            >> > >
            >> > >
            >> > > On Fri, Feb 22, 2013 at 11:54 AM, Eric CS erics324@...> wrote:
            >> > >
            >> > > > **
            >> > > >
            >> > > >
            >> > > > thanks for the reply.
            >> > > > Yes I installed the firmware is Big endian think.
            >> > > > In fact the first time I try to "opkg update" works fine but then
            >> "opkg
            >> > > > upgrade" the system hangs and reboots. I also managed to install
            >> ipkg
            >> > > with
            >> > > > "setup-optware.sh" installs fine but when I do "ipkg update" the
            >> system
            >> > > > also
            >> > > > hangs and reboots too.
            >> > > > What is IIRC? how I can fix the kernel panic?
            >> > > >
            >> > > > 2013/2/22 Anthony Takata htwiz2002@...>
            >> > > >
            >> > > > > **
            >> > >
            >> > > >
            >> > > > >
            >> > > > >
            >> > > > > Do you get any data back before it restarts? If it's causing a
            >> kernel
            >> > > > panic
            >> > > > > that might be the cause.
            >> > > > > I'm not familiar with openslug, but iirc you might need to make
            >> sure
            >> > > > > whether the programs you install are big-endian or little-endian
            >> (I
            >> > > think
            >> > > > > the nslu2 is big endian by default?)
            >> > > > >
            >> > > > > On Fri, Feb 22, 2013 at 8:16 AM, Eric CS erics324@...>
            >> wrote:
            >> > > > >
            >> > > > > > **
            >> > > >
            >> > > > >
            >> > > > > >
            >> > > > > >
            >> > > > > > Hi all, I have a question about slugosBE 5.3 Beta and NSLU2. I
            >> > > > installed
            >> > > > > > the
            >> > > > > > firmware with upslug2 successfully. I configured the network
            >> with
            >> > > > "turnup
            >> > > > > > init" then I installed the system to my external hard drive 400
            >> gb
            >> > > > with "
            >> > > > > > turnup disk-i / dev/sda1" then I created a swapfile file.
            >> Everything
            >> > > > fine
            >> > > > > > until I try to use opkg or ipkg, when I use the command "opkg
            >> update"
            >> > > > > and "
            >> > > > > > ipkg update" NSLU2 automatically restarts.
            >> > > > > > I searched a lot on google but can not find solution. Someone
            >> could
            >> > > > give
            >> > > > > > me a
            >> > > > > > solution to solve this? thanks
            >>
            >>
            >>
            >
            >


            [Non-text portions of this message have been removed]
          • Ovidiu Sas
            Try to install another firmware and see if the issue persists. Maybe it s a hardware issue (bad memory??) -ovidiu
            Message 5 of 9 , Feb 23, 2013
            • 0 Attachment
              Try to install another firmware and see if the issue persists.
              Maybe it's a hardware issue (bad memory??)

              -ovidiu

              On Sat, Feb 23, 2013 at 2:03 PM, Eric CS <erics324@...> wrote:
              >
              >
              >
              > I can do "ipkg update" succesfully the first time I reflashed openslug, but
              > then "ipkg upgrade" or "ipkg install x" fails.
              > maybe it's because I made the modification in resistance R83?
              >
              > 2013/2/23 Eric CS erics324@...>
              >
              >
              >
              > > I reinstalled the firmware and reunsling hard disk several times with the
              > > same result.
              > >
              > >
              > > 2013/2/23 Ovidiu Sas osas@...>
              > >
              > >> **
              > >>
              > >>
              > >> Try to re-unsling the hard drive and start fresh.
              > >> I have openslug installed on a NSLU a while ago and it is working fine.
              > >>
              > >> Regards,
              > >> Ovidiu Sas
              > >>
              > >>
              > >> On Fri, Feb 22, 2013 at 6:59 PM, Eric CS erics324@...> wrote:
              > >> >
              > >> >
              > >> >
              > >> > df command gives me this response
              > >> >
              > >> > Filesystem 1K-blocks Used Available Use% Mounted on
              > >> > /dev/root 6400 5468 932 85% /initrd
              > >> > /dev/sda1 384578164 251608 364791116 0% /
              > >> > /dev/sda1 384578164 251608 364791116 0% /dev/.static/dev
              > >> > udev 2048 36 2012 2% /dev
              > >> > tmpfs 15120 0 15120 0% /var/volatile
              > >> > tmpfs 15120 0 15120 0% /dev/shm
              > >> >
              > >> > I'm using an external hard drive 400 gb not think it's due to lack of
              > >> space
              > >> > .. perhaps the downloads directory hosts "ipkg" not correct? I've also
              > >> tried
              > >> > reinstalling "ipkg" but without success, when I try to use "ipkg" or
              > >> "ipkg-
              > >> > opt" the NSLU2 reboots itself.
              > >> >
              > >> > 2013/2/23 Anthony Takata htwiz2002@...>
              > >> >
              > >> > > **
              > >>
              > >> >
              > >> >
              > >> > >
              > >> > >
              > >> > > IIRC = If I Remember Correctly.
              > >> > > Make sure you have sufficient space on the disks (use the df command)
              > >> > > You can always try reinstalling ipkg, that won't harm anything.
              > >> > >
              > >> > >
              > >> > > On Fri, Feb 22, 2013 at 11:54 AM, Eric CS erics324@...> wrote:
              > >> > >
              > >> > > > **
              > >> > > >
              > >> > > >
              > >> > > > thanks for the reply.
              > >> > > > Yes I installed the firmware is Big endian think.
              > >> > > > In fact the first time I try to "opkg update" works fine but then
              > >> "opkg
              > >> > > > upgrade" the system hangs and reboots. I also managed to install
              > >> ipkg
              > >> > > with
              > >> > > > "setup-optware.sh" installs fine but when I do "ipkg update" the
              > >> system
              > >> > > > also
              > >> > > > hangs and reboots too.
              > >> > > > What is IIRC? how I can fix the kernel panic?
              > >> > > >
              > >> > > > 2013/2/22 Anthony Takata htwiz2002@...>
              > >> > > >
              > >> > > > > **
              > >> > >
              > >> > > >
              > >> > > > >
              > >> > > > >
              > >> > > > > Do you get any data back before it restarts? If it's causing a
              > >> kernel
              > >> > > > panic
              > >> > > > > that might be the cause.
              > >> > > > > I'm not familiar with openslug, but iirc you might need to make
              > >> sure
              > >> > > > > whether the programs you install are big-endian or little-endian
              > >> (I
              > >> > > think
              > >> > > > > the nslu2 is big endian by default?)
              > >> > > > >
              > >> > > > > On Fri, Feb 22, 2013 at 8:16 AM, Eric CS erics324@...>
              > >> wrote:
              > >> > > > >
              > >> > > > > > **
              > >> > > >
              > >> > > > >
              > >> > > > > >
              > >> > > > > >
              > >> > > > > > Hi all, I have a question about slugosBE 5.3 Beta and NSLU2. I
              > >> > > > installed
              > >> > > > > > the
              > >> > > > > > firmware with upslug2 successfully. I configured the network
              > >> with
              > >> > > > "turnup
              > >> > > > > > init" then I installed the system to my external hard drive 400
              > >> gb
              > >> > > > with "
              > >> > > > > > turnup disk-i / dev/sda1" then I created a swapfile file.
              > >> Everything
              > >> > > > fine
              > >> > > > > > until I try to use opkg or ipkg, when I use the command "opkg
              > >> update"
              > >> > > > > and "
              > >> > > > > > ipkg update" NSLU2 automatically restarts.
              > >> > > > > > I searched a lot on google but can not find solution. Someone
              > >> could
              > >> > > > give
              > >> > > > > > me a
              > >> > > > > > solution to solve this? thanks
            Your message has been successfully submitted and would be delivered to recipients shortly.