Loading ...
Sorry, an error occurred while loading the content.

transmission-remote authentication failure

Expand Messages
  • Stefano
    Hi everybody. I m using transmission 2.73 (13592) with authentication enabled and whitelist disabled. I can access torrent list using a web browser from any
    Message 1 of 3 , Jan 8, 2013
    • 0 Attachment
      Hi everybody.
      I'm using transmission 2.73 (13592) with authentication enabled and
      whitelist disabled. I can access torrent list using a web browser from
      any PC in my network and authentication is correctly working, but when
      I try to get torrent list with transmission-remote from an SSH session
      I get the following error:

      Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
      application/x-www-form-urlencoded

      I use the following script:

      #!/bin/sh
      transmission-remote -l --auth username:password

      The script is perfectly working if I disable rpc authentication in
      settings.json.
      If I add the debug option (-b) this is what i get:

      posting:
      --------
      {"arguments":{"fields":["error","errorString","eta","id","isFinished","l\
      eftUntilDone","name","peersGettingFromUs","peersSendingToUs","rateDownlo\
      ad","rateUpload","sizeWhenDone","status","uploadRatio"]},"method":"torre\
      nt-get","tag":4}

      --------
      > POST /transmission/rpc/ HTTP/1.1
      User-Agent: transmission-remote/2.73 (13592)
      Host: localhost:9091
      Accept: */*
      Accept-Encoding: deflate, gzip
      Content-Length: 233
      Content-Type: application/x-www-form-urlencoded

      < HTTP/1.1 401 Unauthorized
      < Server: Transmission
      < WWW-Authenticate: Basic realm="Transmission"
      < Date: Tue, 08 Jan 2013 15:24:45 GMT
      < Content-Length: 43
      < Content-Type: text/html; charset=ISO-8859-1
      <
      Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
      application/x-www-form-urlencoded

      Note that if I issue the command

      transmission-remote -b -l

      I have the following output:

      posting:
      --------
      {"arguments":{"fields":["error","errorString","eta","id","isFinished","l\
      eftUntilDone","name","peersGettingFromUs","peersSendingToUs","rateDownlo\
      ad","rateUpload","sizeWhenDone","status","uploadRatio"]},"method":"torre\
      nt-get","tag":4}

      --------
      > POST /transmission/rpc/ HTTP/1.1
      User-Agent: transmission-remote/2.73 (13592)
      Host: localhost:9091
      Accept: */*
      Accept-Encoding: deflate, gzip
      Content-Length: 233
      Content-Type: application/x-www-form-urlencoded

      < HTTP/1.1 401 Unauthorized
      < Server: Transmission
      < WWW-Authenticate: Basic realm="Transmission"
      < Date: Tue, 08 Jan 2013 15:26:37 GMT
      < Content-Length: 43
      < Content-Type: text/html; charset=ISO-8859-1
      <
      Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
      application/x-www-form-urlencoded

      It seems that sent data does not contain authentication even if this is
      given on the command line, as Content-Length is always 233.

      Any idea?

      Thanks,
      Stefano


      [Non-text portions of this message have been removed]
    • oddballhero
      Try transmission-remote --auth=username:password -l
      Message 2 of 3 , Jan 9, 2013
      • 0 Attachment
        Try transmission-remote --auth=username:password -l

        --- In nslu2-general@yahoogroups.com, "Stefano" wrote:
        >
        > Hi everybody.
        > I'm using transmission 2.73 (13592) with authentication enabled and
        > whitelist disabled. I can access torrent list using a web browser from
        > any PC in my network and authentication is correctly working, but when
        > I try to get torrent list with transmission-remote from an SSH session
        > I get the following error:
        >
        > Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
        > application/x-www-form-urlencoded
        >
        > I use the following script:
        >
        > #!/bin/sh
        > transmission-remote -l --auth username:password
        >
        > The script is perfectly working if I disable rpc authentication in
        > settings.json.
        > If I add the debug option (-b) this is what i get:
        >
        > posting:
        > --------
        > {"arguments":{"fields":["error","errorString","eta","id","isFinished","l\
        > eftUntilDone","name","peersGettingFromUs","peersSendingToUs","rateDownlo\
        > ad","rateUpload","sizeWhenDone","status","uploadRatio"]},"method":"torre\
        > nt-get","tag":4}
        >
        > --------
        > > POST /transmission/rpc/ HTTP/1.1
        > User-Agent: transmission-remote/2.73 (13592)
        > Host: localhost:9091
        > Accept: */*
        > Accept-Encoding: deflate, gzip
        > Content-Length: 233
        > Content-Type: application/x-www-form-urlencoded
        >
        > < HTTP/1.1 401 Unauthorized
        > < Server: Transmission
        > < WWW-Authenticate: Basic realm="Transmission"
        > < Date: Tue, 08 Jan 2013 15:24:45 GMT
        > < Content-Length: 43
        > < Content-Type: text/html; charset=ISO-8859-1
        > <
        > Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
        > application/x-www-form-urlencoded
        >
        > Note that if I issue the command
        >
        > transmission-remote -b -l
        >
        > I have the following output:
        >
        > posting:
        > --------
        > {"arguments":{"fields":["error","errorString","eta","id","isFinished","l\
        > eftUntilDone","name","peersGettingFromUs","peersSendingToUs","rateDownlo\
        > ad","rateUpload","sizeWhenDone","status","uploadRatio"]},"method":"torre\
        > nt-get","tag":4}
        >
        > --------
        > > POST /transmission/rpc/ HTTP/1.1
        > User-Agent: transmission-remote/2.73 (13592)
        > Host: localhost:9091
        > Accept: */*
        > Accept-Encoding: deflate, gzip
        > Content-Length: 233
        > Content-Type: application/x-www-form-urlencoded
        >
        > < HTTP/1.1 401 Unauthorized
        > < Server: Transmission
        > < WWW-Authenticate: Basic realm="Transmission"
        > < Date: Tue, 08 Jan 2013 15:26:37 GMT
        > < Content-Length: 43
        > < Content-Type: text/html; charset=ISO-8859-1
        > <
        > Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
        > application/x-www-form-urlencoded
        >
        > It seems that sent data does not contain authentication even if this is
        > given on the command line, as Content-Length is always 233.
        >
        > Any idea?
        >
        > Thanks,
        > Stefano
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Stefano
        AH AH AH!! I can t believe it!! It WORKS!! It s just a problem of parameters order... Thankyou very much! Cheers Stefano
        Message 3 of 3 , Jan 9, 2013
        • 0 Attachment
          AH AH AH!!
          I can't believe it!!
          It WORKS!! It's just a problem of parameters order...
          Thankyou very much!

          Cheers
          Stefano

          --- In nslu2-general@yahoogroups.com, "oddballhero" wrote:
          >
          > Try transmission-remote --auth=username:password -l
          >
          > --- In nslu2-general@yahoogroups.com, "Stefano" wrote:
          > >
          > > Hi everybody.
          > > I'm using transmission 2.73 (13592) with authentication enabled and
          > > whitelist disabled. I can access torrent list using a web browser from
          > > any PC in my network and authentication is correctly working, but when
          > > I try to get torrent list with transmission-remote from an SSH session
          > > I get the following error:
          > >
          > > Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
          > > application/x-www-form-urlencoded
          > >
          > > I use the following script:
          > >
          > > #!/bin/sh
          > > transmission-remote -l --auth username:password
          > >
          > > The script is perfectly working if I disable rpc authentication in
          > > settings.json.
          > > If I add the debug option (-b) this is what i get:
          > >
          > > posting:
          > > --------
          > > {"arguments":{"fields":["error","errorString","eta","id","isFinished","l\
          > > eftUntilDone","name","peersGettingFromUs","peersSendingToUs","rateDownlo\
          > > ad","rateUpload","sizeWhenDone","status","uploadRatio"]},"method":"torre\
          > > nt-get","tag":4}
          > >
          > > --------
          > > > POST /transmission/rpc/ HTTP/1.1
          > > User-Agent: transmission-remote/2.73 (13592)
          > > Host: localhost:9091
          > > Accept: */*
          > > Accept-Encoding: deflate, gzip
          > > Content-Length: 233
          > > Content-Type: application/x-www-form-urlencoded
          > >
          > > < HTTP/1.1 401 Unauthorized
          > > < Server: Transmission
          > > < WWW-Authenticate: Basic realm="Transmission"
          > > < Date: Tue, 08 Jan 2013 15:24:45 GMT
          > > < Content-Length: 43
          > > < Content-Type: text/html; charset=ISO-8859-1
          > > <
          > > Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
          > > application/x-www-form-urlencoded
          > >
          > > Note that if I issue the command
          > >
          > > transmission-remote -b -l
          > >
          > > I have the following output:
          > >
          > > posting:
          > > --------
          > > {"arguments":{"fields":["error","errorString","eta","id","isFinished","l\
          > > eftUntilDone","name","peersGettingFromUs","peersSendingToUs","rateDownlo\
          > > ad","rateUpload","sizeWhenDone","status","uploadRatio"]},"method":"torre\
          > > nt-get","tag":4}
          > >
          > > --------
          > > > POST /transmission/rpc/ HTTP/1.1
          > > User-Agent: transmission-remote/2.73 (13592)
          > > Host: localhost:9091
          > > Accept: */*
          > > Accept-Encoding: deflate, gzip
          > > Content-Length: 233
          > > Content-Type: application/x-www-form-urlencoded
          > >
          > > < HTTP/1.1 401 Unauthorized
          > > < Server: Transmission
          > > < WWW-Authenticate: Basic realm="Transmission"
          > > < Date: Tue, 08 Jan 2013 15:26:37 GMT
          > > < Content-Length: 43
          > > < Content-Type: text/html; charset=ISO-8859-1
          > > <
          > > Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Usere:
          > > application/x-www-form-urlencoded
          > >
          > > It seems that sent data does not contain authentication even if this is
          > > given on the command line, as Content-Length is always 233.
          > >
          > > Any idea?
          > >
          > > Thanks,
          > > Stefano
          > >
          > >
          > > [Non-text portions of this message have been removed]
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.