Loading ...
Sorry, an error occurred while loading the content.

Pogoplug Pro can't login via ssh

Expand Messages
  • prosaicmark
    I was in the process of installing Samba via Optware on my Pogoplug Pro when the power flickered forcing a reboot. Now I can t login. Possibly Pertinent items
    Message 1 of 2 , Aug 30, 2012
    • 0 Attachment
      I was in the process of installing Samba via Optware on my Pogoplug Pro when the power flickered forcing a reboot. Now I can't login.

      Possibly Pertinent items
      - I was at the prompt when this happened. To my knowledge there were no non-normal operations.
      - Bash installed with the various recommended bashrc and profiles operating.
      - Bash was the root's default shell. I highly suspect this might be were the problem lays.
      - Pogoplug works normally via it's other standard interfaces.
      - I have attempted to login via putty from windows and ssh from linux.

      Possibly solution - hard reset but I don't know if this will reset the default shell.

      ssh -v output
      user@Murgen:~$ ssh -v root@172.16.1.35
      OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
      debug1: Reading configuration data /etc/ssh/ssh_config
      debug1: /etc/ssh/ssh_config line 19: Applying options for *
      debug1: Connecting to 172.16.1.35 [172.16.1.35] port 22.
      debug1: Connection established.
      debug1: identity file /home/croaker/.ssh/id_rsa type -1
      debug1: identity file /home/croaker/.ssh/id_rsa-cert type -1
      debug1: identity file /home/croaker/.ssh/id_dsa type -1
      debug1: identity file /home/croaker/.ssh/id_dsa-cert type -1
      debug1: identity file /home/croaker/.ssh/id_ecdsa type -1
      debug1: identity file /home/croaker/.ssh/id_ecdsa-cert type -1
      debug1: Remote protocol version 2.0, remote software version dropbear_0.52
      debug1: no match: dropbear_0.52
      debug1: Enabling compatibility mode for protocol 2.0
      debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
      debug1: SSH2_MSG_KEXINIT sent
      debug1: SSH2_MSG_KEXINIT received
      debug1: kex: server->client aes128-ctr hmac-md5 none
      debug1: kex: client->server aes128-ctr hmac-md5 none
      debug1: sending SSH2_MSG_KEXDH_INIT
      debug1: expecting SSH2_MSG_KEXDH_REPLY
      debug1: Server host key: RSA bf:ca:f6:8d:16:2e:87:50:ea:52:3e:ef:11:5c:c5:45
      debug1: Host '172.16.1.35' is known and matches the RSA host key.
      debug1: Found key in /home/user/.ssh/known_hosts:2
      debug1: ssh_rsa_verify: signature correct
      debug1: SSH2_MSG_NEWKEYS sent
      debug1: expecting SSH2_MSG_NEWKEYS
      debug1: SSH2_MSG_NEWKEYS received
      debug1: Roaming not allowed by server
      debug1: SSH2_MSG_SERVICE_REQUEST sent
      debug1: SSH2_MSG_SERVICE_ACCEPT received
      debug1: Authentications that can continue: publickey,password
      debug1: Next authentication method: publickey
      debug1: Trying private key: /home/croaker/.ssh/id_rsa
      debug1: Trying private key: /home/croaker/.ssh/id_dsa
      debug1: Trying private key: /home/croaker/.ssh/id_ecdsa
      debug1: Next authentication method: password
      root@172.16.1.35's password:
      debug1: Authentication succeeded (password).
      Authenticated to 172.16.1.35 ([172.16.1.35]:22).
      debug1: channel 0: new [client-session]
      debug1: Entering interactive session.
      debug1: Sending environment.
      debug1: Sending env LANG = en_US.UTF-8
      debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
      debug1: channel 0: free: client-session, nchannels 1
      Connection to 172.16.1.35 closed.
      Transferred: sent 2152, received 1168 bytes, in 0.0 seconds
      Bytes per second: sent 173758.4, received 94307.5
      debug1: Exit status 1
      user@Murgen:~$
    • Anthony Takata
      Well, it seems that the login is OK, but the shell is either broken or not found right. If you can SCP into it you might be able to edit the aforementioned
      Message 2 of 2 , Aug 31, 2012
      • 0 Attachment
        Well, it seems that the login is OK, but the shell is either broken or not
        found right. If you can SCP into it you might be able to edit the
        aforementioned profile scripts perhaps.

        On Fri, Aug 31, 2012 at 2:32 AM, prosaicmark <mark.jones@...> wrote:

        > **
        >
        >
        > I was in the process of installing Samba via Optware on my Pogoplug Pro
        > when the power flickered forcing a reboot. Now I can't login.
        >
        > Possibly Pertinent items
        > - I was at the prompt when this happened. To my knowledge there were no
        > non-normal operations.
        > - Bash installed with the various recommended bashrc and profiles
        > operating.
        > - Bash was the root's default shell. I highly suspect this might be were
        > the problem lays.
        > - Pogoplug works normally via it's other standard interfaces.
        > - I have attempted to login via putty from windows and ssh from linux.
        >
        > Possibly solution - hard reset but I don't know if this will reset the
        > default shell.
        >
        > ssh -v output
        > user@Murgen:~$ ssh -v root@172.16.1.35
        > OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
        > debug1: Reading configuration data /etc/ssh/ssh_config
        > debug1: /etc/ssh/ssh_config line 19: Applying options for *
        > debug1: Connecting to 172.16.1.35 [172.16.1.35] port 22.
        > debug1: Connection established.
        > debug1: identity file /home/croaker/.ssh/id_rsa type -1
        > debug1: identity file /home/croaker/.ssh/id_rsa-cert type -1
        > debug1: identity file /home/croaker/.ssh/id_dsa type -1
        > debug1: identity file /home/croaker/.ssh/id_dsa-cert type -1
        > debug1: identity file /home/croaker/.ssh/id_ecdsa type -1
        > debug1: identity file /home/croaker/.ssh/id_ecdsa-cert type -1
        > debug1: Remote protocol version 2.0, remote software version dropbear_0.52
        > debug1: no match: dropbear_0.52
        > debug1: Enabling compatibility mode for protocol 2.0
        > debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
        > debug1: SSH2_MSG_KEXINIT sent
        > debug1: SSH2_MSG_KEXINIT received
        > debug1: kex: server->client aes128-ctr hmac-md5 none
        > debug1: kex: client->server aes128-ctr hmac-md5 none
        > debug1: sending SSH2_MSG_KEXDH_INIT
        > debug1: expecting SSH2_MSG_KEXDH_REPLY
        > debug1: Server host key: RSA
        > bf:ca:f6:8d:16:2e:87:50:ea:52:3e:ef:11:5c:c5:45
        > debug1: Host '172.16.1.35' is known and matches the RSA host key.
        > debug1: Found key in /home/user/.ssh/known_hosts:2
        > debug1: ssh_rsa_verify: signature correct
        > debug1: SSH2_MSG_NEWKEYS sent
        > debug1: expecting SSH2_MSG_NEWKEYS
        > debug1: SSH2_MSG_NEWKEYS received
        > debug1: Roaming not allowed by server
        > debug1: SSH2_MSG_SERVICE_REQUEST sent
        > debug1: SSH2_MSG_SERVICE_ACCEPT received
        > debug1: Authentications that can continue: publickey,password
        > debug1: Next authentication method: publickey
        > debug1: Trying private key: /home/croaker/.ssh/id_rsa
        > debug1: Trying private key: /home/croaker/.ssh/id_dsa
        > debug1: Trying private key: /home/croaker/.ssh/id_ecdsa
        > debug1: Next authentication method: password
        > root@172.16.1.35's password:
        > debug1: Authentication succeeded (password).
        > Authenticated to 172.16.1.35 ([172.16.1.35]:22).
        > debug1: channel 0: new [client-session]
        > debug1: Entering interactive session.
        > debug1: Sending environment.
        > debug1: Sending env LANG = en_US.UTF-8
        > debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
        > debug1: channel 0: free: client-session, nchannels 1
        > Connection to 172.16.1.35 closed.
        > Transferred: sent 2152, received 1168 bytes, in 0.0 seconds
        > Bytes per second: sent 173758.4, received 94307.5
        > debug1: Exit status 1
        > user@Murgen:~$
        >
        >
        >


        [Non-text portions of this message have been removed]
      Your message has been successfully submitted and would be delivered to recipients shortly.