Loading ...
Sorry, an error occurred while loading the content.

Re: weechat 0.3.8 and python plugin

Expand Messages
  • samjack_it
    i found the problem and fixed. now python plugin is loaded correctly here is the patch for the weechat.mk: https://www.box.com/s/1ede11d27683b8a3dd96
    Message 1 of 7 , Jun 22, 2012
    • 0 Attachment
      i found the problem and fixed. now python plugin is loaded correctly

      here is the patch for the weechat.mk:

      https://www.box.com/s/1ede11d27683b8a3dd96

      --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@...> wrote:
      >
      > I've tried with no success.
      > First ipkg try to download 0.3.7 version and failure. I don't know why. (obviously I run ipkg update and list command show 0.3.8 version number)
      > resolved downloading package manually.
      >
      > then I run weechat: the lua plugin id loaded correctly, but the python one fails with
      >
      > Error: unable to load plugin "/opt/lib/weechat/plugins/python.so":/opt/lib/weechat/plugins/python.so: undefined symbol: _Py_NoneStruct
      >
      > NB I've installed only python2.6 package
      >
      >
      > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
      > >
      > > ok. I will try next weekend and report here results
      > > thanks
      > >
      > > --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@> wrote:
      > > >
      > > > I just tentatively added python and lua plugin when upgrading weechat to 0.3.8. The reason we didn't have that, is because of some complication involved in cross-compilation.
      > > >
      > > > I have not done any runtime test. Please give it a try, and report problem if any.
      > > >
      > > > Thanks,
      > > >
      > > > -Brian
      > > >
      > > > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
      > > > >
      > > > > Hi all,
      > > > >
      > > > > I am very new with nslu2 and unslung, but I've a question.
      > > > > why current version (0.3.7) of weechat optware package has no plugin support (python, perl, ecc)? maybe there are compile limits or it is a choice to avoid problems with multiple interpreters.
      > > > >
      > > > > yesterday weechat team released version 0.3.8. there is a plan to build new version with python plugin support?
      > > > >
      > > > > Thank to all for great work with nslu2 modding
      > > > >
      > > >
      > >
      >
    • Brian
      Thanks for the patch. Integrated. We can give you svn access to optware if you d like. -Brian
      Message 2 of 7 , Jun 23, 2012
      • 0 Attachment
        Thanks for the patch. Integrated.

        We can give you svn access to optware if you'd like.

        -Brian

        --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@...> wrote:
        >
        > i found the problem and fixed. now python plugin is loaded correctly
        >
        > here is the patch for the weechat.mk:
        >
        > https://www.box.com/s/1ede11d27683b8a3dd96
        >
        > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
        > >
        > > I've tried with no success.
        > > First ipkg try to download 0.3.7 version and failure. I don't know why. (obviously I run ipkg update and list command show 0.3.8 version number)
        > > resolved downloading package manually.
        > >
        > > then I run weechat: the lua plugin id loaded correctly, but the python one fails with
        > >
        > > Error: unable to load plugin "/opt/lib/weechat/plugins/python.so":/opt/lib/weechat/plugins/python.so: undefined symbol: _Py_NoneStruct
        > >
        > > NB I've installed only python2.6 package
        > >
        > >
        > > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
        > > >
        > > > ok. I will try next weekend and report here results
        > > > thanks
        > > >
        > > > --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@> wrote:
        > > > >
        > > > > I just tentatively added python and lua plugin when upgrading weechat to 0.3.8. The reason we didn't have that, is because of some complication involved in cross-compilation.
        > > > >
        > > > > I have not done any runtime test. Please give it a try, and report problem if any.
        > > > >
        > > > > Thanks,
        > > > >
        > > > > -Brian
        > > > >
        > > > > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
        > > > > >
        > > > > > Hi all,
        > > > > >
        > > > > > I am very new with nslu2 and unslung, but I've a question.
        > > > > > why current version (0.3.7) of weechat optware package has no plugin support (python, perl, ecc)? maybe there are compile limits or it is a choice to avoid problems with multiple interpreters.
        > > > > >
        > > > > > yesterday weechat team released version 0.3.8. there is a plan to build new version with python plugin support?
        > > > > >
        > > > > > Thank to all for great work with nslu2 modding
        > > > > >
        > > > >
        > > >
        > >
        >
      • jwon042
        Hello, thank you for getting Python and Lua support for weechat! I appreciate it very much! Will Perl support ever be added? A lot of the scripts for weechat
        Message 3 of 7 , Jul 11, 2012
        • 0 Attachment
          Hello, thank you for getting Python and Lua support for weechat! I appreciate it very much!

          Will Perl support ever be added? A lot of the scripts for weechat are written for Perl as well.

          I can help develop/test Perl integration into weechat if you can point me in the right direction or let me know what the issues are!


          Thank you for your support thus far!

          --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@...> wrote:
          >
          > Thanks for the patch. Integrated.
          >
          > We can give you svn access to optware if you'd like.
          >
          > -Brian
          >
          > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
          > >
          > > i found the problem and fixed. now python plugin is loaded correctly
          > >
          > > here is the patch for the weechat.mk:
          > >
          > > https://www.box.com/s/1ede11d27683b8a3dd96
          > >
          > > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
          > > >
          > > > I've tried with no success.
          > > > First ipkg try to download 0.3.7 version and failure. I don't know why. (obviously I run ipkg update and list command show 0.3.8 version number)
          > > > resolved downloading package manually.
          > > >
          > > > then I run weechat: the lua plugin id loaded correctly, but the python one fails with
          > > >
          > > > Error: unable to load plugin "/opt/lib/weechat/plugins/python.so":/opt/lib/weechat/plugins/python.so: undefined symbol: _Py_NoneStruct
          > > >
          > > > NB I've installed only python2.6 package
          > > >
          > > >
          > > > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
          > > > >
          > > > > ok. I will try next weekend and report here results
          > > > > thanks
          > > > >
          > > > > --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@> wrote:
          > > > > >
          > > > > > I just tentatively added python and lua plugin when upgrading weechat to 0.3.8. The reason we didn't have that, is because of some complication involved in cross-compilation.
          > > > > >
          > > > > > I have not done any runtime test. Please give it a try, and report problem if any.
          > > > > >
          > > > > > Thanks,
          > > > > >
          > > > > > -Brian
          > > > > >
          > > > > > --- In nslu2-general@yahoogroups.com, "samjack_it" <samjack@> wrote:
          > > > > > >
          > > > > > > Hi all,
          > > > > > >
          > > > > > > I am very new with nslu2 and unslung, but I've a question.
          > > > > > > why current version (0.3.7) of weechat optware package has no plugin support (python, perl, ecc)? maybe there are compile limits or it is a choice to avoid problems with multiple interpreters.
          > > > > > >
          > > > > > > yesterday weechat team released version 0.3.8. there is a plan to build new version with python plugin support?
          > > > > > >
          > > > > > > Thank to all for great work with nslu2 modding
          > > > > > >
          > > > > >
          > > > >
          > > >
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.