Loading ...
Sorry, an error occurred while loading the content.

Re: Perl package is missing from ipkg

Expand Messages
  • cpc664
    ... Hi, today svn was upgraded to 1.7.4-1, it doesnt work anymore (on a Synology DS410j). if I launch svnserve directly, I get : svnserve: error while loading
    Message 1 of 5 , May 17, 2012
    • 0 Attachment
      --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@...> wrote:
      >
      > There was a period of time yesterday that svn package build was broken (version upgrade was not successful), that might affected a few other packages including perl, nzbget, and asterisk18. It has since been reverted and all affected packages should have been rebuilt/restored by now.
      >
      > Sorry for the breakage. We'll take a look in the future to see how to minimize the impact of broken builds.

      Hi,

      today svn was upgraded to 1.7.4-1, it doesnt work anymore (on a Synology DS410j).

      if I launch svnserve directly, I get :

      svnserve: error while loading shared libraries: libmagic.so.1: cannot open shared object file: No such file or directory
    • Brian
      For now, ipkg install file will get you the missing libmagic. I ll fix the build to add that dependency. -Brian
      Message 2 of 5 , May 17, 2012
      • 0 Attachment
        For now, "ipkg install file" will get you the missing libmagic.

        I'll fix the build to add that dependency.

        -Brian

        --- In nslu2-general@yahoogroups.com, "cpc664" <cpc664@...> wrote:
        >
        >
        >
        > --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@> wrote:
        > >
        > > There was a period of time yesterday that svn package build was broken (version upgrade was not successful), that might affected a few other packages including perl, nzbget, and asterisk18. It has since been reverted and all affected packages should have been rebuilt/restored by now.
        > >
        > > Sorry for the breakage. We'll take a look in the future to see how to minimize the impact of broken builds.
        >
        > Hi,
        >
        > today svn was upgraded to 1.7.4-1, it doesnt work anymore (on a Synology DS410j).
        >
        > if I launch svnserve directly, I get :
        >
        > svnserve: error while loading shared libraries: libmagic.so.1: cannot open shared object file: No such file or directory
        >
      • cpc664
        ... Thanks a lot, installing file and upgrading to SVN v1.7.5-1, and now it works again.
        Message 3 of 5 , May 18, 2012
        • 0 Attachment
          --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@...> wrote:
          >
          > For now, "ipkg install file" will get you the missing libmagic.
          >
          > I'll fix the build to add that dependency.

          Thanks a lot, installing file and upgrading to SVN v1.7.5-1, and now it works again.
        Your message has been successfully submitted and would be delivered to recipients shortly.