Loading ...
Sorry, an error occurred while loading the content.

Perl package is missing from ipkg

Expand Messages
  • ptorinator
    Yesterday, I was trying to install rsnapshot and it failed with the following error trying to install perl: Installing perl (5.10.0-6) to root... Downloading
    Message 1 of 5 , May 4, 2012
    • 0 Attachment
      Yesterday, I was trying to install rsnapshot and it failed with the following error trying to install perl:

      Installing perl (5.10.0-6) to root...
      Downloading ipkg.nslu2-linux.org/feeds/optware/ts509/cross/unstable/perl_5.10.0-6_i686.ipk
      Nothing to be done
      An error ocurred, return value: 22.
      Collected errors:
      ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /opt/ipkg-8pVDlR ipkg.nslu2-linux.org/feeds/optware/ts509/cross/unstable/perl_5.10.0-6_i686.ipk'
      Failed to download perl. Perhaps you need to run 'ipkg update'?

      When I went directly to the web site, I got the error "404 Not Found". It looks like the 5.10.0.6 perl package was missing in general on ipkg.nslu2. Was it removed for some reason?

      I installed rsnapshot onto a different server a few days ago and it worked fine:

      Package: perl
      Version: 5.10.0-6
      Depends: libdb, gdbm
      Status: install ok installed
      Architecture: i686
      Installed-Time: 1335898127

      Today, I tried again, and it worked fine:

      Package: perl
      Version: 5.10.0-6
      Depends: libdb, gdbm
      Status: install ok installed
      Architecture: i686
      Installed-Time: 1336135235

      What happened to perl for those couple of days? Is this message forum the best place to report these type of issues in the future?
    • Brian
      There was a period of time yesterday that svn package build was broken (version upgrade was not successful), that might affected a few other packages including
      Message 2 of 5 , May 4, 2012
      • 0 Attachment
        There was a period of time yesterday that svn package build was broken (version upgrade was not successful), that might affected a few other packages including perl, nzbget, and asterisk18. It has since been reverted and all affected packages should have been rebuilt/restored by now.

        Sorry for the breakage. We'll take a look in the future to see how to minimize the impact of broken builds.

        Thanks for your patience,

        -Brian

        --- In nslu2-general@yahoogroups.com, "ptorinator" <register@...> wrote:
        >
        > Yesterday, I was trying to install rsnapshot and it failed with the following error trying to install perl:
        >
        > Installing perl (5.10.0-6) to root...
        > Downloading ipkg.nslu2-linux.org/feeds/optware/ts509/cross/unstable/perl_5.10.0-6_i686.ipk
        > Nothing to be done
        > An error ocurred, return value: 22.
        > Collected errors:
        > ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /opt/ipkg-8pVDlR ipkg.nslu2-linux.org/feeds/optware/ts509/cross/unstable/perl_5.10.0-6_i686.ipk'
        > Failed to download perl. Perhaps you need to run 'ipkg update'?
        >
        > When I went directly to the web site, I got the error "404 Not Found". It looks like the 5.10.0.6 perl package was missing in general on ipkg.nslu2. Was it removed for some reason?
        >
        > I installed rsnapshot onto a different server a few days ago and it worked fine:
        >
        > Package: perl
        > Version: 5.10.0-6
        > Depends: libdb, gdbm
        > Status: install ok installed
        > Architecture: i686
        > Installed-Time: 1335898127
        >
        > Today, I tried again, and it worked fine:
        >
        > Package: perl
        > Version: 5.10.0-6
        > Depends: libdb, gdbm
        > Status: install ok installed
        > Architecture: i686
        > Installed-Time: 1336135235
        >
        > What happened to perl for those couple of days? Is this message forum the best place to report these type of issues in the future?
        >
      • cpc664
        ... Hi, today svn was upgraded to 1.7.4-1, it doesnt work anymore (on a Synology DS410j). if I launch svnserve directly, I get : svnserve: error while loading
        Message 3 of 5 , May 17, 2012
        • 0 Attachment
          --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@...> wrote:
          >
          > There was a period of time yesterday that svn package build was broken (version upgrade was not successful), that might affected a few other packages including perl, nzbget, and asterisk18. It has since been reverted and all affected packages should have been rebuilt/restored by now.
          >
          > Sorry for the breakage. We'll take a look in the future to see how to minimize the impact of broken builds.

          Hi,

          today svn was upgraded to 1.7.4-1, it doesnt work anymore (on a Synology DS410j).

          if I launch svnserve directly, I get :

          svnserve: error while loading shared libraries: libmagic.so.1: cannot open shared object file: No such file or directory
        • Brian
          For now, ipkg install file will get you the missing libmagic. I ll fix the build to add that dependency. -Brian
          Message 4 of 5 , May 17, 2012
          • 0 Attachment
            For now, "ipkg install file" will get you the missing libmagic.

            I'll fix the build to add that dependency.

            -Brian

            --- In nslu2-general@yahoogroups.com, "cpc664" <cpc664@...> wrote:
            >
            >
            >
            > --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@> wrote:
            > >
            > > There was a period of time yesterday that svn package build was broken (version upgrade was not successful), that might affected a few other packages including perl, nzbget, and asterisk18. It has since been reverted and all affected packages should have been rebuilt/restored by now.
            > >
            > > Sorry for the breakage. We'll take a look in the future to see how to minimize the impact of broken builds.
            >
            > Hi,
            >
            > today svn was upgraded to 1.7.4-1, it doesnt work anymore (on a Synology DS410j).
            >
            > if I launch svnserve directly, I get :
            >
            > svnserve: error while loading shared libraries: libmagic.so.1: cannot open shared object file: No such file or directory
            >
          • cpc664
            ... Thanks a lot, installing file and upgrading to SVN v1.7.5-1, and now it works again.
            Message 5 of 5 , May 18, 2012
            • 0 Attachment
              --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@...> wrote:
              >
              > For now, "ipkg install file" will get you the missing libmagic.
              >
              > I'll fix the build to add that dependency.

              Thanks a lot, installing file and upgrading to SVN v1.7.5-1, and now it works again.
            Your message has been successfully submitted and would be delivered to recipients shortly.