Loading ...
Sorry, an error occurred while loading the content.

ipkg lighttpd 1.4.30 with openssl causes a segmentation fault

Expand Messages
  • wouter_post
    Hello! I ve recently upgraded to lighttpd v1.4.30-1 from 1.4.29 on oleg fw and I noticed that it crashed. After some digging and testing out config files I
    Message 1 of 3 , Dec 20, 2011
    • 0 Attachment
      Hello!

      I've recently upgraded to lighttpd v1.4.30-1 from 1.4.29 on oleg fw and I noticed that it crashed.
      After some digging and testing out config files I noticed that when ssl was enabled lighttpd crashed with a segmentation fault.
      this happend as soon as you'd try to access a https page.

      ssl config:
      ------------------------------------------
      $SERVER["socket"] == ":443" {
      #### SSL engine
      ssl.engine = "enable"
      ssl.pemfile = "/opt/etc/lighttpd/server.pem"
      server.document-root = "/tmp/mnt/securedwww"
      }
      -------------------------------------------

      Everything is up to date, and openssl seems to be working fine.

      Any chance this bug could be fixed or does a workaround exists?
      I will provide extra information if required.

      Thanks!
      WPtE
    • romash2000
      There is a bug in Lighttpd-1.4.30 which was fixed in the 2822 revision: http://redmine.lighttpd.net/projects/lighttpd/repository/revisions/2822 Following patch
      Message 2 of 3 , Apr 30, 2012
      • 0 Attachment
        There is a bug in Lighttpd-1.4.30 which was fixed in the 2822 revision: http://redmine.lighttpd.net/projects/lighttpd/repository/revisions/2822

        Following patch must be applied by package creator; however, I don't know his contacts...

        Index: connections.c
        ===================================================================
        --- connections.c (revision 2821)
        +++ connections.c (revision 2822)
        @@ -1360,9 +1360,7 @@
        }

        con->renegotiations = 0;
        -#ifndef OPENSSL_NO_TLSEXT
        SSL_set_app_data(con->ssl, con);
        -#endif
        SSL_set_accept_state(con->ssl);
        con->conf.is_ssl=1;

        Best regards!

        --- In nslu2-general@yahoogroups.com, "wouter_post" <wp.soft@...> wrote:
        >
        > Hello!
        >
        > I've recently upgraded to lighttpd v1.4.30-1 from 1.4.29 on oleg fw and I noticed that it crashed.
        > After some digging and testing out config files I noticed that when ssl was enabled lighttpd crashed with a segmentation fault.
        > this happend as soon as you'd try to access a https page.
        >
        > ssl config:
        > ------------------------------------------
        > $SERVER["socket"] == ":443" {
        > #### SSL engine
        > ssl.engine = "enable"
        > ssl.pemfile = "/opt/etc/lighttpd/server.pem"
        > server.document-root = "/tmp/mnt/securedwww"
        > }
        > -------------------------------------------
        >
        > Everything is up to date, and openssl seems to be working fine.
        >
        > Any chance this bug could be fixed or does a workaround exists?
        > I will provide extra information if required.
        >
        > Thanks!
        > WPtE
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.