Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] USB disk (Seagate FreeAgent) spins down too much

Expand Messages
  • Harsh
    Hi, Is this a Seagate FreeAgent Go ? If it is, I got burned by the same problem before on SlugOS 5.3BE. I tried all the tricks on the nslu2-linux website about
    Message 1 of 3 , Sep 15, 2011
    • 0 Attachment
      Hi,


      Is this a Seagate FreeAgent Go ? If it is, I got burned by the same problem before on SlugOS 5.3BE. I tried all the tricks on the nslu2-linux website about spinning down using sdparm, using scsi idle, force wake-up, using the windows utility to set no/different sleep times, different buffer sizes on Samba, using just ftp, etc etc. but nothing worked. The disk appeared to spin down on idle time, or used to just abruptly disconnect when doing large data transfers and by the time it came back online, it basically had filesystem damage/unclean mounts. Mine was a USB powered disk, so it might have been because it wasn't getting enough power off the NSLU2 port. I had however not tried with a powered hub.


      I did some investigating online and there were several articles that claimed Seagate Freeagent drives were "not supported" on Linux in general but that people had found (working) work-arounds for the sleep issues.

      I however tried for weeks and then finally just abandoned the disk altogether (sold it off at a 40% loss), bought an externally powered SATA dock and used a regular disk of the same capacity. My new Debian Squeeze setup now works flawlessly and has been running un-interrupted for several months now with no issues and better perf :-).

      -H



      ________________________________
      From: radicedicinque <radicedicinque@...>
      To: nslu2-general@yahoogroups.com
      Sent: Wednesday, 14 September 2011 5:35 AM
      Subject: [nslu2-general] USB disk (Seagate FreeAgent) spins down too much


       
      Hi all,

      I am running Debian 5.0.7 with kernel 2.6.26 and a Seagate FreeAgent as main USB disk.

      Even though the disk is configured to not go to sleep at all (done via the utility under Windows), it still spins down after just a few seconds (3 to 5), for spinning up with considerable noise within a few others (10 to 30) because of disk activity.

      I would like to keep it active the whole time, but I cannot really figure out why it spins down at all. It seems to me that the USB driver is to blame. Still, I see no way to check its settings (e.g. with the various file in /sys or /proc).

      Any idea?

      Thanks




      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.