Loading ...
Sorry, an error occurred while loading the content.

OWW installation

Expand Messages
  • kc0qir
    I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via ipkg. If anyone
    Message 1 of 14 , Jan 23, 2011
    • 0 Attachment
      I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via ipkg. If anyone has a copy please let me know. Much appreciated in advance !
    • Mike Westerhof (mwester)
      ... Is it not in the feeds? Or do you need a special version of that package for some specific reason? -Mike (mwester)
      Message 2 of 14 , Jan 23, 2011
      • 0 Attachment
        On 1/23/2011 11:36 AM, kc0qir wrote:
        > I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via ipkg. If anyone has a copy please let me know. Much appreciated in advance !

        Is it not in the feeds? Or do you need a special version of that
        package for some specific reason?

        -Mike (mwester)
      • kc0qir
        The current uNSLUng installation using ipkg provides version libusb - 0.1.12-2. With this installation I cannot get OWW to talk to the USB port properly. I
        Message 3 of 14 , Jan 23, 2011
        • 0 Attachment
          The current uNSLUng installation using ipkg provides version libusb - 0.1.12-2. With this installation I cannot get OWW to talk to the USB port properly. I have another machine up and running that is using libusb - 0.1.12-1. So I need to be able to downgrade the package to see if that will fix my issue.


          --- In nslu2-general@yahoogroups.com, "Mike Westerhof (mwester)" <mwester@...> wrote:
          >
          > On 1/23/2011 11:36 AM, kc0qir wrote:
          > > I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via ipkg. If anyone has a copy please let me know. Much appreciated in advance !
          >
          > Is it not in the feeds? Or do you need a special version of that
          > package for some specific reason?
          >
          > -Mike (mwester)
          >
        • Doug
          I did get owfs working on the nslu2 running Debian but as I remember it was somewhat flaky and I ended up using the digitemp package instead. Not sure if it is
          Message 4 of 14 , Jan 23, 2011
          • 0 Attachment
            I did get owfs working on the nslu2 running Debian but as I remember it was
            somewhat flaky and I ended up using the digitemp package instead. Not sure if it
            is available for the unslung but it is for Debian. I suspect the source code
            would compile. It does not have the flexibility of owfs but does read the 1wire
            temp sensors and many others. I use it to monitor temps and humidity from a
            remote location via the Internet. It is independent of the file system and I
            have never had a bit of problem with it reading the USB via the 1 wire USB
            adapter. http://www.digitemp.com

            Doug Crompton
            WA3DSP
            www.crompton.com




            ________________________________
            From: kc0qir <kc0qir@...>
            To: nslu2-general@yahoogroups.com
            Sent: Sun, January 23, 2011 12:36:40 PM
            Subject: [nslu2-general] OWW installation


            I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using OWW. I
            am needing a copy of libusb - 0.1.12-1 that I can install via ipkg. If anyone
            has a copy please let me know. Much appreciated in advance !




            [Non-text portions of this message have been removed]
          • Mike Westerhof
            ... Ok. Use ipkg download libusb . Delete the libusb package it downloaded; you just need the URL it printed out. The old packages are not deleted out of
            Message 5 of 14 , Jan 24, 2011
            • 0 Attachment
              kc0qir wrote:
              > The current uNSLUng installation using ipkg provides version libusb - 0.1.12-2. With this installation I cannot get OWW to talk to the USB port properly. I have another machine up and running that is using libusb - 0.1.12-1. So I need to be able to downgrade the package to see if that will fix my issue.
              >

              Ok. Use "ipkg download libusb". Delete the libusb package it
              downloaded; you just need the URL it printed out. The old packages are
              not deleted out of the feed, so if you edit that URL with the version
              you want, you should be able to use wget to fetch the old ipk file.

              Unslung is pretty much dead - have you considered SlugOS or alternate
              firmware?

              -Mike (mwester)


              > --- In nslu2-general@yahoogroups.com, "Mike Westerhof (mwester)" <mwester@...> wrote:
              >
              >> On 1/23/2011 11:36 AM, kc0qir wrote:
              >>
              >>> I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via ipkg. If anyone has a copy please let me know. Much appreciated in advance !
              >>>
              >> Is it not in the feeds? Or do you need a special version of that
              >> package for some specific reason?
              >>
              >> -Mike (mwester)
              >>
            • GSV_NFA
              ... I ve hit exactly the same problem when rebuilding my old weather station: a power cut somehow fried the old usb stick so I had to rebuild. I haven t been
              Message 6 of 14 , May 17, 2011
              • 0 Attachment
                David Campbell wrote:
                >
                > I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using
                > OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via ipkg.
                > If anyone has a copy please let me know. Much appreciated in advance !
                >
                I've hit exactly the same problem when rebuilding my old weather station: a
                power cut somehow fried the old usb stick so I had to rebuild. I haven't
                been able to do a wget for the older version number as it comes back as 'Not
                Found'. Any help most appreciated!
                Cheers,
                Gerard

                --
                View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31641418.html
                Sent from the Nslu2 - General mailing list archive at Nabble.com.
              • GSV_NFA
                ... Scratch that, found it! http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk -- View this message in context:
                Message 7 of 14 , May 17, 2011
                • 0 Attachment
                  GSV_NFA wrote:
                  >
                  >
                  > David Campbell wrote:
                  >>
                  >> I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using
                  >> OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via
                  >> ipkg. If anyone has a copy please let me know. Much appreciated in
                  >> advance !
                  >>
                  > I've hit exactly the same problem when rebuilding my old weather station:
                  > a power cut somehow fried the old usb stick so I had to rebuild. I
                  > haven't been able to do a wget for the older version number as it comes
                  > back as 'Not Found'. Any help most appreciated!
                  > Cheers,
                  > Gerard
                  >
                  >
                  Scratch that, found it!
                  http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk


                  --
                  View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31641523.html
                  Sent from the Nslu2 - General mailing list archive at Nabble.com.
                • GSV_NFA
                  ... Double scratch that: ipkg refuses to downgrade for some reason, and I get the following: ipkg multiple packages (libusb and libusb) providing same name
                  Message 8 of 14 , May 18, 2011
                  • 0 Attachment
                    GSV_NFA wrote:
                    >
                    >
                    >
                    > GSV_NFA wrote:
                    >>
                    >>
                    >> David Campbell wrote:
                    >>>
                    >>> I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using
                    >>> OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via
                    >>> ipkg. If anyone has a copy please let me know. Much appreciated in
                    >>> advance !
                    >>>
                    >> I've hit exactly the same problem when rebuilding my old weather station:
                    >> a power cut somehow fried the old usb stick so I had to rebuild. I
                    >> haven't been able to do a wget for the older version number as it comes
                    >> back as 'Not Found'. Any help most appreciated!
                    >> Cheers,
                    >> Gerard
                    >>
                    >>
                    > Scratch that, found it!
                    > http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk
                    >
                    >
                    >
                    Double scratch that: ipkg refuses to downgrade for some reason, and I get
                    the following:
                    ipkg 'multiple packages (libusb and libusb) providing same name marked hold
                    or prefer. using latest and no matter what I've tried it stubbornly insists
                    on using the 0.1.12-2 version. I've also tried uninstalling libusb and oww,
                    then installing libusb 0.1.12-1 then oww, but it still insists on using the
                    newer version.

                    The ipkg options of -force-downgrade and -force-overwrite appear to be
                    ignored! It always finishes with "... using latest version".

                    --
                    View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31650850.html
                    Sent from the Nslu2 - General mailing list archive at Nabble.com.
                  • kc0qir
                    This is what I had encountered. No joy in mudville...
                    Message 9 of 14 , May 18, 2011
                    • 0 Attachment
                      This is what I had encountered. No joy in mudville...

                      --- In nslu2-general@yahoogroups.com, GSV_NFA <gsvnofixedabode@...> wrote:
                      >
                      >
                      >
                      >
                      > GSV_NFA wrote:
                      > >
                      > >
                      > >
                      > > GSV_NFA wrote:
                      > >>
                      > >>
                      > >> David Campbell wrote:
                      > >>>
                      > >>> I am working on a NSLU2 V2.3R63-uNSLUng-6.10-beta weather station using
                      > >>> OWW. I am needing a copy of libusb - 0.1.12-1 that I can install via
                      > >>> ipkg. If anyone has a copy please let me know. Much appreciated in
                      > >>> advance !
                      > >>>
                      > >> I've hit exactly the same problem when rebuilding my old weather station:
                      > >> a power cut somehow fried the old usb stick so I had to rebuild. I
                      > >> haven't been able to do a wget for the older version number as it comes
                      > >> back as 'Not Found'. Any help most appreciated!
                      > >> Cheers,
                      > >> Gerard
                      > >>
                      > >>
                      > > Scratch that, found it!
                      > > http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk
                      > >
                      > >
                      > >
                      > Double scratch that: ipkg refuses to downgrade for some reason, and I get
                      > the following:
                      > ipkg 'multiple packages (libusb and libusb) providing same name marked hold
                      > or prefer. using latest and no matter what I've tried it stubbornly insists
                      > on using the 0.1.12-2 version. I've also tried uninstalling libusb and oww,
                      > then installing libusb 0.1.12-1 then oww, but it still insists on using the
                      > newer version.
                      >
                      > The ipkg options of -force-downgrade and -force-overwrite appear to be
                      > ignored! It always finishes with "... using latest version".
                      >
                      > --
                      > View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31650850.html
                      > Sent from the Nslu2 - General mailing list archive at Nabble.com.
                      >
                    • GSV_NFA
                      ... Ok, so ipkg is ignoring its own flags now. This is getting VERY frustrating! Exactly where/why does it install 0.1.12-2 ?? -- View this message in
                      Message 10 of 14 , May 20, 2011
                      • 0 Attachment
                        > # ipkg install -force-reinstall -force-overwrite -force-downgrade
                        > http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk
                        > Downloading
                        > http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk
                        > Installing libusb (0.1.12-2) to root...
                        > Downloading
                        > http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libusb_0.1.12-2_armeb.ipk
                        > Configuring libusb
                        > Collected errors:
                        > Multiple packages (libusb and libusb) providing same name marked HOLD or
                        > PREFER. Using latest.
                        > Multiple packages (libusb and libusb) providing same name marked HOLD or
                        > PREFER. Using latest.
                        > #
                        Ok, so ipkg is ignoring its own flags now. This is getting VERY
                        frustrating! Exactly where/why does it install 0.1.12-2 ??
                        --
                        View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31661969.html
                        Sent from the Nslu2 - General mailing list archive at Nabble.com.
                      • David Campbell
                        I was wondering if someone could try and recompile under the latest Unslug build to fix the issues with the USB access I gave up trying to get work around but
                        Message 11 of 14 , May 20, 2011
                        • 0 Attachment
                          I was wondering if someone could try and recompile under the latest Unslug
                          build to fix the issues with the USB access

                          I gave up trying to get work around but am concerned if my existing
                          installation ever dies that I will be out of business. I am a hacker and not
                          a programmer so I rely on the skills and expertise of others.

                          Thanks in advance for any support.



                          GSV_NFA wrote:
                          >
                          >
                          >
                          >> # ipkg install -force-reinstall -force-overwrite -force-downgrade
                          >> http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk
                          >> Downloading
                          >> http://downloads.openwrt.org/kamikaze/old/8.09_RC1/ixp4xx/packages/libusb_0.1.12-1_armeb.ipk
                          >> Installing libusb (0.1.12-2) to root...
                          >> Downloading
                          >> http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/libusb_0.1.12-2_armeb.ipk
                          >> Configuring libusb
                          >> Collected errors:
                          >> Multiple packages (libusb and libusb) providing same name marked HOLD or
                          >> PREFER. Using latest.
                          >> Multiple packages (libusb and libusb) providing same name marked HOLD or
                          >> PREFER. Using latest.
                          >> #
                          > Ok, so ipkg is ignoring its own flags now. This is getting VERY
                          > frustrating! Exactly where/why does it install 0.1.12-2 ??
                          >

                          --
                          View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31668585.html
                          Sent from the Nslu2 - General mailing list archive at Nabble.com.
                        • GSV_NFA
                          SUCCESS!! I got an email from Simon Melhueish (oww author) who pointed me in the direction of the older version of oww:
                          Message 12 of 14 , May 21, 2011
                          • 0 Attachment
                            SUCCESS!!
                            I got an email from Simon Melhueish (oww author) who pointed me in the
                            direction of the older version of oww:
                            http://sourceforge.net/projects/oww/files/oww/0.82.1/
                            I then uninstalled the current 83.1 version, installed 82.1 from the above
                            link, but still had no luck: the package just stopped responding.
                            I then tried downgrading the libusb package again to 0.1.12-1 but still the
                            same error and continued to run 0.1.12-2.
                            Then the sneaky bit: grabbed the older /opt/lib/libusb-0.1.so.4 and
                            libusb-0.1.so.4.4.4 files from a backup and copied them into the current
                            /opt/lib/ directory and restarted the Slug.
                            BY GOLLY IT WORKED! :-) Sluggy now pumping out the weather info once again
                            at www.hyland.tk


                            David Campbell wrote:
                            >
                            > I was wondering if someone could try and recompile under the latest Unslug
                            > build to fix the issues with the USB access
                            >

                            --
                            View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31673108.html
                            Sent from the Nslu2 - General mailing list archive at Nabble.com.
                          • David Campbell
                            Any chance you could emai me those two libusb files ? ... -- View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31675765.html Sent
                            Message 13 of 14 , May 22, 2011
                            • 0 Attachment
                              Any chance you could emai me those two libusb files ?



                              GSV_NFA wrote:
                              >
                              > SUCCESS!!
                              > I got an email from Simon Melhueish (oww author) who pointed me in the
                              > direction of the older version of oww:
                              > http://sourceforge.net/projects/oww/files/oww/0.82.1/
                              > I then uninstalled the current 83.1 version, installed 82.1 from the above
                              > link, but still had no luck: the package just stopped responding.
                              > I then tried downgrading the libusb package again to 0.1.12-1 but still
                              > the same error and continued to run 0.1.12-2.
                              > Then the sneaky bit: grabbed the older /opt/lib/libusb-0.1.so.4 and
                              > libusb-0.1.so.4.4.4 files from a backup and copied them into the current
                              > /opt/lib/ directory and restarted the Slug.
                              > BY GOLLY IT WORKED! :-) Sluggy now pumping out the weather info once
                              > again at www.hyland.tk
                              >
                              >
                              > David Campbell wrote:
                              >>
                              >> I was wondering if someone could try and recompile under the latest
                              >> Unslug build to fix the issues with the USB access
                              >>
                              >
                              >

                              --
                              View this message in context: http://old.nabble.com/OWW-installation-tp30743102p31675765.html
                              Sent from the Nslu2 - General mailing list archive at Nabble.com.
                            • swiftarf
                              Hi, I m having the same frustration with ipkg and trying to downgrade libusb_0.1.12-2. Would you mind e-mailing me the 2 .so files you used in your workaround
                              Message 14 of 14 , Jun 16, 2013
                              • 0 Attachment
                                Hi,
                                I'm having the same frustration with ipkg and trying to downgrade
                                libusb_0.1.12-2. Would you mind e-mailing me the 2 .so files you used in
                                your workaround please?
                                Thanks,
                                Simon



                                --
                                View this message in context: http://nslu2.10980.n7.nabble.com/OWW-installation-tp2089p20207.html
                                Sent from the General mailing list archive at Nabble.com.
                              Your message has been successfully submitted and would be delivered to recipients shortly.