Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] What is wrong?

Expand Messages
  • Mike Westerhof (mwester)
    ... Clearly owhttpd is present -- so the error message is indicating that something else is not found . The system is interpreting the owhttpd file as a
    Message 1 of 5 , May 25 7:09 AM
    • 0 Attachment
      JaskaJ wrote:
      > I install owfs and oww to my slugos 5.3. When trying to start them nothing happens.. What I should try next?
      >
      > root@logger:/home# ls -l /opt/bin/ow*
      > -rwxr-xr-x 1 root root 14040 May 15 23:59 /opt/bin/owdir
      > -rwxr-xr-x 1 root root 11180 May 15 23:59 /opt/bin/owfs
      > -rwxr-xr-x 1 root root 53784 May 15 23:59 /opt/bin/owftpd
      > -rwxr-xr-x 1 root root 14096 May 15 23:59 /opt/bin/owget
      > -rwxr-xr-x 1 root root 22896 May 15 23:59 /opt/bin/owhttpd
      > -rwxr-xr-x 1 root root 13896 May 15 23:59 /opt/bin/owpresent
      > -rwxr-xr-x 1 root root 13928 May 15 23:59 /opt/bin/owread
      > -rwxr-xr-x 1 root root 21332 May 15 23:59 /opt/bin/owserver
      > -rwxr-xr-x 1 root root 173840 Mar 27 13:58 /opt/bin/owwnogui
      > -rwxr-xr-x 1 root root 14852 May 15 23:59 /opt/bin/owwrite
      > root@logger:/home# owwnogui -i
      > -sh: owwnogui: not found
      > root@logger:/home# /opt/bin/owwnogui -i
      > -sh: /opt/bin/owwnogui: not found
      > root@logger:/home# /opt/bin/owf
      > /opt/bin/owfs /opt/bin/owftpd
      > root@logger:/home# /opt/bin/owfs
      > -sh: /opt/bin/owfs: not found
      > root@logger:/home# /opt/bin/owhttpd
      > -sh: /opt/bin/owhttpd: not found
      >
      Clearly owhttpd is present -- so the error message is indicating that
      something else is "not found". The system is interpreting the owhttpd
      file as a shell script, and trying to find the interpretor for that script.

      So you need to find out what sort of files these are -- type "head
      /opt/bin/owhttpd" and it will print the first few lines of the file. If
      you get garbage, it's binary -- next paragraph. If you get something
      that looks like "#!/bin/bash" at the top of the file, then it is, in
      fact, a script -- and it is the interpretor that you are missing. If
      it's bash (as the example I typed there), then install bash. Otherwise,
      figure out what interpretor it is, and install it.

      It seems unlikely that those are all scripts, though -- more likely
      you'll get garbage (binary) when you use the "head" command. So that
      means that the files are not recognized as executable programs -- they
      are incompatible with your system. The question then is, where did you
      get the owfs package? We'll need to know a lot more about what you are
      running on (did you install SlugOS/BE or LE?), and what steps you took
      to install owfs (including what steps you took to install the optware
      feeds).

      -Mike (mwester)


      > root@logger:/home# $PATH
      > -sh: /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/bin: not found
      >

      (BTW, the above line is a very poor way to print out your path: use
      "echo $PATH" instead.)
    • JaskaJ
      I m using slugOS/BE 5.3 Files are binary. slugOS and optware feeds are installed with this guide
      Message 2 of 5 , May 25 9:32 AM
      • 0 Attachment
        I'm using slugOS/BE 5.3
        Files are binary.
        slugOS and optware feeds are installed with this guide http://www.nslu2-linux.org/wiki/SlugOS/InstallandTurnupABasicSlugOSSystem

        I installed both, oww and owfs, first with ipkg. Then I try install them from source. Same results..
        oww files are here https://sourceforge.net/projects/oww/files/
        owfs here: https://sourceforge.net/projects/owfs/files/
        bash is installed already.


        Jussi
      • Brian
        Can you /opt/bin/ipkg install openssl and retry? If that solves the problem, the oww package has a missing dependency. -Brian
        Message 3 of 5 , May 25 3:10 PM
        • 0 Attachment
          Can you "/opt/bin/ipkg install openssl" and retry? If that solves the problem, the oww package has a missing dependency.

          -Brian

          --- In nslu2-general@yahoogroups.com, "JaskaJ" <jkphome@...> wrote:
          >
          > I install owfs and oww to my slugos 5.3. When trying to start them nothing happens.. What I should try next?
          >
          > root@logger:/home# ls -l /opt/bin/ow*
          > -rwxr-xr-x 1 root root 14040 May 15 23:59 /opt/bin/owdir
          > -rwxr-xr-x 1 root root 11180 May 15 23:59 /opt/bin/owfs
          > -rwxr-xr-x 1 root root 53784 May 15 23:59 /opt/bin/owftpd
          > -rwxr-xr-x 1 root root 14096 May 15 23:59 /opt/bin/owget
          > -rwxr-xr-x 1 root root 22896 May 15 23:59 /opt/bin/owhttpd
          > -rwxr-xr-x 1 root root 13896 May 15 23:59 /opt/bin/owpresent
          > -rwxr-xr-x 1 root root 13928 May 15 23:59 /opt/bin/owread
          > -rwxr-xr-x 1 root root 21332 May 15 23:59 /opt/bin/owserver
          > -rwxr-xr-x 1 root root 173840 Mar 27 13:58 /opt/bin/owwnogui
          > -rwxr-xr-x 1 root root 14852 May 15 23:59 /opt/bin/owwrite
          > root@logger:/home# owwnogui -i
          > -sh: owwnogui: not found
          > root@logger:/home# /opt/bin/owwnogui -i
          > -sh: /opt/bin/owwnogui: not found
          > root@logger:/home# /opt/bin/owf
          > /opt/bin/owfs /opt/bin/owftpd
          > root@logger:/home# /opt/bin/owfs
          > -sh: /opt/bin/owfs: not found
          > root@logger:/home# /opt/bin/owhttpd
          > -sh: /opt/bin/owhttpd: not found
          > root@logger:/home# $PATH
          > -sh: /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/bin: not found
          >
        • JaskaJ
          Package openssl (0.9.8n-1) installed in root is up to date.
          Message 4 of 5 , May 25 7:54 PM
          • 0 Attachment
            Package openssl (0.9.8n-1) installed in root is up to date.

            --- In nslu2-general@yahoogroups.com, "Brian" <b88zhou@...> wrote:
            >
            > Can you "/opt/bin/ipkg install openssl" and retry? If that solves the problem, the oww package has a missing dependency.
            >
            > -Brian
            >
            > --- In nslu2-general@yahoogroups.com, "JaskaJ" <jkphome@> wrote:
            > >
            > > I install owfs and oww to my slugos 5.3. When trying to start them nothing happens.. What I should try next?
            > >
            > > root@logger:/home# ls -l /opt/bin/ow*
            > > -rwxr-xr-x 1 root root 14040 May 15 23:59 /opt/bin/owdir
            > > -rwxr-xr-x 1 root root 11180 May 15 23:59 /opt/bin/owfs
            > > -rwxr-xr-x 1 root root 53784 May 15 23:59 /opt/bin/owftpd
            > > -rwxr-xr-x 1 root root 14096 May 15 23:59 /opt/bin/owget
            > > -rwxr-xr-x 1 root root 22896 May 15 23:59 /opt/bin/owhttpd
            > > -rwxr-xr-x 1 root root 13896 May 15 23:59 /opt/bin/owpresent
            > > -rwxr-xr-x 1 root root 13928 May 15 23:59 /opt/bin/owread
            > > -rwxr-xr-x 1 root root 21332 May 15 23:59 /opt/bin/owserver
            > > -rwxr-xr-x 1 root root 173840 Mar 27 13:58 /opt/bin/owwnogui
            > > -rwxr-xr-x 1 root root 14852 May 15 23:59 /opt/bin/owwrite
            > > root@logger:/home# owwnogui -i
            > > -sh: owwnogui: not found
            > > root@logger:/home# /opt/bin/owwnogui -i
            > > -sh: /opt/bin/owwnogui: not found
            > > root@logger:/home# /opt/bin/owf
            > > /opt/bin/owfs /opt/bin/owftpd
            > > root@logger:/home# /opt/bin/owfs
            > > -sh: /opt/bin/owfs: not found
            > > root@logger:/home# /opt/bin/owhttpd
            > > -sh: /opt/bin/owhttpd: not found
            > > root@logger:/home# $PATH
            > > -sh: /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/bin: not found
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.