Loading ...
Sorry, an error occurred while loading the content.
 

Re: NSLU2 Drops Connection to LARGE Disk

Expand Messages
  • docbillnet
    Have you considered you might be having over heating problems? Chances are when you plug the same enclosures on your PC, you are putting them through the same
    Message 1 of 14 , Sep 7, 2009
      Have you considered you might be having over heating problems? Chances are when you plug the same enclosures on your PC, you are putting them through the same usage scenario. You might also have better power saving settings on your PC that allows the drives time to cool off between uses. I personally use a USB stick for my NSLU's to boot off of, so my hard drives can power down longer and they seek less when in use.

      I did put my swap partitions on the hard drives, because I have a cheap USB stick with very slow write performance. Fortunately, I found for my uses swap is not accessed very frequently, so my drives can still power down.

      Of course one reason I did that is the fan for the hard drive enclosure is noisy, and I do not like to hear it running at night. Unless my wife is playing a movie, I don't hear a thing this way.

      Bill


      --- In nslu2-general@yahoogroups.com, "jtgreeno" <jtg-0812@...> wrote:
      >
      > I had been using a stock NSLU2 since 2005 with a 250 GB USB drive and a
      > 1GB USB Flash key. I recently replaced the flash key with a 1.5TB USB
      > drive, which I tried with both EXT3 and NTFS formats (the NSLU2 was at
      > firmware v23R63)... In either format, the connection would drop
      > frequently, and was not stable enough to be the target for a backup
      > process that was formerly successfully targeted to the 250 GB drive...
      >
      > After discovering this forum, I uNSLUng it (v6.10), and and noted the
      > drops still occurred. Then I corrected the clock speed back to 266, and
      > still had frequent drops. I then flashed the NSLU2 to V23R72 & still
      > had drops, so I reflashed back to V23R63... Trying all of these
      > combinations and on both ports with EXT3 and NTFS (where supported):
      >
      > Clock \ Firmware V23R64 6.10 V23R72 133 dropped dropped not
      > tried 266 dropped dropped dropped
      >
      > There seems to be an inherent problem with the NSL's ability to
      > consistently access a "large" disk (> 500 GB).
      >
      > Has anyone encountered this and found a work-around to enable a 1.5TB
      > disk to be consistently accessible & stable? If so, please share your
      > configuration &/or the "tricks" you used.
      >
      > Thanks!
      > JTG
      >
      >
      >
      >
      >
      > [Non-text portions of this message have been removed]
      >
    • jtgreeno
      I haven t considered overheating, and I don t recall the NSLU2 being very warm. (each time the connection dropped, I tried a different connection, so I did
      Message 2 of 14 , Sep 7, 2009
        I haven't considered overheating, and I don't recall the NSLU2 being very warm. (each time the connection dropped, I tried a different connection, so I did pick up the NSLU2 just after each drop).

        I'm not sure I have the means to trouble-shoot this, though, so if anyone has discovered a fix, please post.

        Thanks!
        JTG

        --- In nslu2-general@yahoogroups.com, "docbillnet" <yahoo@...> wrote:
        >
        > Have you considered you might be having over heating problems? Chances are when you plug the same enclosures on your PC, you are putting them through the same usage scenario. You might also have better power saving settings on your PC that allows the drives time to cool off between uses. I personally use a USB stick for my NSLU's to boot off of, so my hard drives can power down longer and they seek less when in use.
        >
        > I did put my swap partitions on the hard drives, because I have a cheap USB stick with very slow write performance. Fortunately, I found for my uses swap is not accessed very frequently, so my drives can still power down.
        >
        > Of course one reason I did that is the fan for the hard drive enclosure is noisy, and I do not like to hear it running at night. Unless my wife is playing a movie, I don't hear a thing this way.
        >
        > Bill
        >
        >
        > --- In nslu2-general@yahoogroups.com, "jtgreeno" <jtg-0812@> wrote:
        > >
        > > I had been using a stock NSLU2 since 2005 with a 250 GB USB drive and a
        > > 1GB USB Flash key. I recently replaced the flash key with a 1.5TB USB
        > > drive, which I tried with both EXT3 and NTFS formats (the NSLU2 was at
        > > firmware v23R63)... In either format, the connection would drop
        > > frequently, and was not stable enough to be the target for a backup
        > > process that was formerly successfully targeted to the 250 GB drive...
        > >
        > > After discovering this forum, I uNSLUng it (v6.10), and and noted the
        > > drops still occurred. Then I corrected the clock speed back to 266, and
        > > still had frequent drops. I then flashed the NSLU2 to V23R72 & still
        > > had drops, so I reflashed back to V23R63... Trying all of these
        > > combinations and on both ports with EXT3 and NTFS (where supported):
        > >
        > > Clock \ Firmware V23R64 6.10 V23R72 133 dropped dropped not
        > > tried 266 dropped dropped dropped
        > >
        > > There seems to be an inherent problem with the NSL's ability to
        > > consistently access a "large" disk (> 500 GB).
        > >
        > > Has anyone encountered this and found a work-around to enable a 1.5TB
        > > disk to be consistently accessible & stable? If so, please share your
        > > configuration &/or the "tricks" you used.
        > >
        > > Thanks!
        > > JTG
        > >
        > >
        > >
        > >
        > >
        > > [Non-text portions of this message have been removed]
        > >
        >
      • docbillnet
        ... Not the NSLU2, the hard drives. When I was using enclosures without fans my hard drives would drop connection regularly. The hard drives themselves
        Message 3 of 14 , Sep 8, 2009
          --- In nslu2-general@yahoogroups.com, "jtgreeno" <jtg-0812@...> wrote:
          >
          > I haven't considered overheating, and I don't recall the NSLU2 being very warm. (each time the connection dropped, I tried a different connection, so I did pick up the NSLU2 just after each drop).
          >

          Not the NSLU2, the hard drives. When I was using enclosures without fans my hard drives would drop connection regularly. The hard drives themselves were smoking hot. So I attributed the fundamental problem to heat. I'm guessing when they are too hot they start sending some bad bits. For some reason my desktop computers can recover from the problem but the NSLU2 can not. I have some guesses as to why this is, but nothing that I have verified. However, keeping the drives well ventilated resolved the problem for except if as you say I try doing a full drive backup. After about 24 hours continuous use the drives will still seem to drop. But even with the best ventilation the larger hard drives have a tendency to overheat. I use rsync, so I can just update my backups incrementally, thus avoiding the issue with continuous use.

          > I'm not sure I have the means to trouble-shoot this, though, so if anyone has discovered a fix, please post.
          >
          > Thanks!
          > JTG
          >
          > --- In nslu2-general@yahoogroups.com, "docbillnet" <yahoo@> wrote:
          > >
          > > Have you considered you might be having over heating problems? Chances are when you plug the same enclosures on your PC, you are putting them through the same usage scenario. You might also have better power saving settings on your PC that allows the drives time to cool off between uses. I personally use a USB stick for my NSLU's to boot off of, so my hard drives can power down longer and they seek less when in use.
          > >
          > > I did put my swap partitions on the hard drives, because I have a cheap USB stick with very slow write performance. Fortunately, I found for my uses swap is not accessed very frequently, so my drives can still power down.
          > >
          > > Of course one reason I did that is the fan for the hard drive enclosure is noisy, and I do not like to hear it running at night. Unless my wife is playing a movie, I don't hear a thing this way.
          > >
          > > Bill
          > >
          > >
          > > --- In nslu2-general@yahoogroups.com, "jtgreeno" <jtg-0812@> wrote:
          > > >
          > > > I had been using a stock NSLU2 since 2005 with a 250 GB USB drive and a
          > > > 1GB USB Flash key. I recently replaced the flash key with a 1.5TB USB
          > > > drive, which I tried with both EXT3 and NTFS formats (the NSLU2 was at
          > > > firmware v23R63)... In either format, the connection would drop
          > > > frequently, and was not stable enough to be the target for a backup
          > > > process that was formerly successfully targeted to the 250 GB drive...
          > > >
          > > > After discovering this forum, I uNSLUng it (v6.10), and and noted the
          > > > drops still occurred. Then I corrected the clock speed back to 266, and
          > > > still had frequent drops. I then flashed the NSLU2 to V23R72 & still
          > > > had drops, so I reflashed back to V23R63... Trying all of these
          > > > combinations and on both ports with EXT3 and NTFS (where supported):
          > > >
          > > > Clock \ Firmware V23R64 6.10 V23R72 133 dropped dropped not
          > > > tried 266 dropped dropped dropped
          > > >
          > > > There seems to be an inherent problem with the NSL's ability to
          > > > consistently access a "large" disk (> 500 GB).
          > > >
          > > > Has anyone encountered this and found a work-around to enable a 1.5TB
          > > > disk to be consistently accessible & stable? If so, please share your
          > > > configuration &/or the "tricks" you used.
          > > >
          > > > Thanks!
          > > > JTG
          > > >
          > > >
          > > >
          > > >
          > > >
          > > > [Non-text portions of this message have been removed]
          > > >
          > >
          >
        • djmuk2
          If you find a solution then let me know - I have the same problem. Generally a restart of the slug cures it but it just took 2 restarts to find the 2nd disk
          Message 4 of 14 , Oct 12, 2009
            If you find a solution then let me know - I have the same problem. Generally
            a restart of the slug cures it but it just took 2 restarts to find the 2nd
            disk again. Interesting that you found the same problem when you unslung it
            as that was going to be my next port of call.... Possible it is the drive
            overheating as I am sure I saw somewhere else that the slug doesn't spin the
            drives down....

            Have you tried the bigger disk on port 1 and the smaller on on port 2 - It
            seems to treat the 2 port differently (eg can use NTFS on 1 and not 2)... My
            one is on a remote site so it is a pain to make changes (and is the backup
            target so I don't really want to take it off site either...)

            thanks

            David

            --
            View this message in context: http://www.nabble.com/NSLU2-Drops-Connection-to-LARGE-Disk-tp25334921p25804665.html
            Sent from the Nslu2 - General mailing list archive at Nabble.com.
          • JimG
            My slug is overclocked & running stock firmware V2.3R76. Drive 1 is a 2TB drive; it s 2 1-gb drives in a dual-sata enclosure with the drives striped & set to
            Message 5 of 14 , Oct 25, 2009
              My slug is overclocked & running stock firmware V2.3R76. Drive 1 is a 2TB drive; it's 2 1-gb drives in a dual-sata enclosure with the drives striped & set to RAID 0 via the sata enclosure. No data or connection issues, been running over 6 months with the occasional reboot due to brownouts.

              Drive 2 is a 500GB 'normal' USB drive; the slug performs a nightly backup to this drive. Again no problems.

              Only issue I've run into is the Administration/Advanced/Disk interface has problems running Scandisk on disk1.

              Wonder if the V2.3R76 firmware helps- hope my posting may be of benefit. Happy Slugging :)
            • dnabble
              I bought a new (but alas discontinued) NSLU2, a pair of 1.5T internal eSATA drives, and a pair of almost matching BlackX HDD USB/eSATA docking stations.
              Message 6 of 14 , Oct 28, 2009
                I bought a "new" (but alas discontinued) NSLU2, a pair of 1.5T internal eSATA
                drives, and a pair of "almost" matching BlackX HDD USB/eSATA "docking
                stations."

                Not so prominently printed on the BlackX boxes, is the phrase: "SUPPORT UP
                TO 1TB (1,000GB) H.D.D."

                Rats!!

                Nevertheless, I decided to try, and went ahead with formatting, figuring to
                see an error message, signaling failure.

                Formats appeared to succeed, as did unslinging (SlugOS/LE), as did rsyncing,
                for a time, and therein lies a tale.

                As the drive filled up, the rsync process would hang inexplicably, and hang
                the slug: all and any terminal sessions would become unresponsive and new
                ssh requests ignored.

                Reboots always solved the problem, and always the slug was good for whatever
                you wanted, which seems to suggest overheating was not the problem. In fact
                the hanging was always associated with an rsync copying more files inbound.

                I was worried at first that, for the first time (in 4 slugs), the
                over-clocking to 266 MHz had bit me, but (see overheating consideration
                above) the hanging should have been random and not so connected with rsync.

                The mystifier was that (1) rsync would hang during a large (1GB) file
                transfer, (2) reboot, (3) rsync might appear to complete that file transfer
                and hang during an ensuing one. The disk "fill" was at around 80% as I
                recall.

                The problem also MIGHT have been related to my use of a 32MB "swapfile"
                instead of a larger, and real-er, swap "partition." (SlugOS/LE is smart
                enough managing memory to be able to get by with a smallish swapfile, in my
                understanding. [See "Install and Turnup SlugOS" at www.nslu2-linux.org]

                At any rate, my solution:
                Decide to live within the means of the BlackX docking stations and partition
                the drive with TWO sizable data partitions (91000 blocks) and a THIRD
                remainder swap partition (400 blocks).

                So far, I filled the first data partition to 82%, and have started the
                second. The acid test will come when that 2nd data partition hits around
                80-90%, but the NSLU2 hasn't so much as burped. IF CPU or disk were
                overheating, or IF it was over-overclocked, there should've been a burp,
                because the rsync stress is identical to the first case.

                Cheers!


                --
                View this message in context: http://www.nabble.com/NSLU2-Drops-Connection-to-LARGE-Disk-tp25334921p26093228.html
                Sent from the Nslu2 - General mailing list archive at Nabble.com.
              • djmalne
                Hmm perhaps the newer f/w does help - where did you get it...? Also I note that you have the bigger disk on port 1 which was one thing I considered as an
                Message 7 of 14 , Oct 28, 2009
                  Hmm perhaps the newer f/w does help - where did you get it...?

                  Also I note that you have the bigger disk on port 1 which was one thing I considered as an option as both disk ports do not appear to be created equal...

                  David
                • JimG
                  I think I downloaded it from linksys FTP site a few years ago. Their FTP site seems to no longer be available. Googling nslu2 2.3R76 will locate some
                  Message 8 of 14 , Oct 31, 2009
                    I think I downloaded it from linksys' FTP site a few years ago. Their FTP site seems to no longer be available. Googling 'nslu2 2.3R76' will locate some download options.

                    The larger disk was connected to disk1 as I did not obtain the backup drive 'till a later time. My NSLU2 implementation was not planned per se, it just came together to solve a file sharing problem, which it has done well.

                    --- In nslu2-general@yahoogroups.com, "djmalne" <nabble.admin@...> wrote:
                    >
                    > Hmm perhaps the newer f/w does help - where did you get it...?
                    >
                    > Also I note that you have the bigger disk on port 1 which was one thing I considered as an option as both disk ports do not appear to be created equal...
                    >
                    > David
                    >
                  • djmalne
                    I found the new f/ware - as you suggested I had googled it already! It does seem more stable so I will wait and see... David
                    Message 9 of 14 , Nov 1, 2009
                      I found the new f/ware - as you suggested I had googled it already!

                      It does seem more stable so I will wait and see...

                      David
                    • gamesharkmike
                      I have had connections drop with NTFS on my 80 GB USB Hard drive. I made a topic but I kept getting emails saying Post to mailing list still pending and one
                      Message 10 of 14 , Nov 3, 2009
                        I have had connections drop with NTFS on my 80 GB USB Hard drive.

                        I made a topic but I kept getting emails saying "Post to mailing list still pending" and one that said "Unable to deliver your message"


                        http://www.nabble.com/NTFS-drives-on-NSLU2-tp24583514p24583514.html
                        http://old.nabble.com/NTFS-drives-on-NSLU2-td24583514.html#a24583514
                      • Mike Westerhof
                        ... Send your emails directly to the nslu2-general email list, not via nabble. Mike (mwester)
                        Message 11 of 14 , Nov 4, 2009
                          gamesharkmike wrote:
                          > I have had connections drop with NTFS on my 80 GB USB Hard drive.
                          >
                          > I made a topic but I kept getting emails saying "Post to mailing list still pending" and one that said "Unable to deliver your message"
                          >
                          Send your emails directly to the nslu2-general email list, not via nabble.

                          Mike (mwester)
                        • Mai Kee Reis
                          I copied 1 TB of files from one disk to another at the same NSLU2 (new 266MHz from factory). All okay! My housings are both IcyBox IB-351 StUS-B (one
                          Message 12 of 14 , Nov 4, 2009
                            I copied 1 TB of files from one disk to another at the same NSLU2 (new
                            266MHz from factory).
                            All okay!
                            My housings are both IcyBox "IB-351 StUS-B" (one purchased in mid 2008,
                            one in October 2009).
                            My disks are WD10EACS 1TB SATA (same purchase data).
                            OS is SlugOS/LE 5.3 with addition of the optware package, SMB and screen.
                            Screen is required to do such long lasting actions from ssh terminal -
                            otherwise one has to keep
                            the ssh terminal all time open and connected and the ssh guest computer
                            all times on.

                            The Slug didn't got hot.
                            Say 45°C instead of 38°C when idling (estimation related to my own body
                            temperature).

                            So, if anybody gots problems like dnabble got, he may try my test.
                            If this test also fails, the Slug or the USB Disk Housings or the Power
                            Supply Units are scrap.

                            see:

                            MySlug:~# sreen -r
                            MySlug:~# dd bs=2048k if=/dev/sdb3 of=/dev/sdc3
                            473862+1 records in
                            473862+1 records out
                            993761846784 bytes (994 GB) copied, 273498 seconds, 3.6 MB/s
                            MySlug:~#

                            Note:
                            273498 sec = 4558 min = 76 h = 3.2 days!

                            Okay, pretty slow. But it runs hell stable!
                            Without the 2MB buffer, it would be much slower ;-)

                            with best regards,
                            Mai Kee

                            > There is 1 message in this issue.
                            >
                            > Topics in this digest:
                            >
                            > 1a. Re: NSLU2 Drops Connection to LARGE Disk
                            > From: dnabble
                            >
                            >
                            > Message
                            > ________________________________________________________________________
                            > 1a. Re: NSLU2 Drops Connection to LARGE Disk
                            > Posted by: "dnabble" david.nelson.wi@... cnczane
                            > Date: Wed Oct 28, 2009 4:45 am ((PDT))
                            >
                            >
                            > I bought a "new" (but alas discontinued) NSLU2, a pair of 1.5T internal eSATA
                            > drives, and a pair of "almost" matching BlackX HDD USB/eSATA "docking
                            > stations."
                            >
                            > Not so prominently printed on the BlackX boxes, is the phrase: "SUPPORT UP
                            > TO 1TB (1,000GB) H.D.D."
                            >
                            > Rats!!
                            >
                            > Nevertheless, I decided to try, and went ahead with formatting, figuring to
                            > see an error message, signaling failure.
                            >
                            > Formats appeared to succeed, as did unslinging (SlugOS/LE), as did rsyncing,
                            > for a time, and therein lies a tale.
                            >
                            > As the drive filled up, the rsync process would hang inexplicably, and hang
                            > the slug: all and any terminal sessions would become unresponsive and new
                            > ssh requests ignored.
                            >
                            > Reboots always solved the problem, and always the slug was good for whatever
                            > you wanted, which seems to suggest overheating was not the problem. In fact
                            > the hanging was always associated with an rsync copying more files inbound.
                            >
                            > I was worried at first that, for the first time (in 4 slugs), the
                            > over-clocking to 266 MHz had bit me, but (see overheating consideration
                            > above) the hanging should have been random and not so connected with rsync.
                            >
                            > The mystifier was that (1) rsync would hang during a large (1GB) file
                            > transfer, (2) reboot, (3) rsync might appear to complete that file transfer
                            > and hang during an ensuing one. The disk "fill" was at around 80% as I
                            > recall.
                            >
                            > The problem also MIGHT have been related to my use of a 32MB "swapfile"
                            > instead of a larger, and real-er, swap "partition." (SlugOS/LE is smart
                            > enough managing memory to be able to get by with a smallish swapfile, in my
                            > understanding. [See "Install and Turnup SlugOS" at www.nslu2-linux.org]
                            >
                            > At any rate, my solution:
                            > Decide to live within the means of the BlackX docking stations and partition
                            > the drive with TWO sizable data partitions (91000 blocks) and a THIRD
                            > remainder swap partition (400 blocks).
                            >
                            > So far, I filled the first data partition to 82%, and have started the
                            > second. The acid test will come when that 2nd data partition hits around
                            > 80-90%, but the NSLU2 hasn't so much as burped. IF CPU or disk were
                            > overheating, or IF it was over-overclocked, there should've been a burp,
                            > because the rsync stress is identical to the first case.
                            >
                            > Cheers!
                            >
                            >
                            >
                          • gamesharkmike
                            ... I didn t send an email, I used the new topic link. So this is a newsgroup? So does that mean you can post by sending an email?
                            Message 13 of 14 , Nov 6, 2009
                              --- In nslu2-general@yahoogroups.com, Mike Westerhof <mwester@...> wrote:
                              >
                              > gamesharkmike wrote:
                              > > I have had connections drop with NTFS on my 80 GB USB Hard drive.
                              > >
                              > > I made a topic but I kept getting emails saying "Post to mailing list still pending" and one that said "Unable to deliver your message"
                              > >
                              > Send your emails directly to the nslu2-general email list, not via nabble.
                              >
                              > Mike (mwester)
                              >
                              I didn't send an email, I used the new topic link.

                              So this is a newsgroup? So does that mean you can post by sending an email?
                            Your message has been successfully submitted and would be delivered to recipients shortly.