Loading ...
Sorry, an error occurred while loading the content.

Re: Help please to access HDD data

Expand Messages
  • janne5011
    Hi try this in your Ubuntu machine put in your disk and type sudo umount /dev/sbd2 (suppose that the disk with problem) sudo fsck -f /dev/sbd2 probably fsck
    Message 1 of 2 , Apr 7, 2009
      Hi try this in your Ubuntu machine

      put in your disk and type
      sudo umount /dev/sbd2 (suppose that the disk with problem)
      sudo fsck -f /dev/sbd2
      probably fsck will ask you for changes and probably the right
      answer yes
      now try to acess your folders.
      If you have very important data dont do this before its confirmed to work from one more person.
      good luck

      --- In nslu2-general@yahoogroups.com, "pucedynamo" <mail1@...> wrote:
      > Hello
      > Firstly, some background (sorry it's a bit long winded). I have very limited knowledge of Linux. My home network and PCs are entirely Windows based. Please also bear in mind that I may be trying to resolve my problem here by trying to do something that just can't be done (in this way). Apologies in advance.
      > Bought a NSLU2 unit about 4 years ago to use with my Topfield PVR. UnSlung it with the version available at the time (not to disk though). All worked fine. Then added a 300Gb USB2 HDD for backups etc. Again all fine. Then, for the last couple of years the Slug + HDD has just been a NAS device. More recently (can't remeber when exactly) I upgraded the NSLU2 with the UnSlung firmware version V2.3R63-uNSLUng-6.8-beta. This time I did choose the UnSlung to disk option (by mistake actually) However, everything worked and was fine and so it was until yesterday morning (Monday, start of week).
      > Powered everything up as usual. All looked normal but Windows network mapped drives to Slug failed to restore connections. Then noticed that the NSLU2 was not visible on the network. Couldn't access the web GUI, couldn't ping it. It wasn't playing ball at all.
      > Long story short, I am now able to access the NSLU2 web GUI again, I have attached a new disk, formatted it etc and everything works fine. So the problem does not appear to be with the NSLU2 unit.
      > BUT, the moment I try to attched the old HDD, evertything goes to pot. The boot process takes ages (compared to how it was before) but it does still access the disk during boot and all the lights come on solid when it finally comes online. However, at that point I either can't access the web GUI or if I manage to do that, I find that the unit is not recognising the HDD.
      > So, this is what I've tried so far. Fired up my laptop from Ubuntu CD, plug in the errant HDD and it initially is recognised and appears as a volume in the File Browser and I get a second File Browser window in which I can see all my folders (hurrah!). However, if I try to access a folder or the volume, I get various "Cannot mount volume" error dialogues, e.g. "Unable to mount the volume" and "Details: mount: wrong fs type, bad option, bad superblock on /dev/sbd2. missing codepage or other error" and "Error org.freedesktop.Hal.NoSuchDevice" and "Error org.freedesktop.DBus.Error.NoReply"
      > I'm sure a Linux savvy person will know instantly where the problem lies and how to approach this. I only need to retrieve some of the data files that are essentially in just one folder.
      > Any hints, help or encouragement gratefully received.
      > Thanks.
    Your message has been successfully submitted and would be delivered to recipients shortly.