Loading ...
Sorry, an error occurred while loading the content.

SSH has died but telnet's ok

Expand Messages
  • Paul Carmichael
    Just noticed that when I try to access the slug with Putty, I get connection refused. Was working fine until recently. Web access is ok and so is telnet.
    Message 1 of 5 , Jan 20, 2009
    • 0 Attachment
      Just noticed that when I try to access the slug with Putty, I get connection refused. Was working fine until recently. Web access is ok and so is telnet. Obviously not a major deal as I can still work with telnet, but suggests that something's not right. I'm wondering if it's down to an expired certificate or something? I know next to bugger all about ssh.

      Any ideas?
    • Mike (mwester)
      ... Your system probably is no longer booting up in unslung mode; it s booting to internal flash instead. Mike (mwester)
      Message 2 of 5 , Jan 21, 2009
      • 0 Attachment
        Paul Carmichael wrote:
        > Just noticed that when I try to access the slug with Putty, I get connection refused. Was working fine until recently. Web access is ok and so is telnet. Obviously not a major deal as I can still work with telnet, but suggests that something's not right. I'm wondering if it's down to an expired certificate or something? I know next to bugger all about ssh.
        >
        > Any ideas?

        Your system probably is no longer booting up in "unslung" mode; it's
        booting to internal flash instead.

        Mike (mwester)
      • wibbleypants
        ... Nope. Telnet in and I get this: Welcome to Unslung V2.3R63-uNSLUng-6.10-beta ... BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) Built-in shell (ash) Enter
        Message 3 of 5 , Jan 22, 2009
        • 0 Attachment
          --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@...>
          wrote:
          > Paul Carmichael wrote:
          >> Just noticed that when I try to access the slug with Putty, I get
          >>connection refused. Was working fine until recently. Web access is
          >>ok and so is telnet. Obviously not a major deal as I can still work
          >>with telnet, but suggests that something's not right. I'm wondering
          >>if it's down to an expired certificate or something? I know next to
          >>bugger all about ssh.
          >>
          >> Any ideas?
          >
          > Your system probably is no longer booting up in "unslung" mode; it's
          > booting to internal flash instead.

          Nope. Telnet in and I get this:
          "Welcome to Unslung V2.3R63-uNSLUng-6.10-beta

          ---------- NOTE: THIS SYSTEM IS CURRENTLY UNSLUNG ----------

          BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) Built-in shell (ash)
          Enter 'help' for a list of built-in commands."

          Just noticed that ftp boots me out as well. And telnet isn't much use
          as in that environment there's no path etc.
        • John
          ... First, set ssh (Putty) to verbose mode and post the results here. (For command line ssh, the option -v puts it in verbose mode. I don t use putty but
          Message 4 of 5 , Jan 27, 2009
          • 0 Attachment
            On Tue, Jan 20, 2009 at 01:22:18PM +0000, Paul Carmichael wrote:
            > Just noticed that when I try to access the slug with Putty, I get
            >connection refused. Was working fine until recently. Web access
            >is ok and so is telnet. Obviously not a major deal as I can still
            >work with telnet, but suggests that something's not right. I'm
            >wondering if it's down to an expired certificate or something? I
            >know next to bugger all about ssh.
            >
            > Any ideas?

            First, set ssh (Putty) to verbose mode and post the results
            here. (For command line ssh, the option '-v' puts it in verbose
            mode. I don't use putty but it must have something similar.)

            Second, on the slug, check the log files for messages from the
            sshd daemon and post those here also.

            ssh certificates don't expire but there are lots of possible
            problems with mis-set file permissions or maybe the sshd daemon
            fails to start or ....
          • wibbleypants
            ... ... Sorry, I replied via some forum or other and it never arrived here. Anyway, I just re-installed openssh and all is well. Thanks.
            Message 5 of 5 , Feb 3, 2009
            • 0 Attachment
              --- In nslu2-general@yahoogroups.com, John <jl.050877@...> wrote:
              >
              > On Tue, Jan 20, 2009 at 01:22:18PM +0000, Paul Carmichael wrote:
              > > Just noticed that when I try to access the slug with Putty, I get
              > >connection refused.
              <snip>
              > First, set ssh (Putty) to verbose mode and post the results
              > here.

              Sorry, I replied via some forum or other and it never arrived here.
              Anyway, I just re-installed openssh and all is well.

              Thanks.
            Your message has been successfully submitted and would be delivered to recipients shortly.