Loading ...
Sorry, an error occurred while loading the content.
 

write to DISC1

Expand Messages
  • Staber Hans Peter
    I am a newbie to the NSLU2. I have googled a bit and tried to find something regarding disc write access on the FAQ and in the vaults - to no avail. I am quite
    Message 1 of 4 , Oct 4, 2008
      I am a newbie to the NSLU2. I have googled a bit and tried to find
      something regarding disc write access on the FAQ and in the vaults -
      to no avail. I am quite embarassed about what I need to ask the group
      with my first question :

      I can read the data from my 300 GB disk attached to a NSLU2 but I
      cannot write to it. And this despite my efforts to have "rw" access
      setup for the shares. Yes - I have the slug in the same workgroup
      than the laptop (I edited samba.conf accordingly).
      Where do I need to pick up the rope to get to a solution to this
      (simple) problem ?

      My hardware : Dell Latitude D430 laptop, dualboot WinXP Pro and
      Debian 4.0r4 in a LAN

      --
      Hans Peter Staber
      Salzburg
    • Graham
      ... I am also new to Linux - but I found that setting the permissions of the folders on the disk to 777 let me write. Perhaps an expert can tell us the correct
      Message 2 of 4 , Oct 7, 2008
        --- In nslu2-general@yahoogroups.com, Staber Hans Peter <yahoo.hp@...>
        wrote:
        >
        > I am a newbie to the NSLU2. I have googled a bit and tried to find
        > something regarding disc write access on the FAQ and in the vaults -
        > to no avail. I am quite embarassed about what I need to ask the group
        > with my first question :
        >
        > I can read the data from my 300 GB disk attached to a NSLU2 but I
        > cannot write to it. And this despite my efforts to have "rw" access
        > setup for the shares. Yes - I have the slug in the same workgroup
        > than the laptop (I edited samba.conf accordingly).
        > Where do I need to pick up the rope to get to a solution to this
        > (simple) problem ?
        >
        > My hardware : Dell Latitude D430 laptop, dualboot WinXP Pro and
        > Debian 4.0r4 in a LAN
        >
        > --
        > Hans Peter Staber
        > Salzburg
        >
        I am also new to Linux - but I found that setting the permissions of
        the folders on the disk to 777 let me write. Perhaps an expert can
        tell us the correct answer...
      • Joel Gebhart
        ... I am also fairly new to Linux, but 777 would be considered a dangerous setting by most Linux users. It says anyone can do anything to a file in that
        Message 3 of 4 , Oct 7, 2008
          --- In nslu2-general@yahoogroups.com, "Graham" <fgmarshall@...> wrote:
          > I am also new to Linux - but I found that setting the permissions of
          > the folders on the disk to 777 let me write.

          I am also fairly new to Linux, but 777 would be considered a "dangerous"
          setting by most Linux users. It says anyone can do anything to a file
          in that directory, and takes away any user file control. The fact that
          this setting solves your problems seems to indicate a problem with the
          user being authenticated from Windows to the NSLU2.

          Regarding the previous question, I wonder if you inadvertently connected
          your windows computer to this share as an anonymous user, and not as the
          user you set with full permissions on the NSLU2. If you have anonymous
          browsing option set, you could see files, but not edit them.

          You might try disconnecting the windows computer from the share. When
          you reconnect the windows computer and are prompted for the user and
          password, ensure you enter the user on the NSLU2 with full rights to
          this share.
        • LaneD130
          I am no expert, but it s been over 6 weeks since the post was posted, so I thought I would reply. Using the commands chmod and chown, you can set all file
          Message 4 of 4 , Nov 19, 2008
            I am no expert, but it's been over 6 weeks since the post was posted,
            so I thought I would reply.

            Using the commands chmod and chown, you can set all file permissions.

            chown sets the owner and group for a file. e.g:
            chown user file
            or chown user:group file
            This is not used very much since it is not that common to want to
            change the owner or group.

            chmod sets the file's permissions for it's owner, group, and everyone
            else. e.g:
            chmod 123 file
            The 123 should be replaced by the required code. In the example 1 is
            for the owner, 2 for the group, and 3 for EE. The numer you assign to
            each is worked out as follows:
            4 for read access,
            2 for write,
            and 1 for execute.
            If you want to assign read and write, these two should be added
            together (6). If you want read and execute, then it would be 4+1 = 5.
            So from this we work out that if we want our file, temp.txt, to be
            read and written by us, read by the rest of the group, but not seen by
            the rest of the world, then we use:
            chmod 640 temp.txt
            However, if it is a script that everyone needs to run, but you don't
            want anyone else reading it, then the command would be:
            chmod 711 temp.txt
            If we want everyone to be able to do everything:
            chmod 777 temp.txt

            Both commands take the -R option (chmod -R 777 temp.txt and chown -R
            me:grp temp.txt) which means that they will process all
            sub-directories as well.

            temp.txt can be replaced by wildcards like * or ? or *.txt

            In order to change your directory/drive to give:
            you read and write access,
            the group "everyone" ownership,
            and EE read access,
            you should telnet or ssh into your slug, cd to the right directory
            (from the sounds of it this will be /share/hdd/data/ or something
            close) and then use:
            chown -R YourUserName:everyone *
            chmod -R 644 *

            If you want to limit the reading to just you, you need:
            chown -R YourUserName:administrators *
            chmod -R 600 *

            Note: Issuing 777 gives everyone full control, which is not
            necessarily recommended

            Let me know if this fails to make everything clear.

            Cheers,

            Dave
            --- In nslu2-general@yahoogroups.com, "Graham" <fgmarshall@...> wrote:
            >
            > --- In nslu2-general@yahoogroups.com, Staber Hans Peter <yahoo.hp@>
            > wrote:
            > >
            > > I am a newbie to the NSLU2. I have googled a bit and tried to find
            > > something regarding disc write access on the FAQ and in the vaults -
            > > to no avail. I am quite embarassed about what I need to ask the group
            > > with my first question :
            > >
            > > I can read the data from my 300 GB disk attached to a NSLU2 but I
            > > cannot write to it. And this despite my efforts to have "rw" access
            > > setup for the shares. Yes - I have the slug in the same workgroup
            > > than the laptop (I edited samba.conf accordingly).
            > > Where do I need to pick up the rope to get to a solution to this
            > > (simple) problem ?
            > >
            > > My hardware : Dell Latitude D430 laptop, dualboot WinXP Pro and
            > > Debian 4.0r4 in a LAN
            > >
            > > --
            > > Hans Peter Staber
            > > Salzburg
            > >
            > I am also new to Linux - but I found that setting the permissions of
            > the folders on the disk to 777 let me write. Perhaps an expert can
            > tell us the correct answer...
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.