Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] NSLU2 IP 0,0,0,0

Expand Messages
  • Michael Canavatchel
    Hi Mike, I was confusing Telnet in the NSLU with _Telnet into RedBoot!_ I m going to start from the beginning again and maybe my pea brain will get it
    Message 1 of 11 , Aug 5, 2008
      Hi Mike,

      I was confusing Telnet in the NSLU with _Telnet into RedBoot!_

      I'm going to start from the beginning again and maybe my pea brain will
      get it correct!!

      Thank you
      Mike C

      Mike (mwester) wrote:
      > Michael Canavatchel wrote:
      > ...
      > >
      > > Going back to the Unslung readme, I realized that I had not "unslung"
      > > the firmware onto my external hd. So I disconnected the hard drives,
      > > telneted into redboot,
      > You need to telnet into unslung, not the bootloader. The README details
      > the sequence -- disconnect the disks, boot the device, use the web
      > browser to enable telnet, then telnet into the device -- and you'll be
      > prompted for the id and password, and be able to unsling to the hard
      > drive.
      > > but when I did, I was not prompted for a user
      > > name or password. I found that strange, but when I tried to connect the
      > > EXT3 hard disk, I was immediately disconnected from my telnet
      > session. I
      > > telneted in several more times with the same result, connect the drive,
      > > get disconnected. On my last telnet session I began to poke around and
      > > everything I typed, except 'help' returned an error.
      > >
      > > I thought maybe I needed to follow the readme and start over (No, I
      > > didn't back up the original unslung flash.) so I re-flashed the slug
      > > with Sercomm and Unslung 6.10 beta. I put the slug in upgrade mode with
      > > the reset button and everything went perfectly, however when the slug
      > > rebooted, I could no longer access it. I ran NetStat -an and I could
      > see
      > > the slug at IP 0,0,0,0 listening with the port numbers following the ip
      > > address.
      > What commands *did* you run when you were telnetted into redboot? From
      > redboot you have the ability to do some interesting sorts of damage to
      > the data in the flash, so at this point, you probably can't trust any
      > saved settings.
      > I'm also unclear on where you ran netstat -- since you couldn't run
      > netstat on the slug, I'm assuming you ran it on your desktop system --
      > in which case netstat will show you information about your desktop
      > system and not the slug. But in any case, a listening address of
      > is common, it just means "the host's IP, whatever it is".
      > > I obviously can't telnet into the slug and the web interface no longer
      > > works no matter what IP I enter. I can still get into upgrade mode with
      > > the reset button but I have a feeling that re-flashing isn't going
      > to do
      > > anything unless I can specify a default IP address.
      > Yes -- and it's easy to do so -- just flash the Linksys firmware, and
      > follow the Linksys procedure to reset the device to factory defaults
      > using the reset button (I don't recall what that is exactly, but
      > basically you boot it up, wait until it beeps, then hold the reset
      > button in while it's up and running for some period of time -- I think
      > it beeps once or twice -- check the linksys docs, and then a restart
      > should have the device appear at the default address. From
      > there you can fix up your network settings.
      > > I've waded through the nslu2-linux.org site, wiki, FAQ and dozens of
      > > pages on google but I can't find a solution. I do have hope because I
      > > can still access the slug through upgrade mode.
      > >
      > > I know there is a genius or two in the group here, can someone help me?
      > >
      > > Thanks!
      > > Mike C
    Your message has been successfully submitted and would be delivered to recipients shortly.