Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Re: SLugOS/BE as NFS client

Expand Messages
  • Mike (mwester)
    ... SlugOS works very nicely as an NFS client, as well as an NFS server. ... Well, you haven t provided any information on the issue in this email. If you ve
    Message 1 of 11 , Jul 18, 2008
    • 0 Attachment
      beerman_wendel wrote:
      > After spending some more hours an that subject, I did not make any
      > progress ...
      >
      > Could it be that SlugOS/BE does not support NFS as a file system after
      > all and therefor cannot act as a NFS CLIENT?

      SlugOS works very nicely as an NFS client, as well as an NFS server.

      > Any hint is appreciated.

      Well, you haven't provided any information on the issue in this email.
      If you've done so earlier, and not gotten any response, then perhaps
      you've not asked a question that anyone can respond to -- rethinking and
      rephrasing the issue may be helpful. Or at least a URL to the archived
      email that you send earlier...

      > Rigas

      Mike (mwester)
    • beerman_wendel
      ... Hi Mike, just have a look at the top of the tread, please ... :-) Rigas
      Message 2 of 11 , Jul 19, 2008
      • 0 Attachment
        --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@...>
        wrote:
        >
        > beerman_wendel wrote:
        > > After spending some more hours an that subject, I did not make any
        > > progress ...
        > >
        > > Could it be that SlugOS/BE does not support NFS as a file system after
        > > all and therefor cannot act as a NFS CLIENT?
        >
        > SlugOS works very nicely as an NFS client, as well as an NFS server.
        >
        > > Any hint is appreciated.
        >
        > Well, you haven't provided any information on the issue in this email.
        > If you've done so earlier, and not gotten any response, then perhaps
        > you've not asked a question that anyone can respond to -- rethinking and
        > rephrasing the issue may be helpful. Or at least a URL to the archived
        > email that you send earlier...
        >
        > > Rigas
        >
        > Mike (mwester)
        >

        Hi Mike,

        just have a look at the top of the tread, please ... :-)

        Rigas
      • Mike (mwester)
        ... There is no thread at the top :) There are many different ways to get/read the email from the list, and not all viewers of the email will have all the
        Message 3 of 11 , Jul 19, 2008
        • 0 Attachment
          beerman_wendel wrote:

          > just have a look at the top of the tread, please ... :-)
          >
          > Rigas


          There is no thread at the top :) There are many different ways to
          get/read the email from the list, and not all viewers of the email will
          have all the messages in their inbox. In general, if a thread has been
          open for a while, it's worth summarizing the situation anew for those
          who have come into the thread in the middle, or for those who have lost
          the context of the thread -- this applies to any internet mail-list.

          I guess if I get bored today, I can go off to the Yahoo archives and
          search to see what your original problem might be...

          Mike (mwester)
        • beerman_wendel
          Well ... here comes the message again - I think it has all the necessary details ... Rigas Hello, I installed SLUGOS/BE on SLUG2 and want to attach an nfs
          Message 4 of 11 , Jul 19, 2008
          • 0 Attachment
            Well ... here comes the message again - I think it has all the
            necessary details ...

            Rigas


            Hello,

            I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
            SLUG1 (Openslug 3.10) to it.

            I exported the share in SLUG1 (added the following line to etc\exports:)

            /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)

            On SLUG2 im tried to mount that share with:

            mount SLUG1:/opt/mp3 /opt/music

            I received:

            mount: unknown filesystem type 'nfs'

            Does that mean, that SLUGOS/BE does not support NFS?
            Or do I just have to install some packages?
          • Mike (mwester)
            ... It means you need to install packages. http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS Mike (mwester)
            Message 5 of 11 , Jul 19, 2008
            • 0 Attachment
              beerman_wendel wrote:
              > Well ... here comes the message again - I think it has all the
              > necessary details ...
              >
              > Rigas
              >
              >
              > Hello,
              >
              > I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
              > SLUG1 (Openslug 3.10) to it.
              >
              > I exported the share in SLUG1 (added the following line to etc\exports:)
              >
              > /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)
              >
              > On SLUG2 im tried to mount that share with:
              >
              > mount SLUG1:/opt/mp3 /opt/music
              >
              > I received:
              >
              > mount: unknown filesystem type 'nfs'
              >
              > Does that mean, that SLUGOS/BE does not support NFS?
              > Or do I just have to install some packages?

              It means you need to install packages.
              http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS

              Mike (mwester)
            • beerman_wendel
              ... etc exports:) ... Thanks for the answer. I had worked through that howto and all the packages listed there have been installed on the NFS-Server (Slug1,
              Message 6 of 11 , Jul 20, 2008
              • 0 Attachment
                --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@...>
                wrote:
                >
                > beerman_wendel wrote:
                > > Well ... here comes the message again - I think it has all the
                > > necessary details ...
                > >
                > > Rigas
                > >
                > >
                > > Hello,
                > >
                > > I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
                > > SLUG1 (Openslug 3.10) to it.
                > >
                > > I exported the share in SLUG1 (added the following line to
                etc\exports:)
                > >
                > > /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)
                > >
                > > On SLUG2 im tried to mount that share with:
                > >
                > > mount SLUG1:/opt/mp3 /opt/music
                > >
                > > I received:
                > >
                > > mount: unknown filesystem type 'nfs'
                > >
                > > Does that mean, that SLUGOS/BE does not support NFS?
                > > Or do I just have to install some packages?
                >
                > It means you need to install packages.
                > http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS
                >
                > Mike (mwester)
                >

                Thanks for the answer.

                I had worked through that howto and all the packages listed there have
                been installed on the NFS-Server (Slug1, OpenSlug 3.1) and the
                NFS-client (Slug2, SlugOSBE).

                The server part works fine; the question is , whether the client slug
                with SlugOS/BE is at all able to mount a NFS share from an NFS server.

                On the client I get the message: "mount: unknown filesystem type 'nfs'"

                I installed the nfsd kernel module on the client. Do I have to
                activate it somehow?

                Rigas
              • Mike (mwester)
                ... You need to install the package named kernel-module-nfs to get the client side of things. Once you do that, it should know about the nfs filesystem. If
                Message 7 of 11 , Jul 20, 2008
                • 0 Attachment
                  beerman_wendel wrote:
                  > --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@...>
                  > wrote:
                  >> beerman_wendel wrote:
                  >>> Well ... here comes the message again - I think it has all the
                  >>> necessary details ...
                  >>>
                  >>> Rigas
                  >>>
                  >>>
                  >>> Hello,
                  >>>
                  >>> I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
                  >>> SLUG1 (Openslug 3.10) to it.
                  >>>
                  >>> I exported the share in SLUG1 (added the following line to
                  > etc\exports:)
                  >>> /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)
                  >>>
                  >>> On SLUG2 im tried to mount that share with:
                  >>>
                  >>> mount SLUG1:/opt/mp3 /opt/music
                  >>>
                  >>> I received:
                  >>>
                  >>> mount: unknown filesystem type 'nfs'
                  >>>
                  >>> Does that mean, that SLUGOS/BE does not support NFS?
                  >>> Or do I just have to install some packages?
                  >> It means you need to install packages.
                  >> http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS
                  >>
                  >> Mike (mwester)
                  >>
                  >
                  > Thanks for the answer.
                  >
                  > I had worked through that howto and all the packages listed there have
                  > been installed on the NFS-Server (Slug1, OpenSlug 3.1) and the
                  > NFS-client (Slug2, SlugOSBE).
                  >
                  > The server part works fine; the question is , whether the client slug
                  > with SlugOS/BE is at all able to mount a NFS share from an NFS server.
                  >
                  > On the client I get the message: "mount: unknown filesystem type 'nfs'"
                  >
                  > I installed the nfsd kernel module on the client. Do I have to
                  > activate it somehow?

                  You need to install the package named "kernel-module-nfs" to get the
                  client side of things. Once you do that, it should know about the nfs
                  filesystem. If that doesn't do it, there have been reports that a
                  "depmod -a" command is required and/or a reboot to get the system to
                  recognize the new kernel module.

                  As I poke about, though, I notice that the rpcbind executable has gone
                  AWOL -- so if your mount command appears to hang, <ctrl>-c out of it,
                  and try it again with the "-o nolock" option, e.g.:

                  mount -o nolock myserver:/bigfilesystem /mnt

                  > Rigas

                  Mike (mwester)
                • beerman_wendel
                  ... nfs ... Hi Mike, THANK YOU VERY MUCH!! I installed kernel-module-nfs , did depmode -a ... and voila, it works. Many happy thanx from Munich, Rigas
                  Message 8 of 11 , Jul 20, 2008
                  • 0 Attachment
                    --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@...>
                    wrote:
                    >
                    > beerman_wendel wrote:
                    > > --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@>
                    > > wrote:
                    > >> beerman_wendel wrote:
                    > >>> Well ... here comes the message again - I think it has all the
                    > >>> necessary details ...
                    > >>>
                    > >>> Rigas
                    > >>>
                    > >>>
                    > >>> Hello,
                    > >>>
                    > >>> I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
                    > >>> SLUG1 (Openslug 3.10) to it.
                    > >>>
                    > >>> I exported the share in SLUG1 (added the following line to
                    > > etc\exports:)
                    > >>> /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)
                    > >>>
                    > >>> On SLUG2 im tried to mount that share with:
                    > >>>
                    > >>> mount SLUG1:/opt/mp3 /opt/music
                    > >>>
                    > >>> I received:
                    > >>>
                    > >>> mount: unknown filesystem type 'nfs'
                    > >>>
                    > >>> Does that mean, that SLUGOS/BE does not support NFS?
                    > >>> Or do I just have to install some packages?
                    > >> It means you need to install packages.
                    > >> http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS
                    > >>
                    > >> Mike (mwester)
                    > >>
                    > >
                    > > Thanks for the answer.
                    > >
                    > > I had worked through that howto and all the packages listed there have
                    > > been installed on the NFS-Server (Slug1, OpenSlug 3.1) and the
                    > > NFS-client (Slug2, SlugOSBE).
                    > >
                    > > The server part works fine; the question is , whether the client slug
                    > > with SlugOS/BE is at all able to mount a NFS share from an NFS server.
                    > >
                    > > On the client I get the message: "mount: unknown filesystem type
                    'nfs'"
                    > >
                    > > I installed the nfsd kernel module on the client. Do I have to
                    > > activate it somehow?
                    >
                    > You need to install the package named "kernel-module-nfs" to get the
                    > client side of things. Once you do that, it should know about the nfs
                    > filesystem. If that doesn't do it, there have been reports that a
                    > "depmod -a" command is required and/or a reboot to get the system to
                    > recognize the new kernel module.
                    >
                    > As I poke about, though, I notice that the rpcbind executable has gone
                    > AWOL -- so if your mount command appears to hang, <ctrl>-c out of it,
                    > and try it again with the "-o nolock" option, e.g.:
                    >
                    > mount -o nolock myserver:/bigfilesystem /mnt
                    >
                    > > Rigas
                    >
                    > Mike (mwester)
                    >

                    Hi Mike,

                    THANK YOU VERY MUCH!!

                    I installed "kernel-module-nfs", did depmode -a ...
                    and voila, it works.

                    Many happy thanx from Munich,

                    Rigas
                  • beerman_wendel
                    ... After many month of perfect and stable nfs operation, both slugs crushed during a power outage the other day. Both run ok now, but when I try to establish
                    Message 9 of 11 , May 13, 2009
                    • 0 Attachment
                      --- In nslu2-general@yahoogroups.com, "beerman_wendel" <beerman_wendel@...> wrote:
                      >
                      > --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@>
                      > wrote:
                      > >
                      > > beerman_wendel wrote:
                      > > > --- In nslu2-general@yahoogroups.com, "Mike (mwester)" <mwester@>
                      > > > wrote:
                      > > >> beerman_wendel wrote:
                      > > >>> Well ... here comes the message again - I think it has all the
                      > > >>> necessary details ...
                      > > >>>
                      > > >>> Rigas
                      > > >>>
                      > > >>>
                      > > >>> Hello,
                      > > >>>
                      > > >>> I installed SLUGOS/BE on SLUG2 and want to attach an nfs share from
                      > > >>> SLUG1 (Openslug 3.10) to it.
                      > > >>>
                      > > >>> I exported the share in SLUG1 (added the following line to
                      > > > etc\exports:)
                      > > >>> /opt/mp3 192.168.xxx.xxx(ro,no_root_squash,sync)
                      > > >>>
                      > > >>> On SLUG2 im tried to mount that share with:
                      > > >>>
                      > > >>> mount SLUG1:/opt/mp3 /opt/music
                      > > >>>
                      > > >>> I received:
                      > > >>>
                      > > >>> mount: unknown filesystem type 'nfs'
                      > > >>>
                      > > >>> Does that mean, that SLUGOS/BE does not support NFS?
                      > > >>> Or do I just have to install some packages?
                      > > >> It means you need to install packages.
                      > > >> http://www.nslu2-linux.org/wiki/OpenSlug/InstallNFS
                      > > >>
                      > > >> Mike (mwester)
                      > > >>
                      > > >
                      > > > Thanks for the answer.
                      > > >
                      > > > I had worked through that howto and all the packages listed there have
                      > > > been installed on the NFS-Server (Slug1, OpenSlug 3.1) and the
                      > > > NFS-client (Slug2, SlugOSBE).
                      > > >
                      > > > The server part works fine; the question is , whether the client slug
                      > > > with SlugOS/BE is at all able to mount a NFS share from an NFS server.
                      > > >
                      > > > On the client I get the message: "mount: unknown filesystem type
                      > 'nfs'"
                      > > >
                      > > > I installed the nfsd kernel module on the client. Do I have to
                      > > > activate it somehow?
                      > >
                      > > You need to install the package named "kernel-module-nfs" to get the
                      > > client side of things. Once you do that, it should know about the nfs
                      > > filesystem. If that doesn't do it, there have been reports that a
                      > > "depmod -a" command is required and/or a reboot to get the system to
                      > > recognize the new kernel module.
                      > >
                      > > As I poke about, though, I notice that the rpcbind executable has gone
                      > > AWOL -- so if your mount command appears to hang, <ctrl>-c out of it,
                      > > and try it again with the "-o nolock" option, e.g.:
                      > >
                      > > mount -o nolock myserver:/bigfilesystem /mnt
                      > >
                      > > > Rigas
                      > >
                      > > Mike (mwester)
                      > >
                      >
                      > Hi Mike,
                      >
                      > THANK YOU VERY MUCH!!
                      >
                      > I installed "kernel-module-nfs", did depmode -a ...
                      > and voila, it works.
                      >
                      > Many happy thanx from Munich,
                      >
                      > Rigas
                      >

                      After many month of perfect and stable nfs operation, both slugs crushed during a power outage the other day.

                      Both run ok now, but when I try to establish the nfs connection from the client side, I get this in return:

                      "mount: RPC: Program not registered"

                      (The same message also comes when the slug starts ... as I can tell from dmesg.)

                      /sbin/portmap is running


                      Any ideas?

                      Rigas
                    Your message has been successfully submitted and would be delivered to recipients shortly.