Loading ...
Sorry, an error occurred while loading the content.

Samba

Expand Messages
  • mackowiakp
    Upss... After ipkg update and ipkg upgrade, samba was updated to version 3.2.0-1. And from this moment I have no access to NSLU2 over SMBD/NMBD protocols.
    Message 1 of 10 , Jul 5, 2008
    • 0 Attachment
      Upss... After ipkg update and ipkg upgrade, samba was updated to
      version 3.2.0-1. And from this moment I have no access to NSLU2 over
      SMBD/NMBD protocols. Samba daemons are no active. So I try to run nmbd
      and smbd by hand but daemons disappear after while. So how can I
      downgrade samba to former version (i dont remeber which one was it) or
      how can I make the new version of samba ready to work?
    • Brian Zhou
      I had to add interfaces = 192.168.1.77/24 line in the global section of /opt/etc/samba/smb.conf to get it working again (change to IP address of your slug of
      Message 2 of 10 , Jul 5, 2008
      • 0 Attachment
        I had to add

        interfaces = 192.168.1.77/24

        line in the global section of /opt/etc/samba/smb.conf to get it
        working again (change to IP address of your slug of course). I think I
        ran nmbd in foreground with debug and saw the error message.
        Fortunately this is an easy configuration change. Hope this helps you.

        -Brian

        --- In nslu2-general@yahoogroups.com, "mackowiakp" <mackowiakp@...> wrote:
        >
        > Upss... After ipkg update and ipkg upgrade, samba was updated to
        > version 3.2.0-1. And from this moment I have no access to NSLU2 over
        > SMBD/NMBD protocols. Samba daemons are no active. So I try to run nmbd
        > and smbd by hand but daemons disappear after while. So how can I
        > downgrade samba to former version (i dont remeber which one was it) or
        > how can I make the new version of samba ready to work?
        >
      • Robert Hammond
        I also had this problem after upgrading from 3.0.x to 3.2.0 with my Unslung NSLU2. And this fix worked for me, unsure why this is needed because the earlier
        Message 3 of 10 , Jul 6, 2008
        • 0 Attachment
          I also had this problem after upgrading from 3.0.x to 3.2.0 with my
          Unslung NSLU2. And this fix worked for me, unsure why this is needed
          because the earlier version would work quite happily without specifying
          any interfaces. Note that I run my system on a different sub net
          192.168.2.0. My interfaces line is :-

          interfaces = 192.168.2.77/24, ixp0, lo

          Will add this to the relevant Wiki page later tonight.

          >I had to add
          >
          >interfaces = 192.168.1.77/24
          >
          >line in the global section of /opt/etc/samba/smb.conf to get it
          >working again (change to IP address of your slug of course). I think I
          >ran nmbd in foreground with debug and saw the error message.
          >Fortunately this is an easy configuration change. Hope this helps you.
          >
          >-Brian
          >
          >--- In nslu2-general@yahoogroups.com, "mackowiakp" <mackowiakp@...> wrote:
          >>
          >> Upss... After ipkg update and ipkg upgrade, samba was updated to
          >> version 3.2.0-1. And from this moment I have no access to NSLU2 over
          >> SMBD/NMBD protocols. Samba daemons are no active. So I try to run nmbd
          >> and smbd by hand but daemons disappear after while. So how can I
          >> downgrade samba to former version (i dont remeber which one was it) or
          >> how can I make the new version of samba ready to work?
          >>
          >
          >
          >
          >------------------------------------
          >
          >Yahoo! Groups Links
          >
          >
          >

          --
          Robert Hammond
          PGP:0x154144DA
        • Piotr Mackowiak
          MANY THANKS BRIAN ! It works ! ... -- ... Z powazaniem/Yours sincerely Piotr Mackowiak
          Message 4 of 10 , Jul 7, 2008
          • 0 Attachment
            MANY THANKS BRIAN ! It works !


            Sunday 06 of July 2008 08:25:44 Brian Zhou napisał(a):
            > I had to add
            >
            > interfaces = 192.168.1.77/24
            >
            > line in the global section of /opt/etc/samba/smb.conf to get it
            > working again (change to IP address of your slug of course). I think I
            > ran nmbd in foreground with debug and saw the error message.
            > Fortunately this is an easy configuration change. Hope this helps you.
            >
            > -Brian
            >
            > --- In nslu2-general@yahoogroups.com, "mackowiakp" <mackowiakp@...> wrote:
            > > Upss... After ipkg update and ipkg upgrade, samba was updated to
            > > version 3.2.0-1. And from this moment I have no access to NSLU2 over
            > > SMBD/NMBD protocols. Samba daemons are no active. So I try to run nmbd
            > > and smbd by hand but daemons disappear after while. So how can I
            > > downgrade samba to former version (i dont remeber which one was it) or
            > > how can I make the new version of samba ready to work?



            --


            -------------

            Z powazaniem/Yours sincerely

            Piotr Mackowiak
          • Dominion Knight
            ... Hello, I ve been trying to get samba3 up on my Unslung 6.8 slug for a while and can t get it working. I implemented the change to the interfaces line, but
            Message 5 of 10 , Jul 8, 2008
            • 0 Attachment
              --- In nslu2-general@yahoogroups.com, Robert Hammond <rob.hammond@...>
              wrote:
              >
              > I also had this problem after upgrading from 3.0.x to 3.2.0 with my
              > Unslung NSLU2. And this fix worked for me, unsure why this is needed
              > because the earlier version would work quite happily without specifying
              > any interfaces. Note that I run my system on a different sub net
              > 192.168.2.0. My interfaces line is :-
              >
              > interfaces = 192.168.2.77/24, ixp0, lo
              >
              > Will add this to the relevant Wiki page later tonight.

              Hello,

              I've been trying to get samba3 up on my Unslung 6.8 slug for a while
              and can't get it working. I implemented the change to the interfaces
              line, but this doesn't seem to help.

              I have even tried a very basic config file (per the samba site) with
              the following basic setup:

              [global]
              workgroup = MSHOME
              netbios name = nslu2
              interfaces = 192.168.1.77/24, ixp0, lo
              [share1]
              path = /share/hdd/data

              and still I can't access the share, even using smbclient on the slug:

              # smbclient -L localhost
              protocol negotiation failed
              #

              If I use the second "working" configuration on the wiki page
              (http://www.nslu2-linux.org/wiki/Optware/Samba), with the single
              modification of adding the interfaces = 192.168.1.77/24, ixp0, lo line
              to the configuration, I get the following from smbclient:

              # smbclient -L localhost
              Connection to localhost failed (Error NT_STATUS_BAD_NETWORK_NAME)
              #

              In my samba log file (/opt/var/samba/log.smbd) there are a few errors
              about primtcap and several "transport endpoint is not coneected"
              errors, in addition to a couple of others:

              # cat log.smbd
              [1969/12/31 19:24:46, 0] source/printing/pcap.c:pcap_cache_reload(158)
              Unable to open printcap file /opt/etc/printcap for read!
              [1969/12/31 19:24:46, 0] source/printing/pcap.c:pcap_cache_reload(158)
              Unable to open printcap file /opt/etc/printcap for read!
              [1969/12/31 19:24:47, 0] source/lib/interface.c:load_interfaces(540)
              WARNING: no network interfaces found
              [1969/12/31 19:24:49, 0] source/smbd/server.c:open_sockets_smbd(547)
              open_sockets_smbd: No sockets available to bind to.
              [1969/12/31 19:26:25, 0] source/smbd/server.c:main(1208)
              smbd version 3.2.0 started.
              Copyright Andrew Tridgell and the Samba Team 1992-2008
              [1969/12/31 19:26:25, 0] source/printing/pcap.c:pcap_cache_reload(158)
              Unable to open printcap file /opt/etc/printcap for read!
              [1969/12/31 19:26:25, 0] source/printing/pcap.c:pcap_cache_reload(158)
              Unable to open printcap file /opt/etc/printcap for read!
              [1969/12/31 19:27:09, 0]
              source/lib/util_sock.c:get_peer_addr_internal(1596)
              getpeername failed. Error was Transport endpoint is not connected
              [1969/12/31 19:27:09, 0]
              source/lib/util_sock.c:get_peer_addr_internal(1596)
              getpeername failed. Error was Transport endpoint is not connected
              #

              Here is a copy of the modified smb.conf if needed (despite the
              comments my nslu2's IP is 192.168.1.77):

              # Samba config file created using SWAT
              # from 192.168.2.50 (192.168.2.50)
              # Date: 2007/09/25 20:35:19

              [global]
              workgroup = MSHOME
              server string = Samba %v Network Drive
              netbios name = blackrock
              interfaces = 192.168.1.77/24, ixp0, lo
              bind interfaces only = Yes
              map to guest = Bad User
              null passwords = Yes
              guest account = guest
              log file = /opt/var/samba/log.%m
              max log size = 10
              name resolve order = wins bcast
              socket options = SO_SNDBUF=8192 SO_RCVBUF=8192
              load printers = No
              printcap name = /opt/etc/printcap
              dns proxy = No
              ldap ssl = no
              config file = /opt/etc/samba/smb.conf
              lock directory = /var/samba3
              pid directory = /var/samba3
              create mask = 0771
              force create mode = 0660
              force directory mode = 0771
              hosts allow = 192.168., 172., 10., localhost

              [ADMIN 1]
              comment = Full Data Partition
              path = /
              valid users = @administrators
              write list = @administrators

              [DISK 1]
              comment = Public Folder Tree For Everyone
              path = /public/
              valid users = @administrators, @everyone
              write list = @administrators, @everyone
              read only = No
              guest ok = Yes

              There was no problem under samba 2. Any assistance would be greatly
              appreciated.
            • Robert Hammond
              In message , Dominion Knight writes ... The printcap error is because Samba is trying to open a non existent
              Message 6 of 10 , Jul 10, 2008
              • 0 Attachment
                In message <g50tks+fv4a@...>, Dominion Knight <joe@...>
                writes
                >--- In nslu2-general@yahoogroups.com, Robert Hammond <rob.hammond@...>
                >wrote:
                >>
                >> I also had this problem after upgrading from 3.0.x to 3.2.0 with my
                >> Unslung NSLU2. And this fix worked for me, unsure why this is needed
                >> because the earlier version would work quite happily without specifying
                >> any interfaces. Note that I run my system on a different sub net
                >> 192.168.2.0. My interfaces line is :-
                >>
                >> interfaces = 192.168.2.77/24, ixp0, lo
                >>
                >> Will add this to the relevant Wiki page later tonight.
                >
                >Hello,
                >
                >I've been trying to get samba3 up on my Unslung 6.8 slug for a while
                >and can't get it working. I implemented the change to the interfaces
                >line, but this doesn't seem to help.
                >
                >I have even tried a very basic config file (per the samba site) with
                >the following basic setup:
                >
                >[global]
                >workgroup = MSHOME
                >netbios name = nslu2
                >interfaces = 192.168.1.77/24, ixp0, lo
                >[share1]
                >path = /share/hdd/data
                >
                >and still I can't access the share, even using smbclient on the slug:
                >
                ># smbclient -L localhost
                >protocol negotiation failed
                >#
                >
                >If I use the second "working" configuration on the wiki page
                >(http://www.nslu2-linux.org/wiki/Optware/Samba), with the single
                >modification of adding the interfaces = 192.168.1.77/24, ixp0, lo line
                >to the configuration, I get the following from smbclient:
                >
                ># smbclient -L localhost
                >Connection to localhost failed (Error NT_STATUS_BAD_NETWORK_NAME)
                >#
                >
                >In my samba log file (/opt/var/samba/log.smbd) there are a few errors
                >about primtcap and several "transport endpoint is not coneected"
                >errors, in addition to a couple of others:
                >
                ># cat log.smbd
                >[1969/12/31 19:24:46, 0] source/printing/pcap.c:pcap_cache_reload(158)
                > Unable to open printcap file /opt/etc/printcap for read!
                <Snip>
                The printcap error is because Samba is trying to open a non existent
                file. Easily fixed by creating a blank file by logging in as root at a
                console prompt :-

                touch /opt/etc/printcap

                chmod 0644 /opt/etc/printcap

                --
                Robert Hammond
                PGP:0x154144DA
              • dwang5
                I m having a similar problem trying to install samba 3.2. It seems that the interfaces on the nslu2 aren t being recognized by samba 3.2. I haven t been able
                Message 7 of 10 , Jul 27, 2008
                • 0 Attachment
                  I'm having a similar problem trying to install samba 3.2.

                  It seems that the interfaces on the nslu2 aren't being recognized by
                  samba 3.2.

                  I haven't been able to figure out the solution, so for now I've
                  reverted back to samba 2.




                  --- In nslu2-general@yahoogroups.com, "Dominion Knight" <joe@...> wrote:
                  >
                  > --- In nslu2-general@yahoogroups.com, Robert Hammond <rob.hammond@>
                  > wrote:
                  > >
                  > > I also had this problem after upgrading from 3.0.x to 3.2.0 with my
                  > > Unslung NSLU2. And this fix worked for me, unsure why this is
                  needed
                  > > because the earlier version would work quite happily without
                  specifying
                  > > any interfaces. Note that I run my system on a different sub net
                  > > 192.168.2.0. My interfaces line is :-
                  > >
                  > > interfaces = 192.168.2.77/24, ixp0, lo
                  > >
                  > > Will add this to the relevant Wiki page later tonight.
                  >
                  > Hello,
                  >
                  > I've been trying to get samba3 up on my Unslung 6.8 slug for a while
                  > and can't get it working. I implemented the change to the interfaces
                  > line, but this doesn't seem to help.
                  >
                  > I have even tried a very basic config file (per the samba site) with
                  > the following basic setup:
                  >
                  > [global]
                  > workgroup = MSHOME
                  > netbios name = nslu2
                  > interfaces = 192.168.1.77/24, ixp0, lo
                  > [share1]
                  > path = /share/hdd/data
                  >
                  > and still I can't access the share, even using smbclient on the slug:
                  >
                  > # smbclient -L localhost
                  > protocol negotiation failed
                  > #
                  >
                  > If I use the second "working" configuration on the wiki page
                  > (http://www.nslu2-linux.org/wiki/Optware/Samba), with the single
                  > modification of adding the interfaces = 192.168.1.77/24, ixp0, lo line
                  > to the configuration, I get the following from smbclient:
                  >
                  > # smbclient -L localhost
                  > Connection to localhost failed (Error NT_STATUS_BAD_NETWORK_NAME)
                  > #
                  >
                  > In my samba log file (/opt/var/samba/log.smbd) there are a few errors
                  > about primtcap and several "transport endpoint is not coneected"
                  > errors, in addition to a couple of others:
                  >
                  > # cat log.smbd
                  > [1969/12/31 19:24:46, 0] source/printing/pcap.c:pcap_cache_reload(158)
                  > Unable to open printcap file /opt/etc/printcap for read!
                  > [1969/12/31 19:24:46, 0] source/printing/pcap.c:pcap_cache_reload(158)
                  > Unable to open printcap file /opt/etc/printcap for read!
                  > [1969/12/31 19:24:47, 0] source/lib/interface.c:load_interfaces(540)
                  > WARNING: no network interfaces found
                  > [1969/12/31 19:24:49, 0] source/smbd/server.c:open_sockets_smbd(547)
                  > open_sockets_smbd: No sockets available to bind to.
                  > [1969/12/31 19:26:25, 0] source/smbd/server.c:main(1208)
                  > smbd version 3.2.0 started.
                  > Copyright Andrew Tridgell and the Samba Team 1992-2008
                  > [1969/12/31 19:26:25, 0] source/printing/pcap.c:pcap_cache_reload(158)
                  > Unable to open printcap file /opt/etc/printcap for read!
                  > [1969/12/31 19:26:25, 0] source/printing/pcap.c:pcap_cache_reload(158)
                  > Unable to open printcap file /opt/etc/printcap for read!
                  > [1969/12/31 19:27:09, 0]
                  > source/lib/util_sock.c:get_peer_addr_internal(1596)
                  > getpeername failed. Error was Transport endpoint is not connected
                  > [1969/12/31 19:27:09, 0]
                  > source/lib/util_sock.c:get_peer_addr_internal(1596)
                  > getpeername failed. Error was Transport endpoint is not connected
                  > #
                  >
                  > Here is a copy of the modified smb.conf if needed (despite the
                  > comments my nslu2's IP is 192.168.1.77):
                  >
                  > # Samba config file created using SWAT
                  > # from 192.168.2.50 (192.168.2.50)
                  > # Date: 2007/09/25 20:35:19
                  >
                  > [global]
                  > workgroup = MSHOME
                  > server string = Samba %v Network Drive
                  > netbios name = blackrock
                  > interfaces = 192.168.1.77/24, ixp0, lo
                  > bind interfaces only = Yes
                  > map to guest = Bad User
                  > null passwords = Yes
                  > guest account = guest
                  > log file = /opt/var/samba/log.%m
                  > max log size = 10
                  > name resolve order = wins bcast
                  > socket options = SO_SNDBUF=8192 SO_RCVBUF=8192
                  > load printers = No
                  > printcap name = /opt/etc/printcap
                  > dns proxy = No
                  > ldap ssl = no
                  > config file = /opt/etc/samba/smb.conf
                  > lock directory = /var/samba3
                  > pid directory = /var/samba3
                  > create mask = 0771
                  > force create mode = 0660
                  > force directory mode = 0771
                  > hosts allow = 192.168., 172., 10., localhost
                  >
                  > [ADMIN 1]
                  > comment = Full Data Partition
                  > path = /
                  > valid users = @administrators
                  > write list = @administrators
                  >
                  > [DISK 1]
                  > comment = Public Folder Tree For Everyone
                  > path = /public/
                  > valid users = @administrators, @everyone
                  > write list = @administrators, @everyone
                  > read only = No
                  > guest ok = Yes
                  >
                  > There was no problem under samba 2. Any assistance would be greatly
                  > appreciated.
                  >
                • diego_tech01
                  I was able to get Samba working with help from this site. http://www.pogoplugged.com/forum/thread/15812/Optware-problems-on-Pogoplug-Pro/ I am unsure if Samba
                  Message 8 of 10 , Jul 3, 2011
                  • 0 Attachment
                    I was able to get Samba working with help from this site. http://www.pogoplugged.com/forum/thread/15812/Optware-problems-on-Pogoplug-Pro/

                    I am unsure if Samba is actually running. SWAT says nmbd is running, but smbd is not running. Even when I start it. Smbstatus displays the following.

                    [root@Pogoplug init.d]# smbstatus

                    Samba version 2.2.12
                    Service uid gid pid machine
                    ----------------------------------------------

                    No locked files

                    I have added my own user "nobody" and changed the password. I have tried connecting to the server from OSX finder. It asks me for the user/password and the user I created, but it fails.

                    So I'm not sure at this point if it's running or not. Or why it won't connect.
                  • bruce turrie
                    I don t use SWAT myself, but if smbd isn t running then Samba isn t working. You might try running: testparm Running testparm is usually a good idea after
                    Message 9 of 10 , Jul 3, 2011
                    • 0 Attachment
                      I don't use SWAT myself, but if smbd isn't running then Samba isn't working. You might try running:

                      testparm

                      Running testparm is usually a good idea after making changes to samba configuration. In this case it will tell you if you have
                      any samba configuration errors that are keeping smbd from running. If so presumably they can be fixed using SWAT or by directly editing: 

                      /opt/etc/samba/smb.conf

                      There are multiple examples of working smb.conf files for pogoplugs on the internet you can compare your file with. There's one here:

                      https://turriebuntu.wordpress.com/pogoplugdockstar-pages/add-samba-to-your-pogoplug/


                      Other than that I guess I'd need more information before I could help much. 

                      ________________________________
                      From: diego_tech01 <diegoa@...>
                      To: nslu2-general@yahoogroups.com
                      Sent: Sunday, July 3, 2011 1:16 PM
                      Subject: [nslu2-general] Samba


                       
                      I was able to get Samba working with help from this site. http://www.pogoplugged.com/forum/thread/15812/Optware-problems-on-Pogoplug-Pro/

                      I am unsure if Samba is actually running. SWAT says nmbd is running, but smbd is not running. Even when I start it. Smbstatus displays the following.

                      [root@Pogoplug init.d]# smbstatus

                      Samba version 2.2.12
                      Service uid gid pid machine
                      ----------------------------------------------

                      No locked files

                      I have added my own user "nobody" and changed the password. I have tried connecting to the server from OSX finder. It asks me for the user/password and the user I created, but it fails.

                      So I'm not sure at this point if it's running or not. Or why it won't connect.




                      [Non-text portions of this message have been removed]
                    • oddballhero
                      To check to see if smbd and nmbd is running, Try ps |grep mbd or ps -ef|grep mbd if you added the extra utils packages. Also there have been problems with
                      Message 10 of 10 , Jul 4, 2011
                      • 0 Attachment
                        To check to see if smbd and nmbd is running, Try "ps |grep mbd" or "ps -ef|grep mbd" if you added the extra utils packages. Also there have been problems with samba2, you might want to change to samba3. See http://www.nslu2-linux.org/wiki/Optware/Plugadditions bottom of the page. If you are still having problems, might need a copy of your smb.conf to check, the ps status, the "mount" status, and "df -h".

                        --- In nslu2-general@yahoogroups.com, "diego_tech01" <diegoa@...> wrote:
                        >
                        > I was able to get Samba working with help from this site. http://www.pogoplugged.com/forum/thread/15812/Optware-problems-on-Pogoplug-Pro/
                        >
                        > I am unsure if Samba is actually running. SWAT says nmbd is running, but smbd is not running. Even when I start it. Smbstatus displays the following.
                        >
                        > [root@Pogoplug init.d]# smbstatus
                        >
                        > Samba version 2.2.12
                        > Service uid gid pid machine
                        > ----------------------------------------------
                        >
                        > No locked files
                        >
                        > I have added my own user "nobody" and changed the password. I have tried connecting to the server from OSX finder. It asks me for the user/password and the user I created, but it fails.
                        >
                        > So I'm not sure at this point if it's running or not. Or why it won't connect.
                        >
                      Your message has been successfully submitted and would be delivered to recipients shortly.