Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nslu2-general] Re: Sharing files with older systems like Xbox

Expand Messages
  • Alain SAURAT
    ... I agree with you, but the file /etc/samba/smb.conf is created on boot by the NSLU2 firmware in fonction of group, users and shares. So the security
    Message 1 of 8 , May 13, 2008
      docbillnet a écrit :
      > --- In nslu2-general@yahoogroups.com, "maisondouf" <maisondouf@...> wrote:
      >
      >> This modification of 'security' would be make after each boot of the
      >> NSLU2, because the default setting is 'user'.
      >>
      >> You can include in the 'rc.1' file in '/etc/rc.d' this little line :
      >>
      >> sed -i 's/security \= \user/security \= \share/'
      >> /share/hdd/conf/share/smb.conf
      >>
      >
      > Why on Earth do you need to do that? At least on all of my Linux
      > systems when I edit a file it stays changed. BTW. I believe the
      > correct file to edit is:
      >
      > /etc/samba/smb.conf
      >
      > There is also a web interface you can install and use for changing
      > your smb settings. (I prefer the web interface, as it also contains
      > helpful hints, like telling you certain settings only work in shared
      > mode.)
      >
      > http://www.samba.org/samba/GUI/
      >
      > I believe the gui interface is installed by default under Debian, but
      > the default configuration only allows connections from localhost.
      >
      > Unfortunately, the behavior of 'user' is the correct one. When you
      > switch to 'share' you are creating a security hole in your network.
      > If you have Windows 98 boxes running, you probably already invested in
      > a good firewall already to keep everything safe, so this should not
      > be a problem.
      >
      > Bill
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      I agree with you, but the file /etc/samba/smb.conf is created on boot by
      the NSLU2 firmware in fonction of group, users and shares.
      So the security parameter is always set to 'user'.

      In fact with the Xbox software I use (Xbox Media Player), I can't
      include in the description of the smb share any information on user and
      password.

      So I can't anymore acceed on nslu2 disk with 'user' mode.

      On the contrary when I boot my Xbox with Xebian ( xbox linux based on
      debian), I can mount all shares with user and pasword and there
      effectively the network is more safe.

      Alain.
    • docbillnet
      ... boot by ... I ve never had my /etc/samba/smb.conf overwritten, but with so many different firmware s to choice from, I guess the one you picked does. In
      Message 2 of 8 , May 14, 2008
        --- In nslu2-general@yahoogroups.com, Alain SAURAT <maisondouf@...> wrote:
        >
        > docbillnet a �crit :
        > I agree with you, but the file /etc/samba/smb.conf is created on
        boot by
        > the NSLU2 firmware in fonction of group, users and shares.
        > So the security parameter is always set to 'user'.
        >
        > In fact with the Xbox software I use (Xbox Media Player), I can't
        > include in the description of the smb share any information on user and
        > password.

        I've never had my /etc/samba/smb.conf overwritten, but with so many
        different firmware's to choice from, I guess the one you picked does.
        In that case, it does make sense to fix it on boot like you suggested.
        Although, I would be tempted to try chattr +i on the file to make it
        immutable... But then that is assuming you are using ext2 or ext3.


        Bill
      • mattias__a
        Hi. I might be totally wrong here but wasn t the Xbox Media Player project killed a few years ago and continued under the Xbox Media Center project? If the
        Message 3 of 8 , May 21, 2008
          Hi. I might be totally wrong here but wasn't the Xbox Media Player
          project killed a few years ago and continued under the Xbox Media
          Center project? If the software you are using on your xbox is in fact
          XBMC (xbox media center) the syntax for authenticating smb-shares is

          <bookmark>
          <name>MySMBShare</name>
          <path>smb://DOMAIN;username:password@MyWindowsServer/movies/</path>
          </bookmark>

          If you are still using XBMP I would recomend that you have a look at
          XMBC

          HTH
          /Mattias



          --- In nslu2-general@yahoogroups.com, "maisondouf" <maisondouf@...>
          wrote:
          >
          > Hi,
          >
          >
          > My problem was simple, before I bought a NSLU2 I have two big USB
          > drives pluged on my own PC.
          >
          > This PC assume to share the disk contents on my personnal network
          with
          > Windows XP sharing protocol.
          >
          > On this network, some Xbox are connected and with the Xbox Media
          > Player, they can read movies on the USB disk.
          >
          > They use the smb syntax to define the map point :
          >
          > smb://WORKGROUP/COMPUTER/SHARE
          >
          > and so without any problem...
          >
          > But now with the USB disks connected on the NSLU2, the Xbox can't
          > connect the disk due to indentification mistakes.
          >
          > It is impossible to make any modification in the Xbox software, so I
          > try to modify the samba server configuration in the NSLU2.
          >
          > In the 'smb.conf' file, the parameter 'security' is set to 'user' so
          > an identification is nedeed to connect shares.
          >
          > When you set this parameter to 'share', the samba server have the
          same
          > behaviour than an old PC with Windows 95 and the Xbox connect
          > correctly the sharing points.
          >
          > This modification of 'security' would be make after each boot of the
          > NSLU2, because the default setting is 'user'.
          >
          > You can include in the 'rc.1' file in '/etc/rc.d' this little line :
          >
          > sed -i 's/security \= \user/security \= \share/'
          > /share/hdd/conf/share/smb.conf
          >
          > You can put this at the end of the file or just after the line
          > containing : "Restore usrgrpshares:"
          >
          > It's run.
          >
          > Alain.
          >
        • Alain SAURAT
          ... Hi, first thanks for your answer. I have also installed XBMC on the xbox, but I never try with this syntax... I will try it this evening. Bye, Alain.
          Message 4 of 8 , May 23, 2008
            mattias__a a écrit :
            > Hi. I might be totally wrong here but wasn't the Xbox Media Player
            > project killed a few years ago and continued under the Xbox Media
            > Center project? If the software you are using on your xbox is in fact
            > XBMC (xbox media center) the syntax for authenticating smb-shares is
            >
            > <bookmark>
            > <name>MySMBShare</name>
            > <path>smb://DOMAIN;username:password@MyWindowsServer/movies/</path>
            > </bookmark>
            >
            > If you are still using XBMP I would recomend that you have a look at
            > XMBC
            >
            > HTH
            > /Mattias
            >
            >
            >
            > --- In nslu2-general@yahoogroups.com, "maisondouf" <maisondouf@...>
            > wrote:
            >
            >> Hi,
            >>
            >>
            >> My problem was simple, before I bought a NSLU2 I have two big USB
            >> drives pluged on my own PC.
            >>
            >> This PC assume to share the disk contents on my personnal network
            >>
            > with
            >
            >> Windows XP sharing protocol.
            >>
            >> On this network, some Xbox are connected and with the Xbox Media
            >> Player, they can read movies on the USB disk.
            >>
            >> They use the smb syntax to define the map point :
            >>
            >> smb://WORKGROUP/COMPUTER/SHARE
            >>
            >> and so without any problem...
            >>
            >> But now with the USB disks connected on the NSLU2, the Xbox can't
            >> connect the disk due to indentification mistakes.
            >>
            >> It is impossible to make any modification in the Xbox software, so I
            >> try to modify the samba server configuration in the NSLU2.
            >>
            >> In the 'smb.conf' file, the parameter 'security' is set to 'user' so
            >> an identification is nedeed to connect shares.
            >>
            >> When you set this parameter to 'share', the samba server have the
            >>
            > same
            >
            >> behaviour than an old PC with Windows 95 and the Xbox connect
            >> correctly the sharing points.
            >>
            >> This modification of 'security' would be make after each boot of the
            >> NSLU2, because the default setting is 'user'.
            >>
            >> You can include in the 'rc.1' file in '/etc/rc.d' this little line :
            >>
            >> sed -i 's/security \= \user/security \= \share/'
            >> /share/hdd/conf/share/smb.conf
            >>
            >> You can put this at the end of the file or just after the line
            >> containing : "Restore usrgrpshares:"
            >>
            >> It's run.
            >>
            >> Alain.

            Hi, first thanks for your answer.

            I have also installed XBMC on the xbox, but I never try with this syntax...

            I will try it this evening.

            Bye, Alain.
          • Alain SAURAT
            ... Hello, I work a big part of the night on the xbox and now all run fine. I have installed ccxstream in the NSLU2 with difficulty due to poor documentation
            Message 5 of 8 , May 24, 2008
              Alain SAURAT a écrit :
              > mattias__a a écrit :
              >
              >> Hi. I might be totally wrong here but wasn't the Xbox Media Player
              >> project killed a few years ago and continued under the Xbox Media
              >> Center project? If the software you are using on your xbox is in fact
              >> XBMC (xbox media center) the syntax for authenticating smb-shares is
              >>
              >> <bookmark>
              >> <name>MySMBShare</name>
              >> <path>smb://DOMAIN;username:password@MyWindowsServer/movies/</path>
              >> </bookmark>
              >>
              >> If you are still using XBMP I would recomend that you have a look at
              >> XMBC
              >>
              >> HTH
              >> /Mattias
              >>
              >>
              >>
              >> --- In nslu2-general@yahoogroups.com, "maisondouf" <maisondouf@...>
              >> wrote:
              >>
              >>
              >>> Hi,
              >>>
              >>>
              >>> My problem was simple, before I bought a NSLU2 I have two big USB
              >>> drives pluged on my own PC.
              >>>
              >>> This PC assume to share the disk contents on my personnal network
              >>>
              >>>
              >> with
              >>
              >>
              >>> Windows XP sharing protocol.
              >>>
              >>> On this network, some Xbox are connected and with the Xbox Media
              >>> Player, they can read movies on the USB disk.
              >>>
              >>> They use the smb syntax to define the map point :
              >>>
              >>> smb://WORKGROUP/COMPUTER/SHARE
              >>>
              >>> and so without any problem...
              >>>
              >>> But now with the USB disks connected on the NSLU2, the Xbox can't
              >>> connect the disk due to indentification mistakes.
              >>>
              >>> It is impossible to make any modification in the Xbox software, so I
              >>> try to modify the samba server configuration in the NSLU2.
              >>>
              >>> In the 'smb.conf' file, the parameter 'security' is set to 'user' so
              >>> an identification is nedeed to connect shares.
              >>>
              >>> When you set this parameter to 'share', the samba server have the
              >>>
              >>>
              >> same
              >>
              >>
              >>> behaviour than an old PC with Windows 95 and the Xbox connect
              >>> correctly the sharing points.
              >>>
              >>> This modification of 'security' would be make after each boot of the
              >>> NSLU2, because the default setting is 'user'.
              >>>
              >>> You can include in the 'rc.1' file in '/etc/rc.d' this little line :
              >>>
              >>> sed -i 's/security \= \user/security \= \share/'
              >>> /share/hdd/conf/share/smb.conf
              >>>
              >>> You can put this at the end of the file or just after the line
              >>> containing : "Restore usrgrpshares:"
              >>>
              >>> It's run.
              >>>
              >>> Alain.
              >>>
              >
              > Hi, first thanks for your answer.
              >
              > I have also installed XBMC on the xbox, but I never try with this syntax...
              >
              > I will try it this evening.
              >
              > Bye, Alain.
              >
              >
              > ------------------------------------
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
              >

              Hello, I work a big part of the night on the xbox and now all run fine.

              I have installed ccxstream in the NSLU2 with difficulty due to poor
              documentation on share, users and password but I obtain now that I wanted.

              In fact the version of Xbmc I have was very old ( 2003 ) and after
              installing the new one (2008) the xbms links are OK.

              I download also a skin 360 like for this soft and now all my childrens
              are happy.

              big thanks to all.

              Alain
            • m_firthows
              ... fact ... is ... ... smb://DOMAIN;username:password@MyWindowsServer/movies/ ... at ... network ... so I ... to user so ... the ...
              Message 6 of 8 , May 24, 2008
                --- In nslu2-general@yahoogroups.com, "mattias__a" <mattias__a@...>
                wrote:
                >
                > Hi. I might be totally wrong here but wasn't the Xbox Media Player
                > project killed a few years ago and continued under the Xbox Media
                > Center project? If the software you are using on your xbox is in
                fact
                > XBMC (xbox media center) the syntax for authenticating smb-shares
                is
                >
                >
                <bookmark>

                > <name>MySMBShare</name>
                >
                <path>smb://DOMAIN;username:password@MyWindowsServer/movies/</path>

                > </bookmark>
                >
                > If you are still using XBMP I would recomend that you have a look
                at
                > XMBC
                >
                > HTH
                > /Mattias
                >
                >
                >
                > --- In nslu2-general@yahoogroups.com, "maisondouf" <maisondouf@>
                > wrote:
                > >
                > > Hi,
                > >
                > >
                > > My problem was simple, before I bought a NSLU2 I have two big USB
                > > drives pluged on my own PC.
                > >
                > > This PC assume to share the disk contents on my personnal
                network
                > with
                > > Windows XP sharing protocol.
                > >
                > > On this network, some Xbox are connected and with the Xbox Media
                > > Player, they can read movies on the USB disk.
                > >
                > > They use the smb syntax to define the map point :
                > >
                > > smb://WORKGROUP/COMPUTER/SHARE
                > >
                > > and so without any problem...
                > >
                > > But now with the USB disks connected on the NSLU2, the Xbox can't
                > > connect the disk due to indentification mistakes.
                > >
                > > It is impossible to make any modification in the Xbox software,
                so I
                > > try to modify the samba server configuration in the NSLU2.
                > >
                > > In the 'smb.conf' file, the parameter 'security' is set
                to 'user' so
                > > an identification is nedeed to connect shares.
                > >
                > > When you set this parameter to 'share', the samba server have
                the
                > same
                > > behaviour than an old PC with Windows 95 and the Xbox connect
                > > correctly the sharing points.
                > >
                > > This modification of 'security' would be make after each boot of
                the
                > > NSLU2, because the default setting is 'user'.
                > >
                > > You can include in the 'rc.1' file in '/etc/rc.d' this little
                line :
                > >
                > > sed -i 's/security \= \user/security \= \share/'
                > > /share/hdd/conf/share/smb.conf
                > >
                > > You can put this at the end of the file or just after the line
                > > containing : "Restore usrgrpshares:"
                > >
                > > It's run.
                > >
                > > Alain.
                > >
                >

                what is your frob to i dont no
              Your message has been successfully submitted and would be delivered to recipients shortly.