Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Re: Problem with BST and File Synchronisation

Expand Messages
  • Carl Lowenstein
    ... Leave the PC set to UK Standard Time (which seems to be the same as UTC) and tell it not to change for Daylight Time. I think you can do this to Windows,
    Message 1 of 4 , Mar 31, 2008
    • 0 Attachment
      On 3/31/08, ian_jefferyes <nslu2@...> wrote:
      >
      > --- In nslu2-general@yahoogroups.com, "Carl Lowenstein"
      > <clowenstein@...> wrote:
      >
      > >
      > > On 3/31/08, ian_jefferyes <nslu2@...> wrote:
      > > >
      > > > Hi,
      > > >
      > > > I am using my NSLU2 for backing up all of my pictures, videos, music
      > > > etc and am using a program called SyncBack to do the copying.
      > > >
      > > > But the problem I am hitting is that since the clocks went
      > forward for
      > > > British Summer Time (BST), all of the files now say that they are an
      > > > hour out and therefore it is trying to copy them all again, aaahh!!
      > > >
      > > > Can someone tell me how I can get around this.
      > > >
      > > > I have tried playing with the time settings on the NSLU2 but these
      > > > seem to make no difference.
      > >
      > > Shouldn't you be keeping file times in UTC? That doesn't change with
      > > Summer Time. Maybe SyncBack is a Windows-centric program and doesn't
      > > know that file times should be kept in UTC, and displayed to the user
      > > in local time.
      > >
      > > carl
      > > --
      > > carl lowenstein
      > > marine physical lab, u.c. san diego
      > > clowenstein@...
      > >
      >
      > Yes, SyncBack is a Windows based program as it is running on my
      > Windows based PC (sorry) and having had a quick look on the internet
      > for UTC I think you are spot on.
      >
      > Am I right in thinking that there is nothing then on the NSLU2 that
      > can be done to change the time of the files? Therefore this leaves me
      > with two options.
      >
      > 1. As you suggest use UTC on the PC and manually set the time.
      > (although I have just tried this and all of my files are still an hour
      > out so will need to be copied again).
      > 2. Change the Sync so it ignores differences in files of up to an
      > hour. (Horrible but will work)
      >

      Leave the PC set to UK Standard Time (which seems to be the same as
      UTC) and tell it not to change for Daylight Time. I think you can do
      this to Windows, but I don't do windows very much.

      Can you ask the NSLU2 what time it thinks it is? Unix commands would be

      date # date and time in local zone
      date -u # date and time in UTC

      carl

      --
      carl lowenstein
      marine physical lab, u.c. san diego
      clowenstein@...
    Your message has been successfully submitted and would be delivered to recipients shortly.