Loading ...
Sorry, an error occurred while loading the content.

Slow NSLU2 generating "wrong" TCP packets

Expand Messages
  • mullasci
    I ve just got an NSLU2 and updated it to R63. When making transfers from it using FTP I get very slow transfer rates (about 5mbit/s). This happens both if the
    Message 1 of 1 , Dec 3, 2007
    • 0 Attachment
      I've just got an NSLU2 and updated it to R63.
      When making transfers from it using FTP I get very slow transfer rates
      (about 5mbit/s).
      This happens both if the receiving machine uses a wired network
      (100mbit) connection and a wireless (802.11b) connection.
      Using SMB does not seems faster at all: about 1/2 an hour for 700MB

      Using wireshark on the destination machine I noticed a lot of "TCP
      segment of a reassembled PDU" looking around i found a post stating
      that this may be related to the speed problem.
      http://www.ethereal.com/lists/ethereal-users/200604/msg00032.html

      The NSLU2 is connected directly to a Gigabit unmanaged switch that
      connects to a DWL2000+ for the wireless connection.
      So the wired chain is: NSLU2->GE switch->eth-usb adapter->notebook
      (built-in network died)
      The wireless chain is: NSLU2->GE switch->DWL2000+ ->notebook
      (integrated intel 2100)

      Speed getting the data with my MacMini is in the same league.

      The NSLU2 is connected to a Maxtor OneTouch III mini edition that in
      my office runs at about 22MBytes/s when connected to the desktop.

      Any suggestion for fix or additional checks is welcome

      Thanks
      Marco
    Your message has been successfully submitted and would be delivered to recipients shortly.