Loading ...
Sorry, an error occurred while loading the content.
 

Assistance please

Expand Messages
  • Richard
    I now have a slug, and trying to get Debian running on it. Albeit with no success. I was trying to use it for a commercial application, but that will not
    Message 1 of 11 , Sep 27, 2007
      I now have a slug, and trying to get Debian running on it.
      Albeit with no success.
      I was trying to use it for a commercial application, but that will not
      happen now. The company I was contracted to did not like linux, or me
      working on it. So I got shown the door.
      So its home use for the slug.
      Either a print server or firewall.

      IYO which are the best OS's to use for either application ?


      --

      Best Wishes

      Richard Bown

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      Registered Linux User 365161
      OS Mandriva 2007.1
      HAM Callsign G8JVM : Locator IO82SP
      QRV all bands 80mtrs to 3 cms ,( non WARC )
      http://www.software-radio.org.uk
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • Sean Gibbins
      ... Of what little I know other the alternatives available for the Slug I can t imagine that you ll go far wrong with Debian for either of these applications.
      Message 2 of 11 , Sep 27, 2007
        Richard wrote:
        >
        > I now have a slug, and trying to get Debian running on it.
        > Albeit with no success.
        > I was trying to use it for a commercial application, but that will not
        > happen now. The company I was contracted to did not like linux, or me
        > working on it. So I got shown the door.
        > So its home use for the slug.
        > Either a print server or firewall.
        >
        > IYO which are the best OS's to use for either application ?
        >












        Of what little I know other the alternatives available for the Slug I
        can't imagine that you'll go far wrong with Debian for either of these
        applications. Go for a minimal install and layer on only those
        applications you need.

        There is an excellent HOWTO here:

        http://www.cyrius.com/debian/nslu2/install.html

        I only encountered one issue, and that was not with the HOWTO but
        something that caused a package to not install correctly first time and
        return an error from the Debian installer. I re-ran that particular
        component of the installation process and all was well.

        BTF/Sean
      • Richard
        On Thu, 27 Sep 2007 09:20:20 +0100 ... ... Hi Sean, thanks for the info. At least now working at home in a windows free area, getting and compiling
        Message 3 of 11 , Sep 27, 2007
          On Thu, 27 Sep 2007 09:20:20 +0100
          Sean Gibbins <sean@...> wrote:

          > Richard wrote:
          > >
          > > I now have a slug, and trying to get Debian running on it.
          > > Albeit with no success.
          <snip>
          >
          > Of what little I know other the alternatives available for the Slug I
          > can't imagine that you'll go far wrong with Debian for either of these
          > applications. Go for a minimal install and layer on only those
          > applications you need.
          >
          > There is an excellent HOWTO here:
          >
          > http://www.cyrius.com/debian/nslu2/install.html
          >
          > I only encountered one issue, and that was not with the HOWTO but
          > something that caused a package to not install correctly first time
          > and return an error from the Debian installer. I re-ran that
          > particular component of the installation process and all was well.
          >
          > BTF/Sean

          Hi Sean, thanks for the info.
          At least now working at home in a windows free area, getting and
          compiling upslug was not a problem.
          I've flashed the installer, the non official one with the ethernet
          driver included, but downloading the image is failing.
          I've got a 8 GB flash drive which has been partitioned and formatted,
          however I cant label the partitions as the names clash with those on the
          host machine.
          After several attempts to down load I've manually
          edited /etc/resolv.conf with a address of a name server and used the ip
          address of the mirror, and at the moment its downloading, got half way
          through partitioning and dropped the link to the host computer.
          First time around the install got all the way to loading the kernel and
          borked. the next time it installed, its still adding packages..
          --

          Best Wishes

          Richard Bown

          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          Registered Linux User 365161
          OS Mandriva 2007.1
          HAM Callsign G8JVM : Locator IO82SP
          QRV all bands 80mtrs to 3 cms ,( non WARC )
          http://www.software-radio.org.uk
          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        • Richard
          Hi all I ve now got Debian I think running on my slug. The installation has all been on the same host computer, but I m locked out of access to the slug, on
          Message 4 of 11 , Sep 28, 2007
            Hi all
            I've now got Debian I think running on my slug.

            The installation has all been on the same host computer, but I'm locked
            out of access to the slug, on all accounts , root, user and installer
            with this :-
            [root@gb7tf Desktop]# ssh installer@192.168.1.77
            @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
            @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
            @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
            IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
            Someone could be eavesdropping on you right now (man-in-the-middle
            attack)! It is also possible that the RSA host key has just been
            changed. The fingerprint for the RSA key sent by the remote host is
            56:48:4c:7e:ac:56:41:89:b0:87:32:a8:ca:36:b0:da.
            Please contact your system administrator.
            Add correct host key in /root/.ssh/known_hosts to get rid of this
            message. Offending key in /root/.ssh/known_hosts:1
            Password authentication is disabled to avoid man-in-the-middle attacks.
            Keyboard-interactive authentication is disabled to avoid
            man-in-the-middle attacks. X11 forwarding is disabled to avoid
            man-in-the-middle attacks. Permission denied
            (publickey,password,keyboard-interactive).

            I cant Telnet in either, or ftp

            Anyone any ideas how I can get in and sort it out.
            The OS is loaded on a 8 GB flash pen.
            I've tried looking at the flash drive contents on the host computer,
            but I cant see the /home directories or /root.


            Anyone any bright ideas of getting in , or is it a reinstall ??

            TIA










            Best Wishes

            Richard Bown

            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
            Registered Linux User 365161
            OS Mandriva 2007.1
            HAM Callsign G8JVM : Locator IO82SP
            QRV all bands 80mtrs to 3 cms ,( non WARC )
            http://www.software-radio.org.uk
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          • Rod Whitby
            ... This is normal for SSH when you change the host key on the target IP address. Do what the message says, and remove the host key corresponding to the
            Message 5 of 11 , Sep 28, 2007
              Richard wrote:
              > I've now got Debian I think running on my slug.
              >
              > The installation has all been on the same host computer, but I'm locked
              > out of access to the slug, on all accounts , root, user and installer
              > with this :-
              > [root@gb7tf Desktop]# ssh installer@192.168.1.77
              > @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
              > @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
              > @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
              > IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
              > Someone could be eavesdropping on you right now (man-in-the-middle
              > attack)! It is also possible that the RSA host key has just been
              > changed. The fingerprint for the RSA key sent by the remote host is
              > 56:48:4c:7e:ac:56:41:89:b0:87:32:a8:ca:36:b0:da.
              > Please contact your system administrator.
              > Add correct host key in /root/.ssh/known_hosts to get rid of this
              > message. Offending key in /root/.ssh/known_hosts:1

              This is normal for SSH when you change the host key on the target IP
              address. Do what the message says, and remove the host key
              corresponding to the slug's IP address from your /root/.ssh/known_hosts
              file (delete the file if you like - it is recreated each time you accept
              a new host key).

              -- Rod
            • Sean Gibbins
              ... The file /etc/ssh/sshd_config should allow you to change the entry within it that will allow password authentication, which if memory serves will currently
              Message 6 of 11 , Sep 28, 2007
                Richard wrote:
                >
                >
                >
                > I cant Telnet in either, or ftp
                >
                > Anyone any ideas how I can get in and sort it out.
                > The OS is loaded on a 8 GB flash pen.
                > I've tried looking at the flash drive contents on the host computer,
                > but I cant see the /home directories or /root.
                >
                > Anyone any bright ideas of getting in , or is it a reinstall ??
                >













                The file /etc/ssh/sshd_config should allow you to change the entry
                within it that will allow password authentication, which if memory
                serves will currently look like this:

                # Change to no to disable tunnelled clear text passwords
                PasswordAuthentication no

                What user are you ssh'ing to the box with? It looks like root: have you
                tried <normal_user>@<ip_address>? See if you can get in as the normal
                user and then su to root if needs be.

                I'm a bit baffled that you can't find /root or /home after the base
                install, and also by the fact that Debian is so strict about default ssh
                access, since I recall having to explicitly lock my sshd down to achieve
                the situation you are currently in!

                Did you define a user during your installation, and how was the disk
                partitioned?
              • Rod Whitby
                ... The message is referring to /root/.ssh/known_hosts on the machine at which you are typing the ssh command, *not* on the slug. -- Rod
                Message 7 of 11 , Sep 28, 2007
                  Sean Gibbins wrote:
                  > Richard wrote:
                  >> I've tried looking at the flash drive contents on the host computer,
                  >> but I cant see the /home directories or /root.
                  >
                  > I'm a bit baffled that you can't find /root or /home after the base
                  > install, and also by the fact that Debian is so strict about default ssh
                  > access, since I recall having to explicitly lock my sshd down to achieve
                  > the situation you are currently in!

                  The message is referring to /root/.ssh/known_hosts on the machine at
                  which you are typing the ssh command, *not* on the slug.

                  -- Rod
                • Richard
                  On Fri, 28 Sep 2007 17:18:19 +0930 ... Thanks Rod, slapped wrists I should have remembered that. The user accounts set up on install aren t there, the only way
                  Message 8 of 11 , Sep 28, 2007
                    On Fri, 28 Sep 2007 17:18:19 +0930
                    Rod Whitby <rod@...> wrote:


                    >
                    > This is normal for SSH when you change the host key on the target IP
                    > address. Do what the message says, and remove the host key
                    > corresponding to the slug's IP address from
                    > your /root/.ssh/known_hosts file (delete the file if you like - it is
                    > recreated each time you accept a new host key).
                    >
                    > -- Rod

                    Thanks Rod, slapped wrists I should have remembered that.
                    The user accounts set up on install aren't there, the only way I can
                    get in is to login as installer and drop to a shell.
                    However, there is no /home directories, and no adduser command
                    I can create a /home but without the passwd command

                    and
                    ~ # df
                    Filesystem 1k-blocks Used Available Use% Mounted on
                    tmpfs 14992 372 14620 2% /dev
                    tmpfs 14992 372 14620 2% /dev
                    tmpfs 14992 372 14620 2% /.dev

                    So the 8 GB flash memory stick isn't mounted.
                    I'll try another install and see if this time it will let me gain full
                    access.

                    Thanks
                    --

                    Best Wishes

                    Richard Bown

                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                    Registered Linux User 365161
                    OS Mandriva 2007.1
                    HAM Callsign G8JVM : Locator IO82SP
                    QRV all bands 80mtrs to 3 cms ,( non WARC )
                    http://www.software-radio.org.uk
                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                  • Rod Whitby
                    ... Note that the Debian 4.0 repository seems to be in a state which makes the Debian 4.0 installer not work. Martin is working on a new installer binary. In
                    Message 9 of 11 , Sep 28, 2007
                      Richard wrote:
                      > I'll try another install and see if this time it will let me gain full
                      > access.

                      Note that the Debian 4.0 repository seems to be in a state which makes
                      the Debian 4.0 installer not work. Martin is working on a new installer
                      binary. In the mean-time you have to use some expert mode to get it to
                      work - details are in the debian-arm mailing list (where all
                      Debian/NSLU2 questions should be asked and answered).

                      -- Rod
                    • Richard
                      On Fri, 28 Sep 2007 20:35:07 +0930 ... OK Rod Am I using the wrong list to ask question s then,,,sorry I ve reinstalled and now it looks like its working, did
                      Message 10 of 11 , Sep 28, 2007
                        On Fri, 28 Sep 2007 20:35:07 +0930
                        Rod Whitby <rod@...> wrote:

                        > Richard wrote:
                        > > I'll try another install and see if this time it will let me gain
                        > > full access.
                        >
                        > Note that the Debian 4.0 repository seems to be in a state which makes
                        > the Debian 4.0 installer not work. Martin is working on a new
                        > installer binary. In the mean-time you have to use some expert mode
                        > to get it to work - details are in the debian-arm mailing list (where
                        > all Debian/NSLU2 questions should be asked and answered).
                        >
                        > -- Rod
                        OK Rod


                        Am I using the wrong list to ask question s then,,,sorry
                        I've reinstalled and now it looks like its working, did get a proper
                        login .
                        But that took two attempts, first time the kernel refused to load,
                        second time OK.
                        I did try unpacking the tar ball directly on to the flash drive, but it
                        did not want to play.

                        thanks for the pointers

                        --

                        Best Wishes

                        Richard Bown

                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                        Registered Linux User 365161
                        OS Mandriva 2007.1
                        HAM Callsign G8JVM : Locator IO82SP
                        QRV all bands 80mtrs to 3 cms ,( non WARC )
                        http://www.software-radio.org.uk
                        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                      • Sean Gibbins
                        ... Doh! Engage brain before typing! Cheers Rod, Sean
                        Message 11 of 11 , Sep 28, 2007
                          Rod Whitby wrote:
                          >
                          > Sean Gibbins wrote:
                          > > Richard wrote:
                          > >> I've tried looking at the flash drive contents on the host computer,
                          > >> but I cant see the /home directories or /root.
                          > >
                          > > I'm a bit baffled that you can't find /root or /home after the base
                          > > install, and also by the fact that Debian is so strict about default ssh
                          > > access, since I recall having to explicitly lock my sshd down to achieve
                          > > the situation you are currently in!
                          >
                          > The message is referring to /root/.ssh/known_hosts on the machine at
                          > which you are typing the ssh command, *not* on the slug.
                          >


















                          Doh! Engage brain before typing!

                          Cheers Rod,

                          Sean
                        Your message has been successfully submitted and would be delivered to recipients shortly.