Loading ...
Sorry, an error occurred while loading the content.

Re:Unable to Format flash - trying to upgrade to 6.8 or at least run 5.

Expand Messages
  • akameswaran
    Thanks for this, Jorge. I had already tried going through the steps in how to troubleshoot drive missing condition, and the drive wasn t even mountable. The
    Message 1 of 2 , Sep 16, 2007
    • 0 Attachment
      Thanks for this, Jorge.

      I had already tried going through the steps in how to troubleshoot
      drive missing condition, and the drive wasn't even mountable.

      The kinda wonky thing is. I used fdisk to partition again, and
      format. For some reason, my slug treated the partitions in the
      expected order this time. I'm not sure if there is some possible race
      condition that causes the nslu2 to mount partitions in a different
      order sometimes?

      Anyway. Late at night, I made a mistake and nuked my hard drive.
      (big difference between tar -cvf and -xvf - but they can look a lot
      alike at 1 am) So i went a head and unslung to the memory stick even
      with it's odd behavior. Basically right now, as long as I have both
      drives plugged in (1GB mem, and 100GB seagate) when the slug boots, It
      runs off the mem stick, and the hd is fine. If I change the
      connection at any time, or disconnect a drive - all hell breaks loose.
      But it's working.

      This is with 5.5. I'll have to upgrade to 6.8 once I fill up my 100GB
      drive - cuz I'll need to use a hub. Until then, i'm going to leave
      well enough alone.

      Oh I btw stopped running twonky - couldn't get flac to work through
      it... and my ps3 doesn't decode flac natively. So installed linux on
      the ps3 and just use the slug as a file server. I realized in my
      house, all my devices are linux boxes at some level or other, so I
      don't really need anything but a file server. Somehow it all feels so
      low tech.


      --- In nslu2-general@yahoogroups.com, Jorge Ruiz <jorgeree@...> wrote:
      > I had the same problem with 3 1GB memory sticks of different brands
      and this is the only thing that worked for me:
      > "I wanted to use disk1 to unsling. Disk1 was already formatted by
      the NSLU, but not recognized if plugged in after NSLU boot.
      > Firmware: V2.3R63. uNSLUng 6.8 beta.
      > The way I was able to unsling:
      > 1)boot without disk
      > 2)telnet to NSLU
      > 3)attach disk (disk is powered off)
      > 4)power on disk
      > 5)type 'mount -t ext3 /dev/sdb1 /mnt/tmpmnt'. => you should see your
      data there
      > 6)type 'umount /mnt/tmpmnt'
      > 7)type 'mount -t ext3 /dev/sdb1 /share/hdd/data'
      > 8)type 'mount -t ext3 /dev/sdb2 /share/hdd/conf'
      > 9)reload the web-interface => you should see your disk there on port 1
      > 10)proceed to unsling as described in the readme (in my case I had
      to type '/sbin/unsling disk1')
      > (replace sdb* with sda* and 'hdd' with 'flash' (e.g. /share/hdd/data
      becomes /share/flash/data) if you want to use disk2 instead of disk1)"
      > I extracted it from:
      > where you can find a lot more information about this topic.
      > Here is another place where you can find more interesting things
      about the same:
      > http://www.nslu2-linux.org/wiki/Unslung/FailedFormatFix
      > I hope it helps you. By the way, you can unsling to either port 1
      or port 2 indistinctly when using unslung 6.8.
      > Regards
      > Jorge
      > --- In nslu2-general@yahoogroups.com, "akameswaran" <akameswaran@>
      > >
      > > Ok,
      > > So I'm fairly new to my slug, but got Unslung 5.5 with Twonky running
      > > fairly easily.
      > >
      > > I had a single hd connected to the slug, and now I want to switch to
      > > using a flash as root, and my media files elsewhere. i have a small I
      > > am confident in being able to move the twonky db onto the HD and also
      > > get to install onto disk instead of ram, if I can get this working.
      > >
      > > I have a 1GB memorex travelDrive that I want to use for my root
      > > filesystem.
      > >
      > > I followed the instructions on the wiki to manually format my usb
      > >
      > > So I can get through the entire process, and end up with a "formatted"
      > > drive. An oddity is that the slug (which could see the flash in
      > > either drive before the repartition) will only see the usbstick if it
      > > is plugged in when I turn on the slug. Otherwise all I get is not
      > > installed, regardless of port. Additionally, this only works on port
      > > 1, port 2 never recognizes it anymore (and isn't that the 'flash'
      > >
      > > Here's another oddity. After the default wiki steps didn't work.
      > > What I notived, was while with fdisk linked to a fake script, the
      > > interface would return "formatted" but upon reboot it always showed
      > > unformatted. I decided I would actually let the slug "format" the
      > > disk. So I restored fdisk in /sbin and let the slug format my memory
      > > stick while in port 1. This succeeded, and every reboot showed it as
      > > "formatted"
      > >
      > > However, when I mounted both my usb stick, and my previous root drive
      > > (a seagate external USB) I noticed that the contents of partition1 on
      > > the hard drive matched to partition 2 on the stick. And vice versa.
      > > Both had partition 3 as swap, obviously. So I tried doing an exact
      > > copy of the partition from the hd to the usb. Due to the media files
      > > being on the root partition, I had to use cpio as opposed to dd
      > >
      > > Anyway... when i did this I treated the partitions on the memory stick
      > > as if they were used the same way my hd was. Ie partition 1 to
      > > partition 1. Even though the slug had set them up backward, there was
      > > no way I was going to waste the mem stick by having an 800 meg config
      > > partition.
      > >
      > > SO anyway, after doing this my memory stick is now "unformatted" and I
      > > couldn't use it to boot back into unslung 5.5. I had hoped by doing a
      > > partition copy it would work, but apparently I was wrong.
      > >
      > > I'm not sure if I should try and repartition the mem stick to one big
      > > FAT partition, just to see if I can get it recognized in port 2 again.
      > > Or whether it might be better to repartition it, but reverse the
      > > sizes of partition 1 and 2 to mirror the (to my eyes) backwards way
      > > the nslu2 had formatted. I suppose the third option is follow the
      > > wiki to the letter, but the fact that the slug showed the drive as
      > > "unformatted" and I couldn't read it in port 2, kind made me nervous
      > > to proceed on that path.
      > >
      > > Any suggestions? I have scoured the wiki and can't find anything else
      > > to try.
      > >
      > > Hmmm, last minute things that might matter.
      > > I have de-underclocked my slug.
      > >
      > > Twonky is currently in ram, but I intend to swap to disk when I do a
      > > cleanupgrade to 6.8. I just want to confirm the memstick can work
      > > before I try.
      > >
      > > The only other pkg's installed are ipkg and python.
      > >
      > >
      > >
      > >
      > > Thanks,
      > >
      > > AK
      > >
      > ---------------------------------
      > ¡Sé un mejor fotógrafo!
      > Perfecciona tu técnica y encuentra las mejores fotos en:
      > http://mx.yahoo.com/promos/mejorambientalista.html
      > [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.