Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-general] Re: DiversionScripts Information - Telnet

Expand Messages
  • Mike (mwester)
    A diversion script can only divert an existing rc script -- and there is no rc.xinetd startup script to divert. I expect that you are trying to divert the
    Message 1 of 3 , Aug 5 6:24 PM
    • 0 Attachment
      A diversion script can only "divert" an existing rc script -- and there is
      no rc.xinetd startup script to divert. I expect that you are trying to
      divert the rc.inetd script instead, so the script that you would place into
      /unslung would be named rc.inetd not rc.xinetd.

      If you are working from instructions on the wiki, can you edit the page to
      correct this?

      Thanks,
      Mike (mwester)


      ----- Original Message -----
      From: "carlos_b_hernandez" <carlos_b_hernandez@...>
      To: <nslu2-general@yahoogroups.com>
      Sent: Friday, August 03, 2007 3:46 PM
      Subject: [nslu2-general] Re: DiversionScripts Information - Telnet


      I am having the same issue with vsftpd. I can not get rc.xinetd
      diversion script to work. Please let me know if you resolve your
      issue and how?
      --- In nslu2-general@yahoogroups.com, "fpapia" <fpapia@...> wrote:
      >
      > I want telnet to run automatically when I boot the box.
      >
      > I am running UnSlung 6.x
      >
      > I placed the following script in the /unslung directory.
      >
      > #! /bin/sh
      > if ( [ ! -f /etc/inetd.conf ] || !(grep telnetd /etc/inetd.conf -
      q) ) then
      > echo "telnet stream tcp nowait root /usr/sbin/telnetd"
      >> /etc/inetd.conf
      > fi
      > return 1
      >
      > The script is called rc.xinetd.
      >
      > All this is according to the DiversionScripts information in the
      wiki.
      >
      > I placed a diversion script called rc.local in the /unslung
      directory.
      >
      > The rc.local script creates a directory called /public/junk1.
      >
      > When the box is power cycled the rc.local script works just fine as
      a
      > directory called junk1 appears in the /public directory but I still
      > have to use the web interface to get the telnet enabled.
      >
      > I verified the existence of /etc/inetd.conf and /usr/sbin/telnetd.
      >
      > What am I doing wrong?
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.